aboutsummaryrefslogtreecommitdiff
path: root/misc/freeguide/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-08-04 14:26:16 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-08-04 14:26:16 +0000
commitdbb6f034ef8ae08b27d8ac201458c4e491bf3e29 (patch)
tree445a4dd224fde256d5801b474107d9e9856bebff /misc/freeguide/Makefile
parent4ac21fed118dfc38612e3d539e4453a60c34afd3 (diff)
downloadports-dbb6f034ef8ae08b27d8ac201458c4e491bf3e29.tar.gz
ports-dbb6f034ef8ae08b27d8ac201458c4e491bf3e29.zip
Notes
Diffstat (limited to 'misc/freeguide/Makefile')
-rw-r--r--misc/freeguide/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/misc/freeguide/Makefile b/misc/freeguide/Makefile
index fcf697839b74..979d37de836e 100644
--- a/misc/freeguide/Makefile
+++ b/misc/freeguide/Makefile
@@ -3,12 +3,10 @@
# Whom: Stephen Hurd <shurd@sasktel.net>
#
# $FreeBSD$
-# $Carpetsmoker: ports/misc/freeguide/Makefile,v 1.1 2007/10/12 12:28:45 carpetsmoker Exp $
#
PORTNAME= freeguide
-PORTVERSION= 0.10.6
-PORTREVISION= 2
+PORTVERSION= 0.11
CATEGORIES= misc java
MASTER_SITES= SF/${PORTNAME}-tv/${PORTNAME}-source/${PORTVERSION}
@@ -17,6 +15,8 @@ COMMENT= An interactive TV guide which will create personalized TV listings
RUN_DEPENDS= tv_cat:${PORTSDIR}/textproc/p5-xmltv
+LICENSE= GPLv2
+
USE_JAVA= yes
USE_JIKES= no
JAVA_VERSION= 1.4+
@@ -32,14 +32,12 @@ MAKE_ARGS= -Dinstall_share_dir=${PREFIX}/share \
-Dinstall_doc_dir=${DOCSDIR} \
-Dinstall_java_share_dir=${JAVASHAREDIR} \
-Dinstall_jar_dir=${JAVAJARDIR}/freeguide
-INSTALL_TARGET= install-linux
+INSTALL_TARGET= install
post-patch:
@${REINPLACE_CMD} 's|__ANT_INSTALL_DIRECTORY__|${JAVAJARDIR}/freeguide|; \
s|=java|=${JAVA}|;' \
${WRKSRC}/install/linux/freeguide
- @${REINPLACE_CMD} 's|install_share_dir}/man|install_man1_dir}/man|g' \
- ${WRKSRC}/ant/install-linux.xml
do-install:
@(cd ${BUILD_WRKSRC}; \