aboutsummaryrefslogtreecommitdiff
path: root/misc/freeswitch-scripts
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2010-08-14 19:06:13 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2010-08-14 19:06:13 +0000
commitfe700dba47e0d0e5db0aa5e9a2f9d616765bbf92 (patch)
tree3b063ae9231ac691f3e071adb60fba332e6244c5 /misc/freeswitch-scripts
parentf852571faa1548702ca0db292a9461c481ce6102 (diff)
downloadports-fe700dba47e0d0e5db0aa5e9a2f9d616765bbf92.tar.gz
ports-fe700dba47e0d0e5db0aa5e9a2f9d616765bbf92.zip
Notes
Diffstat (limited to 'misc/freeswitch-scripts')
-rw-r--r--misc/freeswitch-scripts/Makefile76
-rw-r--r--misc/freeswitch-scripts/distinfo3
-rw-r--r--misc/freeswitch-scripts/pkg-descr1
-rw-r--r--misc/freeswitch-scripts/pkg-plist89
4 files changed, 169 insertions, 0 deletions
diff --git a/misc/freeswitch-scripts/Makefile b/misc/freeswitch-scripts/Makefile
new file mode 100644
index 000000000000..96a1ab0dabe4
--- /dev/null
+++ b/misc/freeswitch-scripts/Makefile
@@ -0,0 +1,76 @@
+# Ports collection makefile for: freeswitch scripts
+# Date created: september , 2009
+# Whom: Richard Neese <r.neese@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= freeswitch-scripts
+PORTVERSION= 1.0.6
+CATEGORIES= misc
+MASTER_SITES= http://files.freeswitch.org/
+DISTNAME= ${BASE_PORTNAME}-${PORTVERSION}
+
+MAINTAINER= r.neese@gmail.com
+COMMENT= FreeSwitch Scripts
+
+RUN_DEPENDS+= ${LOCALBASE}/bin/freeswitch:${PORTSDIR}/net/freeswitch-core
+
+NO_BUILD= yes
+BASE_PORTNAME= freeswitch
+
+WRKSRC= ${WRKDIR}/${BASE_PORTNAME}-${PORTVERSION}/scripts/
+
+OPTIONS= JAVASCRIPT "Install FreeSWITCH JAVASCRIPTS" off \
+ PERL "Install FreeSWITCH Perl Scripts" off \
+ PYTHON "Install FreeSWITCH Python Scripts" off \
+ PHP "Install FreeSWITCH PHP Scripts" off \
+ RSS "Install FreeSWITCH RSS Scripts" off \
+ LUA "Install FreeSWITCH LUA Scripts" off
+
+.include <bsd.port.options.mk>
+
+.for i in JAVASCRIPT PERL PYTHON PHP RSS LUA C
+.if !defined(WITH_${i})
+PLIST_SUB+= WITH_${i}="@comment "
+.else
+PLIST_SUB+= WITH_${i}=""
+.endif
+.endfor
+
+do-install:
+.if defined(WITH_JAVASCRIPT)
+ @${RM} ${WRKSRC}/javascript/ps_pizza.js
+ @${RM} ${WRKSRC}/javascript/pizza.js
+ @${RM} -rf ${WRKSRC}/javascript/js_modules
+ @cd ${WRKSRC}; ${FIND} javascript \
+ | ${CPIO} -pdm -R freeswitch:freeswitch ${PREFIX}/etc/${BASE_PORTNAME}/scripts
+.endif
+
+.if defined(WITH_PERL)
+ @cd ${WRKSRC}; ${FIND} perl \
+ | ${CPIO} -pdm -R freeswitch:freeswitch ${PREFIX}/etc/${BASE_PORTNAME}/scripts
+.endif
+
+.if defined(WITH_PYTHON)
+ @cd ${WRKSRC}; ${FIND} python \
+ | ${CPIO} -pdm -R freeswitch:freeswitch ${PREFIX}/etc/${BASE_PORTNAME}/scripts
+
+.endif
+
+.if defined(WITH_PHP)
+ @cd ${WRKSRC}; ${FIND} php \
+ | ${CPIO} -pdm -R freeswitch:freeswitch ${PREFIX}/etc/${BASE_PORTNAME}/scripts
+.endif
+
+.if defined(WITH_RSS)
+ @cd ${WRKSRC}; ${FIND} rss \
+ | ${CPIO} -pdm -R freeswitch:freeswitch ${PREFIX}/etc/${BASE_PORTNAME}/scripts
+.endif
+
+.if defined(WITH_LUA)
+ @cd ${WRKSRC}; ${FIND} lua \
+ | ${CPIO} -pdm -R freeswitch:freeswitch ${PREFIX}/etc/${BASE_PORTNAME}/scripts
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/freeswitch-scripts/distinfo b/misc/freeswitch-scripts/distinfo
new file mode 100644
index 000000000000..7dbf3ccf30ec
--- /dev/null
+++ b/misc/freeswitch-scripts/distinfo
@@ -0,0 +1,3 @@
+MD5 (freeswitch-1.0.6.tar.gz) = 388effee587887a81fe7f411b7350590
+SHA256 (freeswitch-1.0.6.tar.gz) = 5610f478307b5c06d38e1ea4029298142c2960e426c3297378857d8734770215
+SIZE (freeswitch-1.0.6.tar.gz) = 36400963
diff --git a/misc/freeswitch-scripts/pkg-descr b/misc/freeswitch-scripts/pkg-descr
new file mode 100644
index 000000000000..f845ee578626
--- /dev/null
+++ b/misc/freeswitch-scripts/pkg-descr
@@ -0,0 +1 @@
+port for Various Freeswitch scripts .
diff --git a/misc/freeswitch-scripts/pkg-plist b/misc/freeswitch-scripts/pkg-plist
new file mode 100644
index 000000000000..392120ef823b
--- /dev/null
+++ b/misc/freeswitch-scripts/pkg-plist
@@ -0,0 +1,89 @@
+%%WITH_JAVASCRIPT%%etc/freeswitch/scripts/javascript/aadir/README
+%%WITH_JAVASCRIPT%%etc/freeswitch/scripts/javascript/aadir/aadir.js
+%%WITH_JAVASCRIPT%%etc/freeswitch/scripts/javascript/api.js
+%%WITH_JAVASCRIPT%%etc/freeswitch/scripts/javascript/dtmftest.js
+%%WITH_LUA%%etc/freeswitch/scripts/lua/api.lua
+%%WITH_LUA%%etc/freeswitch/scripts/lua/callback.lua
+%%WITH_LUA%%etc/freeswitch/scripts/lua/helloworld.lua
+%%WITH_LUA%%etc/freeswitch/scripts/lua/mwi_event.lua
+%%WITH_LUA%%etc/freeswitch/scripts/lua/originate.lua
+%%WITH_LUA%%etc/freeswitch/scripts/lua/zrtp_agent.lua
+%%WITH_PERL%%etc/freeswitch/scripts/perl/FreeSWITCH-GizmoConfig.pl
+%%WITH_PERL%%etc/freeswitch/scripts/perl/FreeSWITCH/ChangeLog
+%%WITH_PERL%%etc/freeswitch/scripts/perl/FreeSWITCH/Client.pm
+%%WITH_PERL%%etc/freeswitch/scripts/perl/FreeSWITCH/Makefile.PL
+%%WITH_PERL%%etc/freeswitch/scripts/perl/FreeSWITCH/README
+%%WITH_PERL%%etc/freeswitch/scripts/perl/FreeSWITCH/debian/changelog
+%%WITH_PERL%%etc/freeswitch/scripts/perl/FreeSWITCH/debian/compat
+%%WITH_PERL%%etc/freeswitch/scripts/perl/FreeSWITCH/debian/control
+%%WITH_PERL%%etc/freeswitch/scripts/perl/FreeSWITCH/debian/copyright
+%%WITH_PERL%%etc/freeswitch/scripts/perl/FreeSWITCH/debian/rules
+%%WITH_PERL%%etc/freeswitch/scripts/perl/POE-Filter-FSSocket/CHANGES
+%%WITH_PERL%%etc/freeswitch/scripts/perl/POE-Filter-FSSocket/INSTALL
+%%WITH_PERL%%etc/freeswitch/scripts/perl/POE-Filter-FSSocket/LICENSE
+%%WITH_PERL%%etc/freeswitch/scripts/perl/POE-Filter-FSSocket/Makefile.PL
+%%WITH_PERL%%etc/freeswitch/scripts/perl/POE-Filter-FSSocket/README
+%%WITH_PERL%%etc/freeswitch/scripts/perl/POE-Filter-FSSocket/TODO
+%%WITH_PERL%%etc/freeswitch/scripts/perl/POE-Filter-FSSocket/examples/fsconsole.pl
+%%WITH_PERL%%etc/freeswitch/scripts/perl/POE-Filter-FSSocket/examples/poetest.pl
+%%WITH_PERL%%etc/freeswitch/scripts/perl/POE-Filter-FSSocket/lib/POE/Filter/FSSocket.pm
+%%WITH_PERL%%etc/freeswitch/scripts/perl/POE-Filter-FSSocket/t/01_basic.t
+%%WITH_PERL%%etc/freeswitch/scripts/perl/call.cgi
+%%WITH_PERL%%etc/freeswitch/scripts/perl/combineconf.pl
+%%WITH_PERL%%etc/freeswitch/scripts/perl/dhcp-inform.pl
+%%WITH_PERL%%etc/freeswitch/scripts/perl/extract_log_range.pl
+%%WITH_PERL%%etc/freeswitch/scripts/perl/fs.pl
+%%WITH_PERL%%etc/freeswitch/scripts/perl/fsconsole.pl
+%%WITH_PERL%%etc/freeswitch/scripts/perl/multicast/recv.pl
+%%WITH_PERL%%etc/freeswitch/scripts/perl/multicast/send.pl
+%%WITH_PERL%%etc/freeswitch/scripts/perl/mwi_event.pl
+%%WITH_PERL%%etc/freeswitch/scripts/perl/originate.pl
+%%WITH_PERL%%etc/freeswitch/scripts/perl/rpc.cgi
+%%WITH_PERL%%etc/freeswitch/scripts/perl/scenario/attended_transfer.button
+%%WITH_PERL%%etc/freeswitch/scripts/perl/scenario/blind_transfer.button
+%%WITH_PERL%%etc/freeswitch/scripts/perl/scenario/offhook.button
+%%WITH_PERL%%etc/freeswitch/scripts/perl/scenario/phones.cfg
+%%WITH_PERL%%etc/freeswitch/scripts/perl/scenario/runscenario.pl
+%%WITH_PERL%%etc/freeswitch/scripts/perl/sendmail
+%%WITH_PERL%%etc/freeswitch/scripts/perl/snom-pnpd.pl
+%%WITH_PERL%%etc/freeswitch/scripts/perl/sock.pl
+%%WITH_PERL%%etc/freeswitch/scripts/perl/tonegen/rtttl2tgml.pl
+%%WITH_PERL%%etc/freeswitch/scripts/perl/wplookup.cgi
+%%WITH_PHP%%etc/freeswitch/scripts/php/call.php
+%%WITH_PYTHON%%etc/freeswitch/scripts/python/freepy/INSTALL
+%%WITH_PYTHON%%etc/freeswitch/scripts/python/freepy/README
+%%WITH_PYTHON%%etc/freeswitch/scripts/python/freepy/__init__.py
+%%WITH_PYTHON%%etc/freeswitch/scripts/python/freepy/apirequest.sm
+%%WITH_PYTHON%%etc/freeswitch/scripts/python/freepy/apirequest_sm.py
+%%WITH_PYTHON%%etc/freeswitch/scripts/python/freepy/bgapirequest.sm
+%%WITH_PYTHON%%etc/freeswitch/scripts/python/freepy/bgapirequest_sm.py
+%%WITH_PYTHON%%etc/freeswitch/scripts/python/freepy/fseventlistener.py
+%%WITH_PYTHON%%etc/freeswitch/scripts/python/freepy/fshelper.py
+%%WITH_PYTHON%%etc/freeswitch/scripts/python/freepy/globals.py
+%%WITH_PYTHON%%etc/freeswitch/scripts/python/freepy/loginrequest.sm
+%%WITH_PYTHON%%etc/freeswitch/scripts/python/freepy/loginrequest_sm.py
+%%WITH_PYTHON%%etc/freeswitch/scripts/python/freepy/models.py
+%%WITH_PYTHON%%etc/freeswitch/scripts/python/freepy/request.py
+%%WITH_PYTHON%%etc/freeswitch/scripts/python/mytest.py
+%%WITH_PYTHON%%etc/freeswitch/scripts/python/recipewizard.py
+%%WITH_RSS%%etc/freeswitch/scripts/rss/rss2ivr.pl
+%%WITH_RSS%%etc/freeswitch/scripts/rss/syncrss.pl
+%%WITH_RSS%%@dirrm etc/freeswitch/scripts/rss
+%%WITH_PYTHON%%@dirrm etc/freeswitch/scripts/python/freepy
+%%WITH_PYTHON%%@dirrm etc/freeswitch/scripts/python
+%%WITH_PHP%%@dirrm etc/freeswitch/scripts/php
+%%WITH_PERL%%@dirrm etc/freeswitch/scripts/perl/tonegen
+%%WITH_PERL%%@dirrm etc/freeswitch/scripts/perl/scenario
+%%WITH_PERL%%@dirrm etc/freeswitch/scripts/perl/multicast
+%%WITH_PERL%%@dirrm etc/freeswitch/scripts/perl/POE-Filter-FSSocket/t
+%%WITH_PERL%%@dirrm etc/freeswitch/scripts/perl/POE-Filter-FSSocket/lib/POE/Filter
+%%WITH_PERL%%@dirrm etc/freeswitch/scripts/perl/POE-Filter-FSSocket/lib/POE
+%%WITH_PERL%%@dirrm etc/freeswitch/scripts/perl/POE-Filter-FSSocket/lib
+%%WITH_PERL%%@dirrm etc/freeswitch/scripts/perl/POE-Filter-FSSocket/examples
+%%WITH_PERL%%@dirrm etc/freeswitch/scripts/perl/POE-Filter-FSSocket
+%%WITH_PERL%%@dirrm etc/freeswitch/scripts/perl/FreeSWITCH/debian
+%%WITH_PERL%%@dirrm etc/freeswitch/scripts/perl/FreeSWITCH
+%%WITH_PERL%%@dirrm etc/freeswitch/scripts/perl
+%%WITH_LUA%%@dirrm etc/freeswitch/scripts/lua
+%%WITH_JAVASCRIPT%%@dirrm etc/freeswitch/scripts/javascript/aadir
+%%WITH_JAVASCRIPT%%@dirrm etc/freeswitch/scripts/javascript