aboutsummaryrefslogtreecommitdiff
path: root/misc/getopt
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2013-03-03 01:12:04 +0000
committerEitan Adler <eadler@FreeBSD.org>2013-03-03 01:12:04 +0000
commit01fdad6d47f37ad625911a43f4c81e36ad9d0603 (patch)
tree544a0c943f735e9e29695877c1e24754dec2b2c5 /misc/getopt
parent24b38246dbe9a4bc9346bae362bee65620e62bd1 (diff)
downloadports-01fdad6d47f37ad625911a43f4c81e36ad9d0603.tar.gz
ports-01fdad6d47f37ad625911a43f4c81e36ad9d0603.zip
Notes
Diffstat (limited to 'misc/getopt')
-rw-r--r--misc/getopt/files/patch-Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/misc/getopt/files/patch-Makefile b/misc/getopt/files/patch-Makefile
new file mode 100644
index 000000000000..a3160ae26b0e
--- /dev/null
+++ b/misc/getopt/files/patch-Makefile
@@ -0,0 +1,30 @@
+--- ./Makefile.orig 2013-03-02 19:04:01.590723827 -0500
++++ ./Makefile 2013-03-02 19:06:02.492723812 -0500
+@@ -1,7 +1,7 @@
+ .SUFFIXES:
+
+ DESTDIR=
+-prefix=/usr/local
++prefix=$(PREFIX)
+ bindir=$(prefix)/bin
+ mandir=$(prefix)/man
+ man1dir=$(mandir)/man1
+@@ -32,7 +32,7 @@
+ LANGUAGES = ca cs da de es et eu fi fr gl hu id it ja nl pl pt_BR ru sl sv tr uk vi zh_CN zh_TW
+ MOFILES:=$(patsubst %,po/%.mo,$(LANGUAGES))
+
+-CPPFLAGS=-DLIBCGETOPT=$(LIBCGETOPT) -DWITHOUT_GETTEXT=$(WITHOUT_GETTEXT) -DLOCALEDIR=\"$(localedir)\" -DNOT_UTIL_LINUX -Dprogram_invocation_short_name=\"$(PACKAGE)\" -Dprogram_version=\"$(VERSION)\"
++CPPFLAGS+=-DLIBCGETOPT=$(LIBCGETOPT) -DWITHOUT_GETTEXT=$(WITHOUT_GETTEXT) -DLOCALEDIR=\"$(localedir)\" -DNOT_UTIL_LINUX -Dprogram_invocation_short_name=\"$(PACKAGE)\" -Dprogram_version=\"$(VERSION)\"
+ ifeq ($(LIBCGETOPT),0)
+ CPPFLAGS+=-I./gnu
+ endif
+@@ -41,9 +41,6 @@
+ -Wcast-align -Wmissing-declarations \
+ -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes \
+ -Wnested-externs -Winline
+-OPTIMIZE=-O3 -fno-strength-reduce
+-CFLAGS=$(WARNINGS) $(OPTIMIZE)
+-LDFLAGS=
+
+ sources=getopt.c
+ ifeq ($(LIBCGETOPT),0)