aboutsummaryrefslogtreecommitdiff
path: root/misc/git/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1996-06-17 08:33:47 +0000
committerSatoshi Asami <asami@FreeBSD.org>1996-06-17 08:33:47 +0000
commit0da28ad967ed390f292b4977b1d6cf0b6afb6af4 (patch)
treeae2a787f6301bf46bcc347d3c16e22312b466302 /misc/git/Makefile
parent283d911dbaaa66ae350fab5ce9e09fc9c2dc35d8 (diff)
Notes
Diffstat (limited to 'misc/git/Makefile')
-rw-r--r--misc/git/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/misc/git/Makefile b/misc/git/Makefile
index d7ea0a8ad46e..cc877587d8f1 100644
--- a/misc/git/Makefile
+++ b/misc/git/Makefile
@@ -1,26 +1,29 @@
# New ports collection makefile for: git
-# Version required: 4.3.6
+# Version required: 4.3.11
# Date created: 12 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.1.1.1 1995/07/15 23:26:38 torstenb Exp $
+# $Id: Makefile,v 1.2 1995/11/26 10:47:34 asami Exp $
#
-DISTNAME= git-4.3.6
+DISTNAME= git-4.3.11
CATEGORIES= misc
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
GNU_CONFIGURE= YES
-post-install:
- cp ${PREFIX}/lib/git/term/.gitrc.ansi \
- ${PREFIX}/lib/git/term/.gitrc.cons25
- (cd ${PREFIX}/lib/git/term ; patch --quiet -p0 \
- <${FILESDIR}/gitrc.cons25.patch ; rm .gitrc.cons25.orig)
+pre-install:
+ cp ${WRKSRC}/term/.gitrc.ansi \
+ ${WRKSRC}/term/.gitrc.cons25
+ (cd ${WRKSRC}/term ; patch --quiet -p0 <${FILESDIR}/gitrc.cons25.patch )
+
+post_install:
+.if !defined(NOMANCOMPRESS)
@gzip -9nf ${PREFIX}/man/man1/git.1 ${PREFIX}/man/man1/gitmatch.1 \
${PREFIX}/man/man1/gitaction.1 ${PREFIX}/man/man1/gitmount.1 \
${PREFIX}/man/man1/gitcmp.1 ${PREFIX}/man/man1/gitkeys.1 \
${PREFIX}/man/man1/gitredir.1 ${PREFIX}/man/man1/gitrgrep.1 \
${PREFIX}/man/man1/gitps.1 ${PREFIX}/man/man1/gitview.1
+.endif
.include <bsd.port.mk>