aboutsummaryrefslogtreecommitdiff
path: root/misc/gkrellm-helium/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-06 11:41:44 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-06 11:41:44 +0000
commitf54adc2e0104c05c8dcd4e9d1eed730eb543d046 (patch)
treeb171676495b7e6a10b0c12dbde26ae6a1828a618 /misc/gkrellm-helium/Makefile
parent29a7541b6385ae0bb9451c63c5372ac88424f90e (diff)
downloadports-f54adc2e0104c05c8dcd4e9d1eed730eb543d046.tar.gz
ports-f54adc2e0104c05c8dcd4e9d1eed730eb543d046.zip
Notes
Diffstat (limited to 'misc/gkrellm-helium/Makefile')
-rw-r--r--misc/gkrellm-helium/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/misc/gkrellm-helium/Makefile b/misc/gkrellm-helium/Makefile
new file mode 100644
index 000000000000..8f373706ad6d
--- /dev/null
+++ b/misc/gkrellm-helium/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: gkrellm-helium
+# Date Created: 19 Apr 2003
+# Whom: Pav Lucistnik <pav@oook.cz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gkrellm-helium
+PORTVERSION= 2.1
+CATEGORIES= misc
+MASTER_SITES= http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= pav@oook.cz
+COMMENT= GKrellM plugin reading data from helium thermometer at Strahov, Prague
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|/usr/local/lib/gkrellm2/plugins|${PREFIX}/libexec/gkrellm2/plugins|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|ulong|u_long|' ${WRKSRC}/*.c
+
+.include <bsd.port.mk>