aboutsummaryrefslogtreecommitdiff
path: root/misc/gkrellweather2
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2016-09-17 10:34:56 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2016-09-17 10:34:56 +0000
commit84c3b5830f266ff940269780465ee4c0c099a518 (patch)
tree1280a087ab73feef642d2d5b383314595936e9b2 /misc/gkrellweather2
parent3346021972b58ae3975cf109e41beb4d895dd577 (diff)
downloadports-84c3b5830f266ff940269780465ee4c0c099a518.tar.gz
ports-84c3b5830f266ff940269780465ee4c0c099a518.zip
Notes
Diffstat (limited to 'misc/gkrellweather2')
-rw-r--r--misc/gkrellweather2/Makefile3
-rw-r--r--misc/gkrellweather2/distinfo1
-rw-r--r--misc/gkrellweather2/files/patch-Makefile8
-rw-r--r--misc/gkrellweather2/files/patch-gkrellweather.c17
-rw-r--r--misc/gkrellweather2/pkg-descr2
5 files changed, 21 insertions, 10 deletions
diff --git a/misc/gkrellweather2/Makefile b/misc/gkrellweather2/Makefile
index aede12af8671..585d3383e850 100644
--- a/misc/gkrellweather2/Makefile
+++ b/misc/gkrellweather2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gkrellweather
PORTVERSION= 2.0.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc geography
MASTER_SITES= https://sites.google.com/site/makovick/projects/
@@ -11,6 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Weather plugin for GKrellM
LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:sysutils/gkrellm2
RUN_DEPENDS= gkrellm:sysutils/gkrellm2
diff --git a/misc/gkrellweather2/distinfo b/misc/gkrellweather2/distinfo
index 51e5edebabdf..bea95986f149 100644
--- a/misc/gkrellweather2/distinfo
+++ b/misc/gkrellweather2/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1474107595
SHA256 (gkrellweather-2.0.8.tgz) = 06236ad489151019e71bab4ba63b4b8b06d58c58890caed8b1a28fdd05cde16d
SIZE (gkrellweather-2.0.8.tgz) = 20227
diff --git a/misc/gkrellweather2/files/patch-Makefile b/misc/gkrellweather2/files/patch-Makefile
index 79f121ea1e05..0104529dce95 100644
--- a/misc/gkrellweather2/files/patch-Makefile
+++ b/misc/gkrellweather2/files/patch-Makefile
@@ -1,8 +1,8 @@
---- Makefile.orig Sun Feb 27 14:54:47 2005
-+++ Makefile Wed Mar 2 00:22:17 2005
+--- Makefile.orig 2009-01-11 18:15:02 UTC
++++ Makefile
@@ -1,9 +1,9 @@
PKGNAME = gkrellweather
- VERSION = 2.0.7
+ VERSION = 2.0.8
-CFLAGS = -O2 -std=gnu99 -Wall -fPIC `pkg-config gtk+-2.0 --cflags`
+CFLAGS += -Wall -fPIC `pkg-config gtk+-2.0 --cflags`
LIBS = `pkg-config gtk+-2.0 --libs`
@@ -12,7 +12,7 @@
LOCALEDIR := $(PREFIX)/share/locale
-@@ -14,13 +14,13 @@
+@@ -14,13 +14,13 @@ endif
CFLAGS += -DPACKAGE="\"$(PKGNAME)\""
export PKGNAME LOCALEDIR
diff --git a/misc/gkrellweather2/files/patch-gkrellweather.c b/misc/gkrellweather2/files/patch-gkrellweather.c
index 6ade4424a75a..a455f386a75b 100644
--- a/misc/gkrellweather2/files/patch-gkrellweather.c
+++ b/misc/gkrellweather2/files/patch-gkrellweather.c
@@ -1,6 +1,15 @@
---- gkrellweather.c.orig Mon Mar 31 13:12:57 2003
-+++ gkrellweather.c Sun Jul 13 14:30:14 2003
-@@ -986,7 +986,7 @@
+--- gkrellweather.c.orig 2009-01-11 18:15:02 UTC
++++ gkrellweather.c
+@@ -777,7 +777,7 @@ create_air_tab (GtkWidget *tab)
+ " switch interval - number of seconds (0 = never)" \
+ " between switching display\n")
+ };
+- static gchar url[] = "http://www.nws.noaa.gov/tg/siteloc.shtml";
++ static gchar url[] = "http://www.nws.noaa.gov/tg/siteloc.php";
+ laptop = gtk_notebook_new();
+ gtk_notebook_set_tab_pos(GTK_NOTEBOOK(laptop), GTK_POS_TOP);
+ gtk_box_pack_start(GTK_BOX(tab), laptop, TRUE, TRUE, 0);
+@@ -986,7 +986,7 @@ read_default(void)
options.windspeed_unit = 1;
options.pressure_unit = 1;
strcpy(options.station, DEFAULT_STATION_ID);
@@ -9,7 +18,7 @@
options.command[511] = 0;
snprintf(options.filename, 512, "%s/.wmWeatherReports/%s.dat",
getenv("HOME"), options.station);
-@@ -998,6 +998,7 @@
+@@ -998,6 +998,7 @@ GkrellmMonitor *
gkrellm_init_plugin(void)
{
#ifdef ENABLE_NLS
diff --git a/misc/gkrellweather2/pkg-descr b/misc/gkrellweather2/pkg-descr
index 7135ec2a9dc0..54dc8a1f17ff 100644
--- a/misc/gkrellweather2/pkg-descr
+++ b/misc/gkrellweather2/pkg-descr
@@ -3,7 +3,7 @@ Service
Features
- Choose the location nearest to you by 4-letter METAR station
- identifier code. (http://www.nws.noaa.gov/oso/siteloc.shtml)
+ identifier code.(http://www.nws.noaa.gov/tg/siteloc.php)
- Monitor temperature, dew point, pressure, relative humidity, sky
condition, wind direction and speed
- Display using imperial units (degrees Fareheight, inches of