aboutsummaryrefslogtreecommitdiff
path: root/misc/gkx86info2
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-02-17 13:22:15 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-02-17 13:22:15 +0000
commit735a4f88f7b80565885cef10a3f251394b51cbb7 (patch)
tree7280c4c19c8699d51a7f2f976aee946e9490b0c8 /misc/gkx86info2
parente91a5cfedee5f282761f03cc000db057085070f4 (diff)
downloadports-735a4f88f7b80565885cef10a3f251394b51cbb7.tar.gz
ports-735a4f88f7b80565885cef10a3f251394b51cbb7.zip
Notes
Diffstat (limited to 'misc/gkx86info2')
-rw-r--r--misc/gkx86info2/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/misc/gkx86info2/Makefile b/misc/gkx86info2/Makefile
index eddf19f4b606..e33286a6036d 100644
--- a/misc/gkx86info2/Makefile
+++ b/misc/gkx86info2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gkx86info2
-# Date created: Tue Apr 27 14:15:53 CEST 2004
-# Whom: Tobias Roth <ports@fsck.ch>
-#
+# Created by: Tobias Roth <ports@fsck.ch>
# $FreeBSD$
-#
PORTNAME= gkx86info2
PORTVERSION= 0.0.2
@@ -18,13 +14,16 @@ COMMENT= GKrellM2 plugin that simply prints the current clock speed
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
+USE_PKGCONFIG= build
USE_GNOME= gtk20
WRKSRC= ${WRKDIR}/gkx86info${PORTVERSION}
+.include <bsd.port.options.mk>
+
do-build:
- @cd ${WRKSRC} && eval ${CC} ${CFLAGS} -o MHz.o -c MHz.c
+ @cd ${WRKSRC} && eval ${CC} ${CFLAGS} -fPIC -o MHz.o -c MHz.c
@cd ${WRKSRC} && eval ${CC} ${CFLAGS} -fPIC \
`pkg-config gtk+-2.0 --cflags` -c gkx86info.c
@cd ${WRKSRC} && eval ${CC} ${CFLAGS} -shared \
@@ -35,7 +34,7 @@ do-install:
${PREFIX}/libexec/gkrellm2/plugins/
post-install:
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
.endif