aboutsummaryrefslogtreecommitdiff
path: root/misc/gman/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-03 05:58:03 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-03 05:58:03 +0000
commite3db89b2508ab0ff02d2d75e93323ef3e3e12cf3 (patch)
treeb4ce912eaef36519a56b249164120d460fffeae7 /misc/gman/Makefile
parentd9efbbb1bb7895a4e6637ad10dbc49200955ec39 (diff)
downloadports-e3db89b2508ab0ff02d2d75e93323ef3e3e12cf3.tar.gz
ports-e3db89b2508ab0ff02d2d75e93323ef3e3e12cf3.zip
Notes
Diffstat (limited to 'misc/gman/Makefile')
-rw-r--r--misc/gman/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/misc/gman/Makefile b/misc/gman/Makefile
index e1245df30f9a..900b1f08dcdb 100644
--- a/misc/gman/Makefile
+++ b/misc/gman/Makefile
@@ -9,7 +9,8 @@
PORTNAME= gman
PORTVERSION= 0.9.3
CATEGORIES= misc
-MASTER_SITES= http://homex.coolconnect.com/user/xkwang/gman/
+MASTER_SITES= http://stud3.tuwien.ac.at/~e0025974/distfiles/ \
+ http://homex.coolconnect.com/user/xkwang/gman/
MAINTAINER= ports@FreeBSD.org
@@ -18,12 +19,23 @@ RUN_DEPENDS= ghostview:${PORTSDIR}/print/ghostview
USE_GNOMENG= yes
USE_GNOME= gtk12
+USE_REINPLACE= yes
MAN1= gman.1x
post-patch:
- @${PERL} -pi -e "s,^CXX =,#CXX =,g ; s,^CXXFLAGS =,CXXFLAGS+=,g ; \
- s,gtk-config,${GTK_CONFIG},g ; s,= /usr,= ${PREFIX},g ; \
- s,/var/www,${LOCALBASE}/www,g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's,^CXX =,#CXX =,g' \
+ -e 's,^CXXFLAGS =,CXXFLAGS+=,g' \
+ -e 's,gtk-config,${GTK_CONFIG},g' \
+ -e 's,= /usr,= ${PREFIX},g' \
+ -e 's,\-O2,,g' \
+ -e 's,\-lgtk \-lgdk \-lpthread ,`${GTK_CONFIG} \-\-libs gthread` ,g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gman ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/gman.pl ${PREFIX}/bin/gman.cgi
+ @${MKDIR} ${PREFIX}/www/cgi-bin/gman
+ ${INSTALL_SCRIPT} ${WRKSRC}/gman.pl ${PREFIX}/www/cgi-bin/gman
+ ${INSTALL_MAN} ${WRKSRC}/gman.1x ${MANPREFIX}/man/man1
.include <bsd.port.mk>