aboutsummaryrefslogtreecommitdiff
path: root/misc/gman
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2011-08-26 20:18:25 +0000
committerCy Schubert <cy@FreeBSD.org>2011-08-26 20:18:25 +0000
commit791fda4057ab46b3b5acb12402ba5e8c270a9bd0 (patch)
tree3bcc291ed8c22ed7ea348e1f176e97db322fbd17 /misc/gman
parente74f62ee1894931daf24562e93903792016ebead (diff)
downloadports-791fda4057ab46b3b5acb12402ba5e8c270a9bd0.tar.gz
ports-791fda4057ab46b3b5acb12402ba5e8c270a9bd0.zip
Notes
Diffstat (limited to 'misc/gman')
-rw-r--r--misc/gman/Makefile8
-rw-r--r--misc/gman/distinfo4
-rw-r--r--misc/gman/files/patch-Makefile20
-rw-r--r--misc/gman/files/patch-gman.c2
-rw-r--r--misc/gman/files/patch-gman.pl139
-rw-r--r--misc/gman/files/patch-mandata.c24
-rw-r--r--misc/gman/files/patch-menu.c58
-rw-r--r--misc/gman/files/patch-task.c6
-rw-r--r--misc/gman/files/patch-taskfunc.c6
-rw-r--r--misc/gman/files/patch-window2.c11
10 files changed, 144 insertions, 134 deletions
diff --git a/misc/gman/Makefile b/misc/gman/Makefile
index e29de3fc4619..3a524f83076b 100644
--- a/misc/gman/Makefile
+++ b/misc/gman/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gman
PORTVERSION= 0.9.3
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/g/gman
@@ -16,10 +16,10 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
PATCH_SITES= ${MASTER_SITES}
PATCH_SITE_SUBDIR= ${MASTER_SITE_SUBDIR}
-PATCHFILES= ${PORTNAME}_${PORTVERSION}-2.diff.gz
+PATCHFILES= ${PORTNAME}_${PORTVERSION}-5.diff.gz
PATCH_DIST_STRIP= -p1
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= cy@FreeBSD.org
COMMENT= A user-friendly graphical front end for the man system
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
@@ -34,6 +34,8 @@ USE_GMAKE= yes
MAN1= gman.1x
+CXXFLAGS+= -L${LOCALBASE}/lib
+
post-patch:
@${REINPLACE_CMD} -e 's,^CXX =,#CXX =,g' \
-e 's,^CXXFLAGS =,CXXFLAGS+=,g' \
diff --git a/misc/gman/distinfo b/misc/gman/distinfo
index 8254e14dec5c..5bd4ecea30a5 100644
--- a/misc/gman/distinfo
+++ b/misc/gman/distinfo
@@ -1,4 +1,4 @@
SHA256 (gman_0.9.3.orig.tar.gz) = 27d11b4f2d41691335cb666ca07e6b491fb24496b30330ffbbb26eaa24ed0f99
SIZE (gman_0.9.3.orig.tar.gz) = 42369
-SHA256 (gman_0.9.3-2.diff.gz) = a29ea8cb0488a557b844bee117268fefbf1eabf812532476759efc536dfed1a7
-SIZE (gman_0.9.3-2.diff.gz) = 10295
+SHA256 (gman_0.9.3-5.diff.gz) = e71199a9ca0d39c69f506a0a0d3cb29d35da815e5388a5ba44f7c242f256c684
+SIZE (gman_0.9.3-5.diff.gz) = 12587
diff --git a/misc/gman/files/patch-Makefile b/misc/gman/files/patch-Makefile
new file mode 100644
index 000000000000..244c3f71047b
--- /dev/null
+++ b/misc/gman/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig2 2011-08-25 17:36:53.102931225 -0700
++++ Makefile 2011-08-25 17:40:02.067107593 -0700
+@@ -2,7 +2,7 @@
+ # You can adjust the following variables.
+
+ CXX = g++
+-CXXFLAGS = -DVERSION=\"0.9.3\" $(shell gtk-config --cflags) -O2 -Wall $(DEBUG)
++CXXFLAGS = -DVERSION=\"0.9.3\" $(shell gtk12-config --cflags --libs) -O2 -Wall $(DEBUG)
+ CC = $(CXX) $(CXXFLAGS)
+
+ prefix = /usr/local
+@@ -15,7 +15,7 @@
+ taskfunc.o window2.o
+
+ gman: $(objectfiles)
+- $(CC) -lpthread -lm -lgtk -lglib -rdynamic $(objectfiles) -o gman
++ $(CC) -lpthread -lm -rdynamic $(objectfiles) -o gman
+
+ %.o: %.c %.h
+ gman.o: gman.c gman.h menu.h
diff --git a/misc/gman/files/patch-gman.c b/misc/gman/files/patch-gman.c
index 0b53e1823998..fc20386df7e4 100644
--- a/misc/gman/files/patch-gman.c
+++ b/misc/gman/files/patch-gman.c
@@ -4,7 +4,7 @@
pthread_mutex_init(&context_lock,NULL);
pthread_mutex_init(&loading_man_path_lock,NULL);
init_context();
-- debuging = (int)context->get_value("debuging");
+- debuging = (long)context->get_value("debuging");
+ debuging = (intptr_t)context->get_value("debuging");
pthread_mutex_lock(&gtk_lock);
gtk_init (&argc, &argv);
diff --git a/misc/gman/files/patch-gman.pl b/misc/gman/files/patch-gman.pl
index aa905c88bbf9..765c3dcd7d7c 100644
--- a/misc/gman/files/patch-gman.pl
+++ b/misc/gman/files/patch-gman.pl
@@ -1,69 +1,70 @@
- --- gman.pl.orig Mon Sep 6 16:55:42 2004
- +++ gman.pl Mon Sep 6 16:55:45 2004
- @@ -1,10 +1,10 @@
- #!/usr/bin/perl -w
- -use strict;
-
- if (@ARGV != 2) {
- print <<_EOF_;
- Content-type: text/html
-
- +<!DOCTYPE html PUBLIC "-//IETF//DTD HTML 2.0//EN">
- <html><head><title>gman.pl: invalid use</title></head>
- <body>
- <h1>gman.pl cannot be used without arguments.</h1>
- @@ -14,35 +14,43 @@
- }
-
- my $section = $ARGV[0]; # should also have some sanity check
- +my $cut = "/usr/bin/cut -f 1 -d \" \" ";
- my $name = $ARGV[1];
- -my $man2html = "/usr/lib/cgi-bin/man2html";
- -my $path = `man -w $section $name`; chomp $path; $path =~ s/\s*$//;
- +my $man = "/usr/bin/man";
- +my $man2html = "/usr/local/bin/man2html -nodepage ";
- +my $path = `$man -w $section $name |$cut`; chomp $path; $path =~ s/\s*$//;
-
- unless (-s "$path") {
- warn "not -s $path\n";
- $name = lc $name;
- - $path = `man -w $section $name`; chomp $path; $path =~ s/\s*$//;
- + $path = `$man -w $section $name |$cut`; chomp $path; $path =~ s/\s*$//;
- }
- unless (-s "$path") {
- warn "not -s $path\n";
- print <<end_of_line;
- Content-type: text/html
-
- -<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
- -<HTML><HEAD>
- -<TITLE>404 Not Found</TITLE>
- -</HEAD><BODY>
- +<!DOCTYPE html PUBLIC "-//IETF//DTD HTML 2.0//EN">
- +<html><head>
- +<title>404 Not Found</title>
- +</head><body>
- <H1>Not Found</H1>
- The requested man page $name($section) was not found on this server.
- -</BODY></HTML>
- +</body></html>
- end_of_line
- - die;
- +;
- }
-
- -my $page = `$man2html $path`;
- +my $page = `$man $section $name |$man2html`;
-
- # $page =~ s/^Content-type: text\/html\n\n// if (not run as cgi...);
-
- -$page =~ s/(This document was created by\n<a HREF=\".*\">man2html<\/a>)(,\nusing the manual pages.<br>)/$1 for <a href=\"\/cgi-bin\/gman.pl?1+gman\">gman<\/a>$2/io;
- +print <<eof;
- +Content-type: text/html
- +
- +<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML//EN">
- +eof
- +;
-
- print $page;
- +
+--- gman.pl.orig 2011-08-25 13:06:54.517309488 -0700
++++ gman.pl 2011-08-25 13:12:49.444936858 -0700
+@@ -1,10 +1,10 @@
+ #!/usr/bin/perl -w
+-use strict;
+
+ if (@ARGV != 2) {
+ print <<_EOF_;
+ Content-type: text/html
+
++<!DOCTYPE html PUBLIC "-//IETF//DTD HTML 2.0//EN">
+ <html><head><title>gman.pl: invalid use</title></head>
+ <body>
+ <h1>gman.pl cannot be used without arguments.</h1>
+@@ -14,14 +14,16 @@
+ }
+
+ my $section = $ARGV[0]; # should also have some sanity check
++my $cut = "/usr/bin/cut -f 1 -d \" \" ";
+ my $name = $ARGV[1];
+-my $man2html = "/usr/lib/cgi-bin/man/man2html";
+-my $path = `man -w $section $name`; chomp $path; $path =~ s/\s*$//;
++my $man = "/usr/bin/man";
++my $man2html = "/usr/local/bin/man2html -nodepage ";
++my $path = `$man -w $section $name |$cut`; chomp $path; $path =~ s/\s*$//;
+
+ unless (-s "$path") {
+ warn "not -s $path\n";
+ $name = lc $name;
+- $path = `man -w $section $name`; chomp $path; $path =~ s/\s*$//;
++ $path = `$man -w $section $name |$cut`; chomp $path; $path =~ s/\s*$//;
+ }
+ unless (-s "$path") {
+ warn "not -s $path\n";
+@@ -29,12 +31,12 @@
+ Content-type: text/html
+
+ <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
+-<HTML><HEAD>
+-<TITLE>404 Not Found</TITLE>
+-</HEAD><BODY>
+-<H1>Not Found</H1>
++<html><head>
++<title>404 Not Found</title>
++</head><body>
++<h1>Not Found</h1>
+ The requested man page $name($section) was not found on this server.
+-</BODY></HTML>
++</body></html>
+ end_of_line
+ die;
+ }
+@@ -44,15 +46,9 @@
+ print <<end_of_line;
+ Content-type: text/html
+
+-<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
+-<HTML><HEAD>
+-<TITLE>man2html missing</TITLE>
+-</HEAD><BODY>
+-<H1>man2html missing</H1>
+-
+-<p>You have to install <tt>man2html</tt> in order to use this mode in gman.
++<!DOCTYPE html PUBLIC "-//IETF//DTD HTML 2.0//EN">
+
+-</BODY></HTML>
++</body></html>
+ end_of_line
+ die;
+ }
diff --git a/misc/gman/files/patch-mandata.c b/misc/gman/files/patch-mandata.c
index 5603395f7412..874aeecfb579 100644
--- a/misc/gman/files/patch-mandata.c
+++ b/misc/gman/files/patch-mandata.c
@@ -1,25 +1,23 @@
---- mandata.c.orig 2007-08-12 19:00:16.000000000 +0200
-+++ mandata.c 2007-08-12 19:00:46.000000000 +0200
-@@ -239,13 +239,13 @@
+--- mandata.c.orig 2011-08-25 13:13:20.013866364 -0700
++++ mandata.c 2011-08-25 13:16:34.578700011 -0700
+@@ -239,14 +239,12 @@
char buffer[2*BUFFER_SIZE];
char loc_name[BUFFER_SIZE];
char buffer2[BUFFER_SIZE];
-- switch ((int)context->get_value("show_mode")) {
+- switch ((long)context->get_value("show_mode")) {
+ switch ((intptr_t)context->get_value("show_mode")) {
case 0:
-- sprintf(buffer,"%s -T '%s manual page' -n GMan -e man ",
+- sprintf(buffer,"%s -T '%s manual page' -n '%s - GMan' -e man ",
+ sprintf(buffer,"%s -T '%s manual page' -n GMan -e man %s",
(char*)context->get_value("xterm_command"),
-- get_display_name(buffer1));
+ get_display_name(buffer1),
+ get_display_name(buffer1));
- len = strlen(buffer);
- attach(buffer+len,man_path->GetPath(),file_name);
-+ get_display_name(buffer1), get_display_name(buffer1));
-+/* len = strlen(buffer);
-+ attach(buffer+len,man_path->GetPath(),file_name); */
//g_warning(buffer);
if(!fork())
{
-@@ -256,9 +256,9 @@
+@@ -257,9 +255,9 @@
break;
case 1:
sprintf(loc_name," ~/.gman.%s.ps ",get_display_name(buffer1));
@@ -32,7 +30,7 @@
strcat(buffer," >> ");
strcat(buffer,loc_name);
strcat(buffer," ; ");
-@@ -306,7 +306,7 @@
+@@ -307,7 +305,7 @@
case 2:
sprintf(loc_name," ~/.gman.%s.html ",get_display_name(buffer1));
//g_warning(loc_name);
@@ -41,11 +39,11 @@
strcat(buffer," ");
strcat(buffer,get_section_name(buffer2));
strcat(buffer," ");
-@@ -350,7 +350,7 @@
+@@ -351,7 +349,7 @@
break;
default:
if(context->get_value("show_warning"))
-- g_print("unexpected \'show_mode\' : %d ",(int)context->get_value("show_mode"));
+- g_print("unexpected \'show_mode\' : %ld ",(long)context->get_value("show_mode"));
+ g_print("unexpected \'show_mode\' : %d ",(intptr_t)context->get_value("show_mode"));
return;
}
diff --git a/misc/gman/files/patch-menu.c b/misc/gman/files/patch-menu.c
index cdb3599efb6f..9e0a35c56aec 100644
--- a/misc/gman/files/patch-menu.c
+++ b/misc/gman/files/patch-menu.c
@@ -4,9 +4,9 @@
/*flag = 0 means not to invoke call backs when changing the states of buttons.*/
void updata_menu_buttons(int flag)
{
-- int i,j,k,k2;
-- k = (int)context->get_value("display_section_policy");
-+ int i,j;
+- long i,j,k,k2;
+- k = (long)context->get_value("display_section_policy");
++ long i,j;
+ intptr_t k,k2;
+ k = (intptr_t)context->get_value("display_section_policy");
if(k>0 && k<=2)
@@ -14,28 +14,28 @@
if(!flag) signal_menu_change++;
gtk_check_menu_item_set_active(GTK_CHECK_MENU_ITEM(section_select[k]),1);
}
-- k = (int)context->get_value("display_section");
+- k = (long)context->get_value("display_section");
+ k = (intptr_t)context->get_value("display_section");
for (i = 0;i<10;i++)
if(!(k&(1<<i)) != !(((GtkCheckMenuItem*)(section_buttons[i]))->active)) {
if(!flag) signal_menu_change++;
gtk_check_menu_item_set_active(GTK_CHECK_MENU_ITEM(section_buttons[i]),k&(1<<i));
}
-- k = (int)context->get_value("searching_mode");
+- k = (long)context->get_value("searching_mode");
+ k = (intptr_t)context->get_value("searching_mode");
if(k>0 && k<=1)
if(!(((GtkCheckMenuItem*)(searching_mode_buttons[k]))->active)) {
if(!flag) signal_menu_change++;
gtk_check_menu_item_set_active(GTK_CHECK_MENU_ITEM(searching_mode_buttons[k]),1);
}
-- k = (int)context->get_value("show_mode");
+- k = (long)context->get_value("show_mode");
+ k = (intptr_t)context->get_value("show_mode");
if(k>0 && k<=3)
if(!(((GtkCheckMenuItem*)(show_mode_buttons[k]))->active)) {
if(!flag) signal_menu_change++;
gtk_check_menu_item_set_active(GTK_CHECK_MENU_ITEM(show_mode_buttons[k]),1);
}
-- k2 = (int)context->get_value("show_status_bar");
+- k2 = (long)context->get_value("show_status_bar");
+ k2 = (intptr_t)context->get_value("show_status_bar");
i = k2&(1<<k);
j = (((GtkCheckMenuItem*)(status_bar_button))->active);
@@ -44,11 +44,11 @@
static void updata_widget_show(int flag)
{
-- int k,k2;
+- long k,k2;
+ intptr_t k,k2;
-- k = (int)context->get_value("searching_mode");
-- k2 = (int)context->get_value("show_status_bar");
+- k = (long)context->get_value("searching_mode");
+- k2 = (long)context->get_value("show_status_bar");
+ k = (intptr_t)context->get_value("searching_mode");
+ k2 = (intptr_t)context->get_value("show_status_bar");
@@ -58,8 +58,8 @@
gtk_window_set_title(GTK_WINDOW(window), "Gman");
gtk_window_set_policy( GTK_WINDOW( window ), FALSE, TRUE, FALSE );
gtk_window_set_default_size(GTK_WINDOW(window),
-- (int)context->get_value("h_size"),
-- (int)context->get_value("v_size"));
+- (long)context->get_value("h_size"),
+- (long)context->get_value("v_size"));
+ (intptr_t)context->get_value("h_size"),
+ (intptr_t)context->get_value("v_size"));
@@ -69,8 +69,8 @@
static int section_policy_callback(GtkWidget *w, gpointer data) {
// static int signal;
-- int k,k2;
-- k2 = (int) data;
+- long k,k2;
+- k2 = (long) data;
+ intptr_t k,k2;
+ k2 = (intptr_t) data;
if(!((GtkCheckMenuItem*)(section_select[k2]))->active) return 1;
@@ -78,7 +78,7 @@
if(signal_menu_change>0) {signal_menu_change--;return 1;}
//if(!signal) {signal++;return 1;}
//signal--;
-- k = (int) context->get_value("display_section_policy");
+- k = (long) context->get_value("display_section_policy");
+ k = (intptr_t) context->get_value("display_section_policy");
if(k == k2) return 1;
pthread_mutex_lock(&context_lock);
@@ -87,13 +87,13 @@
}
static int section_select_callback(GtkWidget *w, gpointer data) {
-- int var;
+- long var;
+ intptr_t var;
if(signal_menu_change>0) {signal_menu_change--;return 1;}
pthread_mutex_lock(&context_lock);
-- var = (int)context->get_value("display_section");
-- var ^= (int)data;
+- var = (long)context->get_value("display_section");
+- var ^= (long)data;
+ var = (intptr_t)context->get_value("display_section");
+ var ^= (intptr_t)data;
context->set_value("display_section","int",(void*)var);
@@ -103,7 +103,7 @@
}
// context->save(stdout,"automatically made by Gman");
-- gtk_exit((int)data);
+- gtk_exit((long)data);
+ gtk_exit((intptr_t)data);
}
@@ -112,11 +112,11 @@
static int status_bar_callback (GtkWidget *widget, gpointer data)
{
-- int k,k2;
+- long k,k2;
+ intptr_t k,k2;
if(signal_menu_change>0) {signal_menu_change--;return 1;}
-- k2 = (int) context->get_value("show_status_bar");
-- k = (int) context->get_value("searching_mode");
+- k2 = (long) context->get_value("show_status_bar");
+- k = (long) context->get_value("searching_mode");
+ k2 = (intptr_t) context->get_value("show_status_bar");
+ k = (intptr_t) context->get_value("searching_mode");
if(((GtkCheckMenuItem*)(status_bar_button))->active) k2 = k2 | (1<<k);
@@ -126,15 +126,15 @@
static int search_mode_callback (GtkWidget *widget, gpointer data)
{
-- int k,k2;
-- k2 = (int) data;
+- long k,k2;
+- k2 = (long) data;
+ intptr_t k,k2;
+ k2 = (intptr_t) data;
if(!((GtkCheckMenuItem*)(searching_mode_buttons[k2]))->active) return 1;
if(signal_menu_change>0) {signal_menu_change--;return 1;}
//if(!signal) {signal++;return 1;}
//signal--;
-- k = (int) context->get_value("searching_mode");
+- k = (long) context->get_value("searching_mode");
+ k = (intptr_t) context->get_value("searching_mode");
if(k == k2) return 1;
pthread_mutex_lock(&context_lock);
@@ -143,15 +143,15 @@
static int show_mode_callback (GtkWidget *widget, gpointer data)
{
-- int k,k2;
-- k2 = (int) data;
+- long k,k2;
+- k2 = (long) data;
+ intptr_t k,k2;
+ k2 = (intptr_t) data;
if(!((GtkCheckMenuItem*)(show_mode_buttons[k2]))->active) return 1;
if(signal_menu_change>0) {signal_menu_change--;return 1;}
//if(!signal) {signal++;return 1;}
//signal--;
-- k = (int) context->get_value("show_mode");
+- k = (long) context->get_value("show_mode");
+ k = (intptr_t) context->get_value("show_mode");
if(k == k2) return 1;
pthread_mutex_lock(&context_lock);
@@ -160,7 +160,7 @@
static int button_clicked_callback(GtkWidget * w,gpointer data)
{
-- int i = (int) data;
+- long i = (long) data;
+ intptr_t i = (intptr_t) data;
switch (i) {
case 1: task_set_stop(task_key_word_search);break;
diff --git a/misc/gman/files/patch-task.c b/misc/gman/files/patch-task.c
index 19120d21c53f..80b96fd76d58 100644
--- a/misc/gman/files/patch-task.c
+++ b/misc/gman/files/patch-task.c
@@ -4,13 +4,13 @@
do {
have_task = 0;
task = (Task *)NULL;
-- int flag = 0;
+- long flag = 0;
+ intptr_t flag = 0;
pthread_mutex_lock(&task_group->lock);
j = task_group->tasks->get_size();
for(i = 0; i<j && !have_task ;i++) {
if((task = (Task*)task_group->tasks->get_item(i))->signals[0]->get_size()) {
-- flag = ((int)task->signals[0]->get_item(0) & ~1) | (task->state & 1);
+- flag = ((long)task->signals[0]->get_item(0) & ~1) | (task->state & 1);
+ flag = ((intptr_t)task->signals[0]->get_item(0) & ~1) | (task->state & 1);
task->signals[0]->delete_item(0);
have_task++;
@@ -19,7 +19,7 @@
have_task++;
}
else if (task->signals[1]->get_size()) {
-- flag = ((int)task->signals[1]->get_item(1) & ~1);
+- flag = ((long)task->signals[1]->get_item(1) & ~1);
+ flag = ((intptr_t)task->signals[1]->get_item(1) & ~1);
task->signals[1]->delete_item(0);
have_task++;
diff --git a/misc/gman/files/patch-taskfunc.c b/misc/gman/files/patch-taskfunc.c
index aa7800129f0d..337837d96911 100644
--- a/misc/gman/files/patch-taskfunc.c
+++ b/misc/gman/files/patch-taskfunc.c
@@ -8,11 +8,11 @@
+ intptr_t display_section_ID;
pthread_mutex_lock(&context_lock);
-- switch ((int)context->get_value("display_section_policy")) {
+- switch ((long)context->get_value("display_section_policy")) {
+ switch ((intptr_t)context->get_value("display_section_policy")) {
case 0: display_section_ID = ~0;break;
-- case 1: display_section_ID = ~(int)(context->get_value("display_section"));break;
-- case 2: display_section_ID = (int)context->get_value("display_section"); break;
+- case 1: display_section_ID = ~(long)(context->get_value("display_section"));break;
+- case 2: display_section_ID = (long)context->get_value("display_section"); break;
+ case 1: display_section_ID = ~(intptr_t)(context->get_value("display_section"));break;
+ case 2: display_section_ID = (intptr_t)context->get_value("display_section"); break;
default: fprintf(stderr,"warning: init_man_data: \"display_section_policy\" "
diff --git a/misc/gman/files/patch-window2.c b/misc/gman/files/patch-window2.c
deleted file mode 100644
index 68b5a7fcbc4c..000000000000
--- a/misc/gman/files/patch-window2.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- window2.c.orig 2007-08-12 18:52:11.000000000 +0200
-+++ window2.c 2007-08-12 18:52:53.000000000 +0200
-@@ -223,7 +223,7 @@
- GtkWidget * x, *apply_button,*add_new_button;
- gchar * c, *c2;
- int i;
-- int select = (int)data;
-+ long select = (long)data;
- gchar * clist_item[3];
- // printf("point2 data = %d\n",select);
- apply_button = (GtkWidget*)gtk_object_get_data(GTK_OBJECT(window2),"button2");