aboutsummaryrefslogtreecommitdiff
path: root/misc/gnome-icon-theme-extras/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-05-10 21:19:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-05-10 21:19:08 +0000
commit48e62d9a379cd45a15f6ae89d564f81b3c13d16e (patch)
treeb627baa77f19bb1eab2fa4dee08aab1908131cd0 /misc/gnome-icon-theme-extras/Makefile
parentfbdf96410f8e803568c33397323dd9d8d3af995f (diff)
Notes
Diffstat (limited to 'misc/gnome-icon-theme-extras/Makefile')
-rw-r--r--misc/gnome-icon-theme-extras/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/misc/gnome-icon-theme-extras/Makefile b/misc/gnome-icon-theme-extras/Makefile
new file mode 100644
index 000000000000..95e7f63f08ed
--- /dev/null
+++ b/misc/gnome-icon-theme-extras/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: gnome-icon-theme-extras
+# Date Created: 27 March 2009
+# Whom: Alexander Logvinov <avl@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/misc/gnome-icon-theme-extras/Makefile,v 1.3 2010/04/20 20:56:39 kwm Exp $
+#
+
+PORTNAME= gnome-icon-theme-extras
+PORTVERSION= 2.30.1
+CATEGORIES= misc gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= An additional collection of icons for the GNOME 2 desktop
+
+BUILD_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme \
+ icon-naming-utils>=0.8.7:${PORTSDIR}/x11-themes/icon-naming-utils
+RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack intlhack gtk20
+INSTALLS_ICONS= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>