aboutsummaryrefslogtreecommitdiff
path: root/misc/gnome-osd/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-11-16 15:36:58 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-11-16 15:36:58 +0000
commitfddb388b96308c2c6321a58e1d7d5024a0ec7cf6 (patch)
tree325063214d472763bce64c019ded64b1bdfcd9bc /misc/gnome-osd/Makefile
parentd5f746c2ae0a4064a7e4daa89d9192406169577a (diff)
downloadports-fddb388b96308c2c6321a58e1d7d5024a0ec7cf6.tar.gz
ports-fddb388b96308c2c6321a58e1d7d5024a0ec7cf6.zip
Notes
Diffstat (limited to 'misc/gnome-osd/Makefile')
-rw-r--r--misc/gnome-osd/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/misc/gnome-osd/Makefile b/misc/gnome-osd/Makefile
index 6f5e881f97c7..51a09fd53e8d 100644
--- a/misc/gnome-osd/Makefile
+++ b/misc/gnome-osd/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= gnome-osd
-DISTVERSION= 0.8.0-1
+DISTVERSION= 0.9.1-1
CATEGORIES= misc
-MASTER_SITES= http://telecom.inescporto.pt/~gjc/gnome-osd/
+MASTER_SITES= http://telecom.inescporto.pt/~gjc/gnome-osd/${DISTVERSION:C|-.*$||}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
MAINTAINER= jylefort@FreeBSD.org
@@ -21,24 +21,20 @@ USE_PYTHON= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= gnome-osd.schemas
+PORTDOCS= AUTHORS NEWS README
post-patch:
- @${REINPLACE_CMD} -e 's|control-center-2.0/capplets|applications|' \
+ @${REINPLACE_CMD} -e 's|control-center-2.0/capplets|applications|; \
+ s|$$(datadir)/dbus-1|$$(prefix)/share/dbus-1|' \
${WRKSRC}/Makefile.in
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} \
- ${WRKSRC}/AUTHORS \
- ${WRKSRC}/NEWS \
- ${WRKSRC}/README \
- ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
-
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>