aboutsummaryrefslogtreecommitdiff
path: root/misc/gnomesword
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-20 23:29:31 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-20 23:29:31 +0000
commit94724992e31e4719b43078de02ca7307be09ad19 (patch)
tree737d854cf40425dc3381496d97a9f62b11915e51 /misc/gnomesword
parent4313297a0cee172da6abc7bc58913b6cb9377da2 (diff)
downloadports-94724992e31e4719b43078de02ca7307be09ad19.tar.gz
ports-94724992e31e4719b43078de02ca7307be09ad19.zip
Notes
Diffstat (limited to 'misc/gnomesword')
-rw-r--r--misc/gnomesword/Makefile10
-rw-r--r--misc/gnomesword/files/patch-configure60
-rw-r--r--misc/gnomesword/files/patch-src::gnome2::editor_menu.c49
-rw-r--r--misc/gnomesword/files/patch-src::gnome2::note_editor.c49
-rw-r--r--misc/gnomesword/files/patch-src::gnome2::note_toolbar_style.c16
-rw-r--r--misc/gnomesword/files/patch-src::gnome2::toolbar_style.c16
-rw-r--r--misc/gnomesword/pkg-plist2
7 files changed, 195 insertions, 7 deletions
diff --git a/misc/gnomesword/Makefile b/misc/gnomesword/Makefile
index 2218f29326d8..7c52b41fd92c 100644
--- a/misc/gnomesword/Makefile
+++ b/misc/gnomesword/Makefile
@@ -7,25 +7,21 @@
PORTNAME= gnomesword
PORTVERSION= 2.1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dboudrot@yahoo.com
COMMENT= A bible interface utilizing the sword framework
-BROKEN= Configure fails
-EXPIRATION_DATE=2005-02-18
-DEPRECATED= ${BROKEN}
-
BUILD_DEPENDS= ${X11BASE}/lib/gnome-spell/libgnome-spell-component-0.3.so:${PORTSDIR}/textproc/gnomespell
LIB_DEPENDS= sword.4:${PORTSDIR}/misc/sword
RUN_DEPENDS= ${X11BASE}/lib/gnome-spell/libgnome-spell-component-0.3.so:${PORTSDIR}/textproc/gnomespell
USE_X_PREFIX= yes
INSTALLS_OMF= yes
-USE_GNOME= gnomehack gnomeprefix gnometarget gtkhtml3 intlhack
+USE_GNOME= gnomehack gnomeprefix gnometarget gal2 gtkhtml3 intlhack
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/misc/gnomesword/files/patch-configure b/misc/gnomesword/files/patch-configure
new file mode 100644
index 000000000000..967b4c277da9
--- /dev/null
+++ b/misc/gnomesword/files/patch-configure
@@ -0,0 +1,60 @@
+--- configure.orig Wed Jul 14 09:34:14 2004
++++ configure Thu Feb 17 15:43:03 2005
+@@ -2033,35 +2033,35 @@
+ echo "*** to the full path to pkg-config."
+ echo "*** Or see http://www.freedesktop.org/software/pkgconfig to get pkg-config."
+ else
+ PKG_CONFIG_MIN_VERSION=0.9.0
+ if $PKG_CONFIG --atleast-pkgconfig-version $PKG_CONFIG_MIN_VERSION; then
+- echo "$as_me:$LINENO: checking for libgnomeui-2.0 gtk+-2.0 libgtkhtml-3.0 gal-2.0 libxml-2.0 sword" >&5
+-echo $ECHO_N "checking for libgnomeui-2.0 gtk+-2.0 libgtkhtml-3.0 gal-2.0 libxml-2.0 sword... $ECHO_C" >&6
++ echo "$as_me:$LINENO: checking for libgnomeui-2.0 gtk+-2.0 libgtkhtml-3.1 gal-2.2 libxml-2.0 sword" >&5
++echo $ECHO_N "checking for libgnomeui-2.0 gtk+-2.0 libgtkhtml-3.1 gal-2.2 libxml-2.0 sword... $ECHO_C" >&6
+
+- if $PKG_CONFIG --exists "libgnomeui-2.0 gtk+-2.0 libgtkhtml-3.0 gal-2.0 libxml-2.0 sword" ; then
++ if $PKG_CONFIG --exists "libgnomeui-2.0 gtk+-2.0 libgtkhtml-3.1 gal-2.2 libxml-2.0 sword" ; then
+ echo "$as_me:$LINENO: result: yes" >&5
+ echo "${ECHO_T}yes" >&6
+ succeeded=yes
+
+ echo "$as_me:$LINENO: checking GNOME_CFLAGS" >&5
+ echo $ECHO_N "checking GNOME_CFLAGS... $ECHO_C" >&6
+- GNOME_CFLAGS=`$PKG_CONFIG --cflags "libgnomeui-2.0 gtk+-2.0 libgtkhtml-3.0 gal-2.0 libxml-2.0 sword"`
++ GNOME_CFLAGS=`$PKG_CONFIG --cflags "libgnomeui-2.0 gtk+-2.0 libgtkhtml-3.1 gal-2.2 libxml-2.0 sword"`
+ echo "$as_me:$LINENO: result: $GNOME_CFLAGS" >&5
+ echo "${ECHO_T}$GNOME_CFLAGS" >&6
+
+ echo "$as_me:$LINENO: checking GNOME_LIBS" >&5
+ echo $ECHO_N "checking GNOME_LIBS... $ECHO_C" >&6
+- GNOME_LIBS=`$PKG_CONFIG --libs "libgnomeui-2.0 gtk+-2.0 libgtkhtml-3.0 gal-2.0 libxml-2.0 sword"`
++ GNOME_LIBS=`$PKG_CONFIG --libs "libgnomeui-2.0 gtk+-2.0 libgtkhtml-3.1 gal-2.2 libxml-2.0 sword"`
+ echo "$as_me:$LINENO: result: $GNOME_LIBS" >&5
+ echo "${ECHO_T}$GNOME_LIBS" >&6
+ else
+ GNOME_CFLAGS=""
+ GNOME_LIBS=""
+ ## If we have a custom action on failure, don't print errors, but
+ ## do set a variable so people can do so.
+- GNOME_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "libgnomeui-2.0 gtk+-2.0 libgtkhtml-3.0 gal-2.0 libxml-2.0 sword"`
++ GNOME_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "libgnomeui-2.0 gtk+-2.0 libgtkhtml-3.1 gal-2.2 libxml-2.0 sword"`
+
+ fi
+
+
+
+@@ -23854,13 +23854,13 @@
+ fi
+
+ packagedatadir=share/${PACKAGE}
+ packagedocdir=share/doc/${PACKAGE}
+
+-packagepixmapsdir=share/pixmaps/${PACKAGE}
++packagepixmapsdir=share/gnome/pixmaps/${PACKAGE}
+ packagehelpdir=share/gnome/help/${PACKAGE}
+-packagemenudir=share/applications
++packagemenudir=share/gnome/applications
+
+ NO_PREFIX_PACKAGE_DATA_DIR="${packagedatadir}"
+
+ PACKAGE_DATA_DIR="${packageprefix}/${packagedatadir}"
+
diff --git a/misc/gnomesword/files/patch-src::gnome2::editor_menu.c b/misc/gnomesword/files/patch-src::gnome2::editor_menu.c
new file mode 100644
index 000000000000..5ca9a49a6be1
--- /dev/null
+++ b/misc/gnomesword/files/patch-src::gnome2::editor_menu.c
@@ -0,0 +1,49 @@
+--- src/gnome2/editor_menu.c.orig Fri Apr 2 17:28:07 2004
++++ src/gnome2/editor_menu.c Mon Feb 14 15:08:42 2005
+@@ -29,11 +29,11 @@
+ #include <gtkhtml/htmlform.h>
+ #include <gtkhtml/htmlenums.h>
+ #include <gtkhtml/htmlsettings.h>
+ #include <gtkhtml/htmlcolor.h>
+ #include <gtkhtml/htmlcolorset.h>
+-#include <gtkhtml/htmllinktext.h>
++//#include <gtkhtml/htmllinktext.h>
+ #include <gtkhtml/htmlengine-edit.h>
+ #include <gtkhtml/htmlengine-edit-fontstyle.h>
+ #include <gtkhtml/htmlengine-edit-cut-and-paste.h>
+ #include <gtkhtml/htmlselection.h>
+ #include <gtkhtml/htmlengine-search.h>
+@@ -491,17 +491,33 @@
+ target = strchr(url, '#');
+ url_copy =
+ target ? g_strndup(url,
+ target - url) : g_strdup(url);
+ new_link =
++ html_text_new(text,
++ GTK_HTML_FONT_STYLE_DEFAULT,
++ html_colorset_get_color(e->
++ settings->
++ color_set,
++ HTMLLinkColor));
++ new_link =
++ html_object_set_link(new_link,
++ html_colorset_get_color(e->
++ settings->
++ color_set,
++ HTMLLinkColor),
++ url_copy, target);
++/*
++ new_link =
+ html_link_text_new(text,
+ GTK_HTML_FONT_STYLE_DEFAULT,
+ html_colorset_get_color(e->
+ settings->
+ color_set,
+ HTMLLinkColor),
+ url_copy, target);
++*/
+ html_engine_paste_object(e, new_link,
+ g_utf8_strlen(text, -1));
+ g_free(url_copy);
+ }
+ }
diff --git a/misc/gnomesword/files/patch-src::gnome2::note_editor.c b/misc/gnomesword/files/patch-src::gnome2::note_editor.c
new file mode 100644
index 000000000000..298dd5532e6f
--- /dev/null
+++ b/misc/gnomesword/files/patch-src::gnome2::note_editor.c
@@ -0,0 +1,49 @@
+--- src/gnome2/note_editor.c.orig Thu May 6 19:10:00 2004
++++ src/gnome2/note_editor.c Mon Feb 14 15:12:22 2005
+@@ -29,11 +29,11 @@
+ #include <gtkhtml/htmlform.h>
+ #include <gtkhtml/htmlenums.h>
+ #include <gtkhtml/htmlsettings.h>
+ #include <gtkhtml/htmlcolor.h>
+ #include <gtkhtml/htmlcolorset.h>
+-#include <gtkhtml/htmllinktext.h>
++//#include <gtkhtml/htmllinktext.h>
+ #include <gtkhtml/htmlengine-edit.h>
+ #include <gtkhtml/htmlengine-edit-fontstyle.h>
+ #include <gtkhtml/htmlengine-edit-cut-and-paste.h>
+ #include <gtkhtml/htmlselection.h>
+ #include <gtkhtml/htmlengine-search.h>
+@@ -1185,17 +1185,33 @@
+ target = strchr(url, '#');
+ url_copy =
+ target ? g_strndup(url,
+ target - url) : g_strdup(url);
+ new_link =
++ html_text_new(text,
++ GTK_HTML_FONT_STYLE_DEFAULT,
++ html_colorset_get_color(e->
++ settings->
++ color_set,
++ HTMLLinkColor));
++ new_link =
++ html_object_set_link(new_link,
++ html_colorset_get_color(e->
++ settings->
++ color_set,
++ HTMLLinkColor),
++ url_copy, target);
++/*
++ new_link =
+ html_link_text_new(text,
+ GTK_HTML_FONT_STYLE_DEFAULT,
+ html_colorset_get_color(e->
+ settings->
+ color_set,
+ HTMLLinkColor),
+ url_copy, target);
++*/
+ html_engine_paste_object(e, new_link,
+ g_utf8_strlen(text, -1));
+ g_free(url_copy);
+ }
+ }
diff --git a/misc/gnomesword/files/patch-src::gnome2::note_toolbar_style.c b/misc/gnomesword/files/patch-src::gnome2::note_toolbar_style.c
new file mode 100644
index 000000000000..014a022c06c0
--- /dev/null
+++ b/misc/gnomesword/files/patch-src::gnome2::note_toolbar_style.c
@@ -0,0 +1,16 @@
+--- src/gnome2/note_toolbar_style.c.orig Thu Apr 22 14:12:43 2004
++++ src/gnome2/note_toolbar_style.c Mon Feb 14 15:20:54 2005
+@@ -469,11 +469,12 @@
+ DIALOG_DATA * d)
+ {
+ GSHTMLEditorControlData *cd = d->editor;
+ color_combo_set_color(COLOR_COMBO(cd->combo),
+ &html_colorset_get_color_allocated
+- (html->engine->painter,
++ (cd->html->engine->settings->color_set,
++ html->engine->painter,
+ HTMLTextColor)->color);
+
+ }
+
+ /******************************************************************************
diff --git a/misc/gnomesword/files/patch-src::gnome2::toolbar_style.c b/misc/gnomesword/files/patch-src::gnome2::toolbar_style.c
new file mode 100644
index 000000000000..ae8c6cd1c6c3
--- /dev/null
+++ b/misc/gnomesword/files/patch-src::gnome2::toolbar_style.c
@@ -0,0 +1,16 @@
+--- src/gnome2/toolbar_style.c.orig Thu Apr 22 14:12:43 2004
++++ src/gnome2/toolbar_style.c Mon Feb 14 15:23:28 2005
+@@ -460,11 +460,12 @@
+ static void set_color_combo(GtkHTML * html,
+ GSHTMLEditorControlData * cd)
+ {
+ color_combo_set_color(COLOR_COMBO(cd->combo),
+ &html_colorset_get_color_allocated
+- (html->engine->painter,
++ (cd->html->engine->settings->color_set,
++ html->engine->painter,
+ HTMLTextColor)->color);
+
+ }
+
+ /******************************************************************************
diff --git a/misc/gnomesword/pkg-plist b/misc/gnomesword/pkg-plist
index 6ebb6e7655d6..b08c8a0b7ee8 100644
--- a/misc/gnomesword/pkg-plist
+++ b/misc/gnomesword/pkg-plist
@@ -63,4 +63,6 @@ share/locale/uk/LC_MESSAGES/gnomesword.mo
@dirrm share/gnome/help/gnomesword/C/figures
@dirrm share/gnome/help/gnomesword/C
@dirrm share/gnome/help/gnomesword
+@unexec rmdir %D/share/locale/de_DE/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/de_DE 2> /dev/null || true
%%PORTDOCS%%@dirrm %%DOCSDIR%%