aboutsummaryrefslogtreecommitdiff
path: root/misc/gnuls
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-01-13 01:08:29 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-01-13 01:08:29 +0000
commit441e97c94f675c723bfdf67ec61d2f981044a986 (patch)
tree51cd72e1fbfe0a697bbf5035652402b0d3559945 /misc/gnuls
parentaa2a7cc7b2639e34f0b901f8aa65c03aa9c1632d (diff)
downloadports-441e97c94f675c723bfdf67ec61d2f981044a986.tar.gz
ports-441e97c94f675c723bfdf67ec61d2f981044a986.zip
Notes
Diffstat (limited to 'misc/gnuls')
-rw-r--r--misc/gnuls/Makefile29
-rw-r--r--misc/gnuls/distinfo6
-rw-r--r--misc/gnuls/files/extra-patch-stty.c20
-rw-r--r--misc/gnuls/files/patch-aa19
-rw-r--r--misc/gnuls/files/patch-ab20
-rw-r--r--misc/gnuls/files/patch-ac97
-rw-r--r--misc/gnuls/files/patch-ad42
-rw-r--r--misc/gnuls/files/patch-ae66
-rw-r--r--misc/gnuls/files/patch-af22
-rw-r--r--misc/gnuls/files/patch-ag22
-rw-r--r--misc/gnuls/files/patch-ah22
-rw-r--r--misc/gnuls/files/patch-ai33
-rw-r--r--misc/gnuls/pkg-descr2
-rw-r--r--misc/gnuls/pkg-plist4
14 files changed, 48 insertions, 356 deletions
diff --git a/misc/gnuls/Makefile b/misc/gnuls/Makefile
index e62969060d3a..448ed9b09e06 100644
--- a/misc/gnuls/Makefile
+++ b/misc/gnuls/Makefile
@@ -6,17 +6,36 @@
#
PORTNAME= gnuls
-PORTVERSION= 4.1
+PORTVERSION= 6.12
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= fileutils
-DISTNAME= fileutils-${PORTVERSION}
+MASTER_SITE_SUBDIR= coreutils
+DISTNAME= coreutils-${PORTVERSION}
MAINTAINER= bmc@clapper.org
-COMMENT= GNU colorized `ls'
+COMMENT= GNU colorized 'ls'
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-nls
MAN1= gnuls.1 dircolors.1 dir.1 vdir.1
-.include <bsd.port.mk>
+PLIST_FILES= bin/dir \
+ bin/dircolors \
+ bin/gnuls \
+ bin/vdir
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/dir ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/dircolors ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/ls ${PREFIX}/bin/gnuls
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/vdir ${PREFIX}/bin
+ ${CP} ${WRKSRC}/man/ls.1 ${WRKSRC}/man/gnuls.1
+ ${INSTALL_MAN} ${MAN1:S,^,${WRKSRC}/man/,} ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800039
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-stty.c
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/gnuls/distinfo b/misc/gnuls/distinfo
index 4f547bc131c5..6a910373fce7 100644
--- a/misc/gnuls/distinfo
+++ b/misc/gnuls/distinfo
@@ -1,3 +1,3 @@
-MD5 (fileutils-4.1.tar.gz) = 2fa04ceee87e962ddf72f32a2d6b906d
-SHA256 (fileutils-4.1.tar.gz) = 301c60795b011e63f034cfdf7b327b60f1f8f76909337a530b903bb697937188
-SIZE (fileutils-4.1.tar.gz) = 1812537
+MD5 (coreutils-6.12.tar.gz) = 2ca9ac69823dbd567b905a9e9f53c4f6
+SHA256 (coreutils-6.12.tar.gz) = 49d2f703e2310e6328cb6f9d9bae3612c42b3ee5175f449692c5b95e453cf18a
+SIZE (coreutils-6.12.tar.gz) = 9001890
diff --git a/misc/gnuls/files/extra-patch-stty.c b/misc/gnuls/files/extra-patch-stty.c
new file mode 100644
index 000000000000..8704c918a4dc
--- /dev/null
+++ b/misc/gnuls/files/extra-patch-stty.c
@@ -0,0 +1,20 @@
+--- src/stty.c.orig 2007-03-18 14:36:43.000000000 -0700
++++ src/stty.c 2008-08-28 18:54:40.000000000 -0700
+@@ -282,8 +282,6 @@
+ #endif
+ #ifdef TABDLY
+ {"tab3", output, SANE_UNSET, TAB3, TABDLY},
+- {"tab2", output, SANE_UNSET, TAB2, TABDLY},
+- {"tab1", output, SANE_UNSET, TAB1, TABDLY},
+ {"tab0", output, SANE_SET, TAB0, TABDLY},
+ #else
+ # ifdef OXTABS
+@@ -632,7 +630,7 @@
+ fputs (_("\
+ * [-]onocr do not print carriage returns in the first column\n\
+ [-]opost postprocess output\n\
+- * tabN horizontal tab delay style, N in [0..3]\n\
++ * tabN horizontal tab delay style, N in [0,3]\n\
+ * tabs same as tab0\n\
+ * -tabs same as tab3\n\
+ * vtN vertical tab delay style, N in [0..1]\n\
diff --git a/misc/gnuls/files/patch-aa b/misc/gnuls/files/patch-aa
deleted file mode 100644
index 77ae9523f95c..000000000000
--- a/misc/gnuls/files/patch-aa
+++ /dev/null
@@ -1,19 +0,0 @@
-*** Makefile.in.orig Sun Aug 31 14:13:23 2003
---- Makefile.in Sun Aug 31 14:13:37 2003
-***************
-*** 121,127 ****
-
- AUTOMAKE_OPTIONS = gnits 1.2h
-
-! SUBDIRS = lib intl src doc man m4 po tests
- EXTRA_DIST = Makefile.maint GNUmakefile ChangeLog-1997 \
- .kludge-stamp .prev-version
-
---- 121,127 ----
-
- AUTOMAKE_OPTIONS = gnits 1.2h
-
-! SUBDIRS = lib intl src man
- EXTRA_DIST = Makefile.maint GNUmakefile ChangeLog-1997 \
- .kludge-stamp .prev-version
-
diff --git a/misc/gnuls/files/patch-ab b/misc/gnuls/files/patch-ab
deleted file mode 100644
index 71d38f5eb53a..000000000000
--- a/misc/gnuls/files/patch-ab
+++ /dev/null
@@ -1,20 +0,0 @@
-*** intl/Makefile.in.orig Fri Feb 19 19:20:37 1999
---- intl/Makefile.in Fri Feb 19 19:20:54 1999
-***************
-*** 109,115 ****
- # where configure found a previously installed GNU gettext library.
- # If you want to use the one which comes with this version of the
- # package, you have to use `configure --with-included-gettext'.
-! install: install-exec install-data
- install-exec: all
- if test "$(PACKAGE)" = "gettext" \
- && test '@INTLOBJS@' = '$(GETTOBJS)'; then \
---- 109,116 ----
- # where configure found a previously installed GNU gettext library.
- # If you want to use the one which comes with this version of the
- # package, you have to use `configure --with-included-gettext'.
-! install:
-! @echo Nothing to install in intl
- install-exec: all
- if test "$(PACKAGE)" = "gettext" \
- && test '@INTLOBJS@' = '$(GETTOBJS)'; then \
diff --git a/misc/gnuls/files/patch-ac b/misc/gnuls/files/patch-ac
deleted file mode 100644
index 0d6818b0652a..000000000000
--- a/misc/gnuls/files/patch-ac
+++ /dev/null
@@ -1,97 +0,0 @@
-*** src/Makefile.in.orig Sun Apr 29 07:40:37 2001
---- src/Makefile.in Wed Sep 3 09:22:13 2003
-***************
-*** 121,129 ****
-
- EXTRA_PROGRAMS = df
-
-! bin_PROGRAMS = chgrp chown chmod cp dd dircolors du \
-! ginstall ln dir vdir ls mkdir \
-! mkfifo mknod mv rm rmdir shred sync touch @DF_PROG@
-
-
- datadir = $(prefix)/@DATADIRNAME@
---- 121,127 ----
-
- EXTRA_PROGRAMS = df
-
-! bin_PROGRAMS = gnuls dir vdir dircolors
-
-
- datadir = $(prefix)/@DATADIRNAME@
-***************
-*** 173,183 ****
- CONFIG_HEADER = $(top_builddir)/config.h
- CONFIG_CLEAN_FILES =
- EXTRA_PROGRAMS = df$(EXEEXT)
-! bin_PROGRAMS = chgrp$(EXEEXT) chown$(EXEEXT) chmod$(EXEEXT) cp$(EXEEXT) \
-! dd$(EXEEXT) dircolors$(EXEEXT) du$(EXEEXT) ginstall$(EXEEXT) \
-! ln$(EXEEXT) dir$(EXEEXT) vdir$(EXEEXT) ls$(EXEEXT) mkdir$(EXEEXT) \
-! mkfifo$(EXEEXT) mknod$(EXEEXT) mv$(EXEEXT) rm$(EXEEXT) rmdir$(EXEEXT) \
-! shred$(EXEEXT) sync$(EXEEXT) touch$(EXEEXT) @DF_PROG@
- PROGRAMS = $(bin_PROGRAMS)
-
- CPPFLAGS = @CPPFLAGS@
---- 171,177 ----
- CONFIG_HEADER = $(top_builddir)/config.h
- CONFIG_CLEAN_FILES =
- EXTRA_PROGRAMS = df$(EXEEXT)
-! bin_PROGRAMS = dircolors$(EXEEXT) dir$(EXEEXT) vdir$(EXEEXT) gnuls$(EXEEXT)
- PROGRAMS = $(bin_PROGRAMS)
-
- CPPFLAGS = @CPPFLAGS@
-***************
-*** 242,248 ****
- am_ls_OBJECTS = ls$U.$(OBJEXT) ls-ls$U.$(OBJEXT)
- ls_OBJECTS = $(am_ls_OBJECTS)
- ls_DEPENDENCIES = ../lib/libfetish.a
-! ls_LDFLAGS =
- mkdir_SOURCES = mkdir.c
- mkdir_OBJECTS = mkdir$U.$(OBJEXT)
- mkdir_LDADD = $(LDADD)
---- 236,242 ----
- am_ls_OBJECTS = ls$U.$(OBJEXT) ls-ls$U.$(OBJEXT)
- ls_OBJECTS = $(am_ls_OBJECTS)
- ls_DEPENDENCIES = ../lib/libfetish.a
-! ls_LDFLAGS = -o gnuls
- mkdir_SOURCES = mkdir.c
- mkdir_OBJECTS = mkdir$U.$(OBJEXT)
- mkdir_LDADD = $(LDADD)
-***************
-*** 316,323 ****
- DIST_COMMON = $(noinst_HEADERS) Makefile.am Makefile.in ansi2knr.1 \
- ansi2knr.c
-
-! SOURCES = $(chgrp_SOURCES) chmod.c $(chown_SOURCES) $(cp_SOURCES) dd.c df.c $(dir_SOURCES) dircolors.c du.c $(ginstall_SOURCES) ln.c $(ls_SOURCES) mkdir.c mkfifo.c mknod.c $(mv_SOURCES) $(rm_SOURCES) rmdir.c shred.c sync.c touch.c $(vdir_SOURCES)
-! OBJECTS = $(am_chgrp_OBJECTS) chmod$U.$(OBJEXT) $(am_chown_OBJECTS) $(am_cp_OBJECTS) dd$U.$(OBJEXT) df$U.$(OBJEXT) $(am_dir_OBJECTS) dircolors$U.$(OBJEXT) du$U.$(OBJEXT) $(am_ginstall_OBJECTS) ln$U.$(OBJEXT) $(am_ls_OBJECTS) mkdir$U.$(OBJEXT) mkfifo$U.$(OBJEXT) mknod$U.$(OBJEXT) $(am_mv_OBJECTS) $(am_rm_OBJECTS) rmdir$U.$(OBJEXT) shred$U.$(OBJEXT) sync$U.$(OBJEXT) touch$U.$(OBJEXT) $(am_vdir_OBJECTS)
-
- all: $(BUILT_SOURCES)
- $(MAKE) $(AM_MAKEFLAGS) all-am
---- 310,317 ----
- DIST_COMMON = $(noinst_HEADERS) Makefile.am Makefile.in ansi2knr.1 \
- ansi2knr.c
-
-! SOURCES = $(dir_SOURCES) dircolors.c $(ls_SOURCES) $(vdir_SOURCES)
-! OBJECTS = $(am_dir_OBJECTS) dircolors$U.$(OBJEXT) $(am_ls_OBJECTS) $(am_vdir_OBJECTS)
-
- all: $(BUILT_SOURCES)
- $(MAKE) $(AM_MAKEFLAGS) all-am
-***************
-*** 415,422 ****
- @rm -f ln
- $(LINK) $(ln_LDFLAGS) $(ln_OBJECTS) $(ln_LDADD) $(LIBS)
-
-! ls: $(ls_OBJECTS) $(ls_DEPENDENCIES)
-! @rm -f ls
- $(LINK) $(ls_LDFLAGS) $(ls_OBJECTS) $(ls_LDADD) $(LIBS)
-
- mkdir: $(mkdir_OBJECTS) $(mkdir_DEPENDENCIES)
---- 409,416 ----
- @rm -f ln
- $(LINK) $(ln_LDFLAGS) $(ln_OBJECTS) $(ln_LDADD) $(LIBS)
-
-! gnuls: $(ls_OBJECTS) $(ls_DEPENDENCIES)
-! @rm -f gnuls
- $(LINK) $(ls_LDFLAGS) $(ls_OBJECTS) $(ls_LDADD) $(LIBS)
-
- mkdir: $(mkdir_OBJECTS) $(mkdir_DEPENDENCIES)
diff --git a/misc/gnuls/files/patch-ad b/misc/gnuls/files/patch-ad
deleted file mode 100644
index 4679c9b19242..000000000000
--- a/misc/gnuls/files/patch-ad
+++ /dev/null
@@ -1,42 +0,0 @@
-*** man/Makefile.in.orig Sun Aug 31 13:59:34 2003
---- man/Makefile.in Sun Aug 31 14:00:15 2003
-***************
-*** 118,126 ****
- l = @l@
-
-
-! man_MANS = chgrp.1 chmod.1 chown.1 cp.1 dir.1 dd.1 df.1 dircolors.1 \
-! du.1 ginstall.1 ln.1 ls.1 mkdir.1 mkfifo.1 mknod.1 mv.1 rm.1 rmdir.1 \
-! shred.1 sync.1 touch.1 vdir.1
-
- man_aux = $(man_MANS:.1=.x)
-
---- 118,124 ----
- l = @l@
-
-
-! man_MANS = dir.1 dircolors.1 gnuls.1 vdir.1
-
- man_aux = $(man_MANS:.1=.x)
-
-***************
-*** 148,154 ****
- NROFF = nroff
- DIST_COMMON = Makefile.am Makefile.in
-
-! all: all-am
-
- .SUFFIXES:
-
---- 146,156 ----
- NROFF = nroff
- DIST_COMMON = Makefile.am Makefile.in
-
-! all: freebsd-setup all-am
-!
-! freebsd-setup:
-! @cp ls.1 gnuls.1
-! @cp ls.x gnuls.x
-
- .SUFFIXES:
-
diff --git a/misc/gnuls/files/patch-ae b/misc/gnuls/files/patch-ae
deleted file mode 100644
index df0e95365aec..000000000000
--- a/misc/gnuls/files/patch-ae
+++ /dev/null
@@ -1,66 +0,0 @@
-*** man/ls.1.orig Sun Aug 31 14:01:47 2003
---- man/ls.1 Sun Aug 31 14:04:59 2003
-***************
-*** 1,9 ****
- .\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.24.
-! .TH LS "1" "April 2001" "ls (fileutils) 4.1" FSF
- .SH NAME
-! ls \- list directory contents
- .SH SYNOPSIS
-! .B ls
- [\fIOPTION\fR]... [\fIFILE\fR]...
- .SH DESCRIPTION
- .\" Add any additional description here
---- 1,9 ----
- .\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.24.
-! .TH GNULS "1" "April 2001" "ls (fileutils) 4.1" FSF
- .SH NAME
-! gnuls \- list directory contents
- .SH SYNOPSIS
-! .B gnuls
- [\fIOPTION\fR]... [\fIFILE\fR]...
- .SH DESCRIPTION
- .\" Add any additional description here
-***************
-*** 113,119 ****
- .TP
- \fB\-\-show\-control\-chars\fR
- show non graphic characters as-is (default
-! unless program is `ls' and output is a terminal)
- .TP
- \fB\-Q\fR, \fB\-\-quote\-name\fR
- enclose entry names in double quotes
---- 113,119 ----
- .TP
- \fB\-\-show\-control\-chars\fR
- show non graphic characters as-is (default
-! unless program is `gnuls' and output is a terminal)
- .TP
- \fB\-Q\fR, \fB\-\-quote\-name\fR
- enclose entry names in double quotes
-***************
-*** 196,207 ****
- warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
- .SH "SEE ALSO"
- The full documentation for
-! .B ls
- is maintained as a Texinfo manual. If the
- .B info
-! and
-! .B ls
-! programs are properly installed at your site, the command
- .IP
- .B info ls
- .PP
---- 196,206 ----
- warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
- .SH "SEE ALSO"
- The full documentation for
-! .B gnuls
- is maintained as a Texinfo manual. If the
- .B info
-! program and the full suite of GNU fileutils are properly installed
-! at your site, the command
- .IP
- .B info ls
- .PP
diff --git a/misc/gnuls/files/patch-af b/misc/gnuls/files/patch-af
deleted file mode 100644
index b2b08166dfb4..000000000000
--- a/misc/gnuls/files/patch-af
+++ /dev/null
@@ -1,22 +0,0 @@
-*** man/dircolors.1.orig Sun Aug 31 14:05:39 2003
---- man/dircolors.1 Sun Aug 31 14:06:07 2003
-***************
-*** 43,51 ****
- .B dircolors
- is maintained as a Texinfo manual. If the
- .B info
-! and
-! .B dircolors
-! programs are properly installed at your site, the command
- .IP
- .B info dircolors
- .PP
---- 43,50 ----
- .B dircolors
- is maintained as a Texinfo manual. If the
- .B info
-! program and the full suite of GNU fileutils
-! are properly installed at your site, the command
- .IP
- .B info dircolors
- .PP
diff --git a/misc/gnuls/files/patch-ag b/misc/gnuls/files/patch-ag
deleted file mode 100644
index c7b0aa54d27e..000000000000
--- a/misc/gnuls/files/patch-ag
+++ /dev/null
@@ -1,22 +0,0 @@
-*** man/dir.1.orig Sun Aug 31 14:06:52 2003
---- man/dir.1 Sun Aug 31 14:07:07 2003
-***************
-*** 199,207 ****
- .B dir
- is maintained as a Texinfo manual. If the
- .B info
-! and
-! .B dir
-! programs are properly installed at your site, the command
- .IP
- .B info dir
- .PP
---- 199,206 ----
- .B dir
- is maintained as a Texinfo manual. If the
- .B info
-! program and the full suite of GNU fileutils
-! are properly installed at your site, the command
- .IP
- .B info dir
- .PP
diff --git a/misc/gnuls/files/patch-ah b/misc/gnuls/files/patch-ah
deleted file mode 100644
index 46bab869f2a5..000000000000
--- a/misc/gnuls/files/patch-ah
+++ /dev/null
@@ -1,22 +0,0 @@
-*** man/vdir.1.orig Sun Aug 31 14:07:48 2003
---- man/vdir.1 Sun Aug 31 14:08:01 2003
-***************
-*** 199,207 ****
- .B vdir
- is maintained as a Texinfo manual. If the
- .B info
-! and
-! .B vdir
-! programs are properly installed at your site, the command
- .IP
- .B info vdir
- .PP
---- 199,206 ----
- .B vdir
- is maintained as a Texinfo manual. If the
- .B info
-! program and the full suite of GNU fileutils
-! are properly installed at your site, the command
- .IP
- .B info vdir
- .PP
diff --git a/misc/gnuls/files/patch-ai b/misc/gnuls/files/patch-ai
deleted file mode 100644
index cd7bde9a1593..000000000000
--- a/misc/gnuls/files/patch-ai
+++ /dev/null
@@ -1,33 +0,0 @@
-*** lib/Makefile.in.orig Sat Feb 12 20:16:15 2005
---- lib/Makefile.in Sat Feb 12 20:17:13 2005
-***************
-*** 880,899 ****
- # On systems with glibc-2.1 or newer, the file is redundant, therefore we
- # avoid installing it.
-
-! all-local: charset.alias ref-add.sed ref-del.sed lstat.c stat.c
- install-exec-local: all-local
-- $(mkinstalldirs) $(DESTDIR)$(libdir)
-- if test -f $(charset_alias); then \
-- sed -f ref-add.sed $(charset_alias) > $(charset_tmp) ; \
-- $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
-- rm -f $(charset_tmp) ; \
-- else \
-- if test @GLIBC21@ = no; then \
-- sed -f ref-add.sed charset.alias > $(charset_tmp) ; \
-- $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
-- rm -f $(charset_tmp) ; \
-- fi ; \
-- fi
-
- uninstall-local: all-local
- if test -f $(charset_alias); then \
---- 880,887 ----
- # On systems with glibc-2.1 or newer, the file is redundant, therefore we
- # avoid installing it.
-
-! all-local: ref-add.sed ref-del.sed lstat.c stat.c
- install-exec-local: all-local
-
- uninstall-local: all-local
- if test -f $(charset_alias); then \
diff --git a/misc/gnuls/pkg-descr b/misc/gnuls/pkg-descr
index 82dc47b6c742..e78140b06cdd 100644
--- a/misc/gnuls/pkg-descr
+++ b/misc/gnuls/pkg-descr
@@ -7,7 +7,7 @@ individual man pages for details on each program.
NOTES:
-1. This port modifies the GNU `fileutils' make procedure so that it
+1. This port modifies the GNU `coreutils' make procedure so that it
installs only programs and man pages listed above. In particular, it
does not install the various GNU info files associated with the
programs.
diff --git a/misc/gnuls/pkg-plist b/misc/gnuls/pkg-plist
deleted file mode 100644
index 7b1429281d4a..000000000000
--- a/misc/gnuls/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/dir
-bin/dircolors
-bin/gnuls
-bin/vdir