aboutsummaryrefslogtreecommitdiff
path: root/misc/gonvert/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-26 20:19:57 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-26 20:19:57 +0000
commit4f35fc2f96ad75973276546bfe3cd4421cd2337b (patch)
tree16650bb7bcb2d290434cbe80bcb4b78220987e6a /misc/gonvert/Makefile
parentafb8372e1c66fcace047f03f7dd0026f69bc39f1 (diff)
downloadports-4f35fc2f96ad75973276546bfe3cd4421cd2337b.tar.gz
ports-4f35fc2f96ad75973276546bfe3cd4421cd2337b.zip
Notes
Diffstat (limited to 'misc/gonvert/Makefile')
-rw-r--r--misc/gonvert/Makefile28
1 files changed, 19 insertions, 9 deletions
diff --git a/misc/gonvert/Makefile b/misc/gonvert/Makefile
index ca70072a7998..d32b58f0eac9 100644
--- a/misc/gonvert/Makefile
+++ b/misc/gonvert/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= gonvert
-PORTVERSION= 0.1.5
-PORTREVISION= 0
+PORTVERSION= 0.1.7
CATEGORIES= misc python gnome
MASTER_SITES= http://www.unihedron.com/projects/gonvert/downloads/
@@ -17,16 +16,27 @@ COMMENT= A conversion utility that allows conversion between many units
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:${PORTSDIR}/x11-toolkits/py-gtk2
-USE_REINPLACE= yes
-USE_PYTHON= yes
USE_X_PREFIX= yes
+USE_GNOME= gnomehier
+USE_PYTHON= yes
USE_GMAKE= yes
NO_BUILD= yes
-post-patch:
- @${REINPLACE_CMD} -e "s,/usr/bin/python,${PYTHON_CMD},g" ${WRKSRC}/${PORTNAME}
- @${REINPLACE_CMD} -e "s,gnome-config,${GNOME_CONFIG},g ; \
- s,--directory,-d --mode=755,g ; \
- s,install ,install -c ,g" ${WRKSRC}/Makefile
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/gonvert ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/gonvert.desktop \
+ ${PREFIX}/share/gnome/apps/Utilities
+ ${INSTALL_DATA} ${WRKSRC}/pixmaps/gonvert_icon.png \
+ ${PREFIX}/share/gnome/pixmaps
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/gonvert.glade ${DATADIR}
+ @${MKDIR} ${DATADIR}/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/pixmaps/*.png ${DATADIR}/pixmaps
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in README CHANGELOG FAQ README THANKS TODO
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>