aboutsummaryrefslogtreecommitdiff
path: root/misc/grdb
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-09-09 05:09:11 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-09-09 05:09:11 +0000
commit2ed30a3867e78ff39dbc374db07f73634f77cc54 (patch)
tree0c6371bdbf3b4bc65a203f78e2267cd616370bff /misc/grdb
parent037a94ca9a48b4d6eff023ec7f07d251890c3163 (diff)
downloadports-2ed30a3867e78ff39dbc374db07f73634f77cc54.tar.gz
ports-2ed30a3867e78ff39dbc374db07f73634f77cc54.zip
Notes
Diffstat (limited to 'misc/grdb')
-rw-r--r--misc/grdb/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/misc/grdb/Makefile b/misc/grdb/Makefile
index 96b251f7949f..56f4b9ffb8a5 100644
--- a/misc/grdb/Makefile
+++ b/misc/grdb/Makefile
@@ -16,27 +16,28 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_X_PREFIX= yes
USE_GNOMENG= yes
+USE_GNOME= gtk12
WANT_GNOME= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mgtk12}!=""
-USE_GNOME+= gtk12
-PKGNAMESUFFIX= -gtk
+.if ${HAVE_GNOME:Mgnomelibs}!=""
+USE_GNOME+= gnomeprefix gnomehack gnomelibs
+PKGNAMESUFFIX= -gnome
+PLIST_SUB= DATADIR="share/gnome"
.else
CONFIGURE_ARGS= --disable-gnome
+PLIST_SUB= DATADIR="share"
.endif
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
- s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g'
post-install:
.if !defined(NOPORTDOCS)