aboutsummaryrefslogtreecommitdiff
path: root/misc/gretl/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-07 03:09:35 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-07 03:09:35 +0000
commit68bcf132a56ad9a5925ee8fa1c8d5a60c81fa3cc (patch)
treeffa729ecb3fc3d28c4c37a208295ad1a88d6b39b /misc/gretl/Makefile
parent95e52060d42172e57d5e1f1f84ff6bfe1c9622b9 (diff)
downloadports-68bcf132a56ad9a5925ee8fa1c8d5a60c81fa3cc.tar.gz
ports-68bcf132a56ad9a5925ee8fa1c8d5a60c81fa3cc.zip
Notes
Diffstat (limited to 'misc/gretl/Makefile')
-rw-r--r--misc/gretl/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/misc/gretl/Makefile b/misc/gretl/Makefile
index eb0f83e36273..f1d5bd88d343 100644
--- a/misc/gretl/Makefile
+++ b/misc/gretl/Makefile
@@ -24,23 +24,24 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
WANT_GNOME= yes
USE_GNOME= gnometarget gtk20 libxml2
+USE_GETTEXT= yes
USE_GMAKE= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DGNUPLOT_PNG" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-static --enable-shared --with-gmake
ALL_TARGET= # empty
-INSTALLS_SHLIB= yes
MAN1= gretl.1 gretl-config.1
.include <bsd.port.pre.mk>
.if ${ARCH} == "alpha"
-BROKEN= "math/lapack appears to be broken on alpha"
+BROKEN= math/lapack appears to be broken on alpha
.endif
-.if ${OSVERSION} < 500018
+.if ${OSVERSION} < 500018 || exists(${LOCALBASE}/lib/libreadline.so.5)
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
@@ -49,8 +50,10 @@ PKGNAMESUFFIX= -gnome
USE_GNOME+= gnomeprefix gtksourceview libgnomeui
GCONF_SCHEMAS= gretl.schemas
DATADIR= ${PREFIX}/share/gnome/${PORTNAME}
+PLIST_SUB+= GNOMEUI=""
.else
CONFIGURE_ARGS+= --without-gnome --without-gtksourceview
+PLIST_SUB+= GNOMEUI="@comment "
.endif
.include <bsd.port.post.mk>