aboutsummaryrefslogtreecommitdiff
path: root/misc/gretl/files
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 13:34:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 13:34:09 +0000
commit5d824297fb72f7719603bab88c950c2263150191 (patch)
treed99803d781f2caf4f1671dbe7827e7e62a20fac9 /misc/gretl/files
parent3639a9cce1809d50e83746e4142c2b611666fd8a (diff)
downloadports-5d824297fb72f7719603bab88c950c2263150191.tar.gz
ports-5d824297fb72f7719603bab88c950c2263150191.zip
Notes
Diffstat (limited to 'misc/gretl/files')
-rw-r--r--misc/gretl/files/patch-Makefile.in6
-rw-r--r--misc/gretl/files/patch-aclocal.m4207
-rw-r--r--misc/gretl/files/patch-cli::Makefile.in48
-rw-r--r--misc/gretl/files/patch-configure10
-rw-r--r--misc/gretl/files/patch-doc::manual.xml11
-rw-r--r--misc/gretl/files/patch-gnome::Makefile.in42
-rw-r--r--misc/gretl/files/patch-gui2::Makefile.in54
-rw-r--r--misc/gretl/files/patch-gui2::gretl.c20
-rw-r--r--misc/gretl/files/patch-gui2::omf-install::Makefile.in23
-rw-r--r--misc/gretl/files/patch-gui::Makefile.in29
-rw-r--r--misc/gretl/files/patch-lib::Makefile.in59
-rw-r--r--misc/gretl/files/patch-lib::src::gretl_utils.c13
-rw-r--r--misc/gretl/files/patch-plugin::Makefile.in56
-rw-r--r--misc/gretl/files/patch-po::Makefile.in.in11
-rw-r--r--misc/gretl/files/patch-share::Makefile.in8
-rw-r--r--misc/gretl/files/patch-tools::ltmain.sh49
16 files changed, 532 insertions, 114 deletions
diff --git a/misc/gretl/files/patch-Makefile.in b/misc/gretl/files/patch-Makefile.in
index 18ccc2247eff..c4dab95e3ebc 100644
--- a/misc/gretl/files/patch-Makefile.in
+++ b/misc/gretl/files/patch-Makefile.in
@@ -1,7 +1,7 @@
---- Makefile.in.orig Tue Mar 12 02:54:07 2002
-+++ Makefile.in Thu May 2 01:42:34 2002
+--- Makefile.in.orig Thu Sep 12 00:35:22 2002
++++ Makefile.in Mon Oct 21 10:02:37 2002
@@ -22,8 +22,9 @@
- CC = gcc
+ GUIDIR = gui
endif
-INSTALL_PROGRAM = ${INSTALL} -m 755
diff --git a/misc/gretl/files/patch-aclocal.m4 b/misc/gretl/files/patch-aclocal.m4
new file mode 100644
index 000000000000..fb147833b171
--- /dev/null
+++ b/misc/gretl/files/patch-aclocal.m4
@@ -0,0 +1,207 @@
+--- aclocal.m4.dist Thu Oct 10 11:39:35 2002
++++ aclocal.m4 Mon Oct 21 09:34:35 2002
+@@ -11,7 +11,7 @@
+ # even the implied warranty of MERCHANTABILITY or FITNESS FOR A
+ # PARTICULAR PURPOSE.
+
+-# gettext.m4 serial 13 (gettext-0.11.1)
++# gettext.m4 serial 17 (gettext-0.11.5)
+ dnl Copyright (C) 1995-2002 Free Software Foundation, Inc.
+ dnl This file is free software, distributed under the terms of the GNU
+ dnl General Public License. As a special exception to the GNU General
+@@ -46,7 +46,9 @@
+ dnl $(top_builddir)/intl/libintl.a will be created.
+ dnl If NEEDSYMBOL is specified and is 'need-ngettext', then GNU gettext
+ dnl implementations (in libc or libintl) without the ngettext() function
+-dnl will be ignored.
++dnl will be ignored. If NEEDSYMBOL is specified and is
++dnl 'need-formatstring-macros', then GNU gettext implementations that don't
++dnl support the ISO C 99 <inttypes.h> formatstring macros will be ignored.
+ dnl INTLDIR is used to find the intl libraries. If empty,
+ dnl the value `$(top_builddir)/intl/' is used.
+ dnl
+@@ -73,9 +75,9 @@
+ ifelse([$1], [], , [ifelse([$1], [external], , [ifelse([$1], [no-libtool], , [ifelse([$1], [use-libtool], ,
+ [errprint([ERROR: invalid first argument to AM_GNU_GETTEXT
+ ])])])])])
+- ifelse([$2], [], , [ifelse([$2], [need-ngettext], ,
++ ifelse([$2], [], , [ifelse([$2], [need-ngettext], , [ifelse([$2], [need-formatstring-macros], ,
+ [errprint([ERROR: invalid second argument to AM_GNU_GETTEXT
+-])])])
++])])])])
+ define(gt_included_intl, ifelse([$1], [external], [no], [yes]))
+ define(gt_libtool_suffix_prefix, ifelse([$1], [use-libtool], [l], []))
+
+@@ -88,6 +90,21 @@
+ AC_REQUIRE([AC_LIB_PREPARE_PREFIX])
+ AC_REQUIRE([AC_LIB_RPATH])
+
++ dnl Sometimes libintl requires libiconv, so first search for libiconv.
++ dnl Ideally we would do this search only after the
++ dnl if test "$USE_NLS" = "yes"; then
++ dnl if test "$gt_cv_func_gnugettext_libc" != "yes"; then
++ dnl tests. But if configure.in invokes AM_ICONV after AM_GNU_GETTEXT
++ dnl the configure script would need to contain the same shell code
++ dnl again, outside any 'if'. There are two solutions:
++ dnl - Invoke AM_ICONV_LINKFLAGS_BODY here, outside any 'if'.
++ dnl - Control the expansions in more detail using AC_PROVIDE_IFELSE.
++ dnl Since AC_PROVIDE_IFELSE is only in autoconf >= 2.52 and not
++ dnl documented, we avoid it.
++ ifelse(gt_included_intl, yes, , [
++ AC_REQUIRE([AM_ICONV_LINKFLAGS_BODY])
++ ])
++
+ AC_MSG_CHECKING([whether NLS is requested])
+ dnl Default is enabled NLS
+ AC_ARG_ENABLE(nls,
+@@ -123,13 +140,20 @@
+ dnl to fall back to GNU NLS library.
+
+ dnl Add a version number to the cache macros.
+- define([gt_api_version], ifelse([$2], [need-ngettext], 2, 1))
++ define([gt_api_version], ifelse([$2], [need-formatstring-macros], 3, ifelse([$2], [need-ngettext], 2, 1)))
+ define([gt_cv_func_gnugettext_libc], [gt_cv_func_gnugettext]gt_api_version[_libc])
+ define([gt_cv_func_gnugettext_libintl], [gt_cv_func_gnugettext]gt_api_version[_libintl])
+
+ AC_CACHE_CHECK([for GNU gettext in libc], gt_cv_func_gnugettext_libc,
+ [AC_TRY_LINK([#include <libintl.h>
+-extern int _nl_msg_cat_cntr;
++]ifelse([$2], [need-formatstring-macros],
++[#ifndef __GNU_GETTEXT_SUPPORTED_REVISION
++#define __GNU_GETTEXT_SUPPORTED_REVISION(major) ((major) == 0 ? 0 : -1)
++#endif
++changequote(,)dnl
++typedef int array [2 * (__GNU_GETTEXT_SUPPORTED_REVISION(0) >= 1) - 1];
++changequote([,])dnl
++], [])[extern int _nl_msg_cat_cntr;
+ extern int *_nl_domain_bindings;],
+ [bindtextdomain ("", "");
+ return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_domain_bindings],
+@@ -154,30 +178,42 @@
+ LIBS="$LIBS $LIBINTL"
+ dnl Now see whether libintl exists and does not depend on libiconv.
+ AC_TRY_LINK([#include <libintl.h>
+-extern int _nl_msg_cat_cntr;
+-extern int *_nl_domain_bindings;
++]ifelse([$2], [need-formatstring-macros],
++[#ifndef __GNU_GETTEXT_SUPPORTED_REVISION
++#define __GNU_GETTEXT_SUPPORTED_REVISION(major) ((major) == 0 ? 0 : -1)
++#endif
++changequote(,)dnl
++typedef int array [2 * (__GNU_GETTEXT_SUPPORTED_REVISION(0) >= 1) - 1];
++changequote([,])dnl
++], [])[extern int _nl_msg_cat_cntr;
+ extern
+ #ifdef __cplusplus
+ "C"
+ #endif
+ const char *_nl_expand_alias ();],
+ [bindtextdomain ("", "");
+-return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)],
++return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_expand_alias (0)],
+ gt_cv_func_gnugettext_libintl=yes,
+ gt_cv_func_gnugettext_libintl=no)
+ dnl Now see whether libintl exists and depends on libiconv.
+ if test "$gt_cv_func_gnugettext_libintl" != yes && test -n "$LIBICONV"; then
+ LIBS="$LIBS $LIBICONV"
+ AC_TRY_LINK([#include <libintl.h>
+-extern int _nl_msg_cat_cntr;
+-extern int *_nl_domain_bindings;
++]ifelse([$2], [need-formatstring-macros],
++[#ifndef __GNU_GETTEXT_SUPPORTED_REVISION
++#define __GNU_GETTEXT_SUPPORTED_REVISION(major) ((major) == 0 ? 0 : -1)
++#endif
++changequote(,)dnl
++typedef int array [2 * (__GNU_GETTEXT_SUPPORTED_REVISION(0) >= 1) - 1];
++changequote([,])dnl
++], [])[extern int _nl_msg_cat_cntr;
+ extern
+ #ifdef __cplusplus
+ "C"
+ #endif
+ const char *_nl_expand_alias ();],
+ [bindtextdomain ("", "");
+-return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)],
++return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_expand_alias (0)],
+ [LIBINTL="$LIBINTL $LIBICONV"
+ LTLIBINTL="$LTLIBINTL $LTLIBICONV"
+ gt_cv_func_gnugettext_libintl=yes
+@@ -465,7 +501,7 @@
+ ;;
+ esac
+ done],
+- [# Capture the value of obsolete $ALL_LINGUAS because we need it to compute
++ [# Capture the value of obsolete ALL_LINGUAS because we need it to compute
+ # POFILES, GMOFILES, UPDATEPOFILES, DUMMYPOFILES, CATALOGS. But hide it
+ # from automake.
+ eval 'ALL_LINGUAS''="$ALL_LINGUAS"'
+@@ -494,6 +530,10 @@
+ AC_REQUIRE([AC_FUNC_ALLOCA])dnl
+ AC_REQUIRE([AC_FUNC_MMAP])dnl
+ AC_REQUIRE([jm_GLIBC21])dnl
++ AC_REQUIRE([gt_INTDIV0])dnl
++ AC_REQUIRE([jm_AC_TYPE_UINTMAX_T])dnl
++ AC_REQUIRE([gt_HEADER_INTTYPES_H])dnl
++ AC_REQUIRE([gt_INTTYPES_PRI])dnl
+
+ AC_CHECK_HEADERS([argz.h limits.h locale.h nl_types.h malloc.h stddef.h \
+ stdlib.h string.h unistd.h sys/param.h])
+@@ -503,7 +543,9 @@
+
+ AM_ICONV
+ AM_LANGINFO_CODESET
+- AM_LC_MESSAGES
++ if test $ac_cv_header_locale_h = yes; then
++ AM_LC_MESSAGES
++ fi
+
+ dnl intl/plural.c is generated from intl/plural.y. It requires bison,
+ dnl because plural.y uses bison specific features. It requires at least
+@@ -1322,7 +1364,7 @@
+ AC_LIB_PROG_LD_GNU
+ ])
+
+-# iconv.m4 serial AM3 (gettext-0.11)
++# iconv.m4 serial AM4 (gettext-0.11.3)
+ dnl Copyright (C) 2000-2002 Free Software Foundation, Inc.
+ dnl This file is free software, distributed under the terms of the GNU
+ dnl General Public License. As a special exception to the GNU General
+@@ -1332,11 +1374,8 @@
+
+ dnl From Bruno Haible.
+
+-AC_DEFUN([AM_ICONV_LINK],
++AC_DEFUN([AM_ICONV_LINKFLAGS_BODY],
+ [
+- dnl Some systems have iconv in libc, some have it in libiconv (OSF/1 and
+- dnl those with the standalone portable GNU libiconv installed).
+-
+ dnl Prerequisites of AC_LIB_LINKFLAGS_BODY.
+ AC_REQUIRE([AC_LIB_PREPARE_PREFIX])
+ AC_REQUIRE([AC_LIB_RPATH])
+@@ -1344,6 +1383,16 @@
+ dnl Search for libiconv and define LIBICONV, LTLIBICONV and INCICONV
+ dnl accordingly.
+ AC_LIB_LINKFLAGS_BODY([iconv])
++])
++
++AC_DEFUN([AM_ICONV_LINK],
++[
++ dnl Some systems have iconv in libc, some have it in libiconv (OSF/1 and
++ dnl those with the standalone portable GNU libiconv installed).
++
++ dnl Search for libiconv and define LIBICONV, LTLIBICONV and INCICONV
++ dnl accordingly.
++ AC_REQUIRE([AM_ICONV_LINKFLAGS_BODY])
+
+ dnl Add $INCICONV to CPPFLAGS before performing the following checks,
+ dnl because if the user has installed libiconv and not disabled its use
+@@ -1393,7 +1442,7 @@
+
+ AC_DEFUN([AM_ICONV],
+ [
+- AC_REQUIRE([AM_ICONV_LINK])
++ AM_ICONV_LINK
+ if test "$am_cv_func_iconv" = yes; then
+ AC_MSG_CHECKING([for iconv declaration])
+ AC_CACHE_VAL(am_cv_proto_iconv, [
diff --git a/misc/gretl/files/patch-cli::Makefile.in b/misc/gretl/files/patch-cli::Makefile.in
new file mode 100644
index 000000000000..afef1f23fac4
--- /dev/null
+++ b/misc/gretl/files/patch-cli::Makefile.in
@@ -0,0 +1,48 @@
+--- cli/Makefile.in.orig Tue Nov 12 04:28:19 2002
++++ cli/Makefile.in Mon Nov 18 20:00:01 2002
+@@ -15,6 +15,10 @@
+ RL_OBJ = @RL_OBJ@
+ USE_NLS = @USE_NLS@
+
++CPPFLAGS = @CPPFLAGS@
++LDFLAGS = @LDFLAGS@
++INTL_LIBS = @LTLIBINTL@
++
+ ifeq ($(CC),)
+ CC = gcc
+ endif
+@@ -25,15 +29,14 @@
+ LN = ln -sf
+ endif
+ ifeq ($(USE_NLS),yes)
+- datadir = @datadir@
+- localedir = $(datadir)/locale
++ localedir = $(prefix)/share/locale
+ DEFS = -DLOCALEDIR=\"$(localedir)\" -DHAVE_CONFIG_H
+ endif
+
+ GRETLLIB = ../lib/libgretl-1.0.la
+
+ # General compile options and libs:
+-LIBS = $(CLI_LIBS)
++LIBS = $(CLI_LIBS) $(INTL_LIBS)
+
+ # Directories
+ tooldir = $(topsrc)/tools
+@@ -41,14 +44,14 @@
+
+ #### End of system configuration section. ####
+
+-override CFLAGS += -I. -I.. -I$(libsrc) $(DEFS)
++override CFLAGS += -I. -I.. -I$(libsrc) $(DEFS) $(CPPFLAGS)
+
+ CLI = gretlcli
+ LIBTOOL = $(topsrc)/libtool
+
+ $(CLI): gretlcli.o $(RL_OBJ)
+ ../libtool --mode=link $(CC) -o $@ $< \
+- $(RL_OBJ) $(GRETLLIB) $(CLI_LIBS)
++ $(RL_OBJ) $(GRETLLIB) $(CLI_LIBS) $(LDFLAGS)
+
+ .PHONY :
+
diff --git a/misc/gretl/files/patch-configure b/misc/gretl/files/patch-configure
deleted file mode 100644
index 4b01c0577cb3..000000000000
--- a/misc/gretl/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Sun Apr 21 23:11:36 2002
-+++ configure Wed May 1 06:58:01 2002
-@@ -6114,6 +6114,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/misc/gretl/files/patch-doc::manual.xml b/misc/gretl/files/patch-doc::manual.xml
new file mode 100644
index 000000000000..903d8b6e8bd6
--- /dev/null
+++ b/misc/gretl/files/patch-doc::manual.xml
@@ -0,0 +1,11 @@
+--- doc/manual.xml.orig Fri Nov 8 01:30:56 2002
++++ doc/manual.xml Mon Nov 18 20:26:15 2002
+@@ -1,6 +1,6 @@
+ <?xml version="1.0"?>
+-<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+-"/usr/share/sgml/docbook-xml-4.2/docbookx.dtd" [
++<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
++ "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
+
+ <!ENTITY version "1.0">
+ <!ENTITY latex "LaTeX">
diff --git a/misc/gretl/files/patch-gnome::Makefile.in b/misc/gretl/files/patch-gnome::Makefile.in
index 0092772cd745..0daf4dce042b 100644
--- a/misc/gretl/files/patch-gnome::Makefile.in
+++ b/misc/gretl/files/patch-gnome::Makefile.in
@@ -1,15 +1,41 @@
---- gnome/Makefile.in.orig Sun Aug 25 03:07:17 2002
-+++ gnome/Makefile.in Wed Aug 28 03:10:35 2002
-@@ -18,9 +18,9 @@
+--- gnome/Makefile.in.orig Tue Aug 27 03:11:56 2002
++++ gnome/Makefile.in Mon Oct 21 08:27:48 2002
+@@ -2,10 +2,10 @@
+ docdir = ../doc
+
+ INSTALL = @INSTALL@
+-gnome_prefix = @gnome_prefix@
++datadir = @datadir@
+ have_gnome = @have_gnome@
+
+-sysconfdir = $(gnome_prefix)/etc
++sysconfdir = @sysconfdir@
+
+ GCONFTOOL = @GCONFTOOL@
+ GCONF_SCHEMA_CONFIG_SOURCE = @GCONF_SCHEMA_CONFIG_SOURCE@
+@@ -24,11 +24,11 @@
install_help = install-help-1
endif
-desktopdir = $(gnome_prefix)/share/applications
-mimedir = $(gnome_prefix)/share/mime-info
-gpixmaps = $(gnome_prefix)/share/pixmaps
-+desktopdir = $(gnome_prefix)/share/gnome/applications
-+mimedir = $(gnome_prefix)/share/gnome/mime-info
-+gpixmaps = $(gnome_prefix)/share/gnome/pixmaps
- ghelpdir = $(gnome_prefix)/share/gnome/help/gretl
+-ghelpdir = $(gnome_prefix)/share/gnome/help/gretl
+-schemadir = $(gnome_prefix)/etc/gconf/schemas
++desktopdir = $(datadir)/applications
++mimedir = $(datadir)/mime-info
++gpixmaps = $(datadir)/pixmaps
++ghelpdir = $(datadir)/help/gretl
++schemadir = $(sysconfdir)/gconf/schemas
+
+ install: install-images install-misc install-help-dirs $(install_help) $(install_schemas)
+
+@@ -58,7 +58,7 @@
+ cat $$f | sed s+fileref=\"figures/[^\"]*+\&.png+g > \
+ $(ghelpdir)/C/chapters/`basename $$f` ; done
+ $(INSTALL_DATA) $(docdir)/figures/*.png $(ghelpdir)/C/figures
+- make -C $(omfdir) install
++ $(MAKE) -C $(omfdir) install
- install: install-images install-misc install-help-dirs $(install_help)
+ install-help-1:
+ $(INSTALL_DATA) topic.dat $(ghelpdir)/C
diff --git a/misc/gretl/files/patch-gui2::Makefile.in b/misc/gretl/files/patch-gui2::Makefile.in
new file mode 100644
index 000000000000..b6f3cf5ea560
--- /dev/null
+++ b/misc/gretl/files/patch-gui2::Makefile.in
@@ -0,0 +1,54 @@
+--- gui2/Makefile.in.orig Tue Nov 12 04:28:20 2002
++++ gui2/Makefile.in Mon Nov 18 20:02:19 2002
+@@ -4,6 +4,7 @@
+ exec_prefix = @exec_prefix@
+ bindir = @bindir@
+ libdir = @libdir@
++datadir= @datadir@
+ CC = @CC@
+ CFLAGS = @CFLAGS@
+ MAKE = @MAKE@
+@@ -42,14 +43,13 @@
+ LIBS = $(GNOME_LIBS) $(GTK_EXTRA_LIB) ../lib/libgretl-1.0.la
+ GUI_CFLAGS = $(GNOME_CFLAGS) $(GTK_EXTRA_CFLAGS)
+ query_install_gnome = install-gnome
+- GNOMEDEF = -DGNOME_DISABLE_DEPRECATED -DDATADIR=\"$(gnome_prefix)/share\"
++ GNOMEDEF = -DGNOME_DISABLE_DEPRECATED -DDATADIR=\"$(datadir)\"
+ else
+ LIBS = $(GTK_LIBS) $(GTK_EXTRA_LIB) ../lib/libgretl-1.0.la
+ GUI_CFLAGS = $(GTK_CFLAGS) $(GTK_EXTRA_CFLAGS)
+ endif
+ ifeq ($(USE_NLS),yes)
+- datadir = @datadir@
+- localedir = $(datadir)/locale
++ localedir = $(prefix)/share/locale
+ NLSDEF = -DLOCALEDIR=\"$(localedir)\"
+ endif
+
+@@ -60,7 +60,7 @@
+
+ # Directories
+ bindir = $(prefix)/bin
+-gretldir = $(prefix)/share/gretl
++gretldir = $(datadir)/gretl
+ tooldir = $(topsrc)/tools
+ libsrc = $(topsrc)/lib/src
+ clisrc = $(topsrc)/cli
+@@ -92,7 +92,7 @@
+ $(CC) $(CFLAGS) $(GTK_CFLAGS) -c $<
+
+ $(GTKEXTRA_LITE):
+- make -C gtkextra-lite
++ $(MAKE) -C gtkextra-lite
+
+ .PHONY:
+
+@@ -103,7 +103,7 @@
+ $(LIBTOOL) $(INSTALL_PROGRAM) -s $(PROG) $(bindir)/$(PROG)
+
+ install-data: installdirs
+- $(INSTALL_PROGRAM) $(topsrc)/gretl_sh $(bindir)/gretl
++ $(INSTALL_SCRIPT) $(topsrc)/gretl_sh $(bindir)/gretl
+ $(INSTALL_DATA) ../pixmaps/gretl-logo.xpm $(gretldir)
+ $(INSTALL_DATA) $(topsrc)/COPYING $(gretldir)
+
diff --git a/misc/gretl/files/patch-gui2::gretl.c b/misc/gretl/files/patch-gui2::gretl.c
new file mode 100644
index 000000000000..dcf9fa877ac4
--- /dev/null
+++ b/misc/gretl/files/patch-gui2::gretl.c
@@ -0,0 +1,20 @@
+--- gui2/gretl.c.orig Tue Oct 8 02:10:30 2002
++++ gui2/gretl.c Mon Oct 21 08:48:34 2002
+@@ -1560,7 +1560,7 @@
+ {
+ pid_t pid;
+
+- signal(SIGCLD, SIG_IGN);
++ signal(SIGCHLD, SIG_IGN);
+
+ pid = fork();
+ if (pid == -1) {
+@@ -1649,7 +1649,7 @@
+ return;
+ }
+
+- signal(SIGCLD, SIG_IGN);
++ signal(SIGCHLD, SIG_IGN);
+ pid = fork();
+
+ if (pid == -1) {
diff --git a/misc/gretl/files/patch-gui2::omf-install::Makefile.in b/misc/gretl/files/patch-gui2::omf-install::Makefile.in
new file mode 100644
index 000000000000..45b94a1ec05c
--- /dev/null
+++ b/misc/gretl/files/patch-gui2::omf-install::Makefile.in
@@ -0,0 +1,23 @@
+--- gui2/omf-install/Makefile.in.orig Sun Aug 25 03:09:19 2002
++++ gui2/omf-install/Makefile.in Mon Oct 21 07:48:35 2002
+@@ -1,9 +1,9 @@
+
+ INSTALL = @INSTALL@
+-gnome_prefix = @gnome_prefix@
++datadir = @datadir@
+
+-docdir = $(gnome_prefix)/share/gnome/help/gretl/C
+-omfdir = $(gnome_prefix)/share/omf/gretl
++docdir = $(datadir)/help/gretl/C
++omfdir = $(datadir)/omf/gretl
+
+ gretl-C.omf: gretl-C.omf.in
+ scrollkeeper-preinstall $(docdir)/`awk 'BEGIN {RS = ">" } \
+@@ -12,5 +12,5 @@
+
+ install: gretl-C.omf
+ ../../tools/mkinstalldirs $(omfdir)
+- $(INSTALL) -m 644 $< $(omfdir)
+- scrollkeeper-update -p $(gnome_prefix)/var/scrollkeeper
++ $(INSTALL_DATA) $< $(omfdir)
++ scrollkeeper-update -p /var/log/scrollkeeper
diff --git a/misc/gretl/files/patch-gui::Makefile.in b/misc/gretl/files/patch-gui::Makefile.in
deleted file mode 100644
index c9366e6b0bde..000000000000
--- a/misc/gretl/files/patch-gui::Makefile.in
+++ /dev/null
@@ -1,29 +0,0 @@
---- gui/Makefile.in.orig Mon Aug 26 02:32:00 2002
-+++ gui/Makefile.in Wed Aug 28 00:40:11 2002
-@@ -57,7 +57,7 @@
- endif
- ifeq ($(USE_NLS),yes)
- datadir = @datadir@
-- localedir = $(datadir)/locale
-+ localedir = $(prefix)/share/locale
- DEFS = -DLOCALEDIR=\"$(localedir)\"
- endif
-
-@@ -66,7 +66,7 @@
-
- # Directories
- bindir = $(prefix)/bin
--gretldir = $(prefix)/share/gretl
-+gretldir = $(libdir)/gretl
- tooldir = $(topsrc)/tools
- libsrc = $(topsrc)/lib/src
- clisrc = $(topsrc)/cli
-@@ -100,7 +100,7 @@
- $(LIBTOOL) $(INSTALL_PROGRAM) -s $(PROG) $(bindir)/$(PROG)
-
- install-data: installdirs
-- $(INSTALL_PROGRAM) $(topsrc)/gretl_sh $(bindir)/gretl
-+ $(INSTALL_SCRIPT) $(topsrc)/gretl_sh $(bindir)/gretl
- $(INSTALL_DATA) ../pixmaps/gretl-logo.xpm $(gretldir)
- $(INSTALL_DATA) $(topsrc)/COPYING $(gretldir)
-
diff --git a/misc/gretl/files/patch-lib::Makefile.in b/misc/gretl/files/patch-lib::Makefile.in
index 961520cf09ab..17550caf232f 100644
--- a/misc/gretl/files/patch-lib::Makefile.in
+++ b/misc/gretl/files/patch-lib::Makefile.in
@@ -1,17 +1,18 @@
---- lib/Makefile.in.orig Mon Aug 26 02:31:58 2002
-+++ lib/Makefile.in Wed Aug 28 00:42:18 2002
-@@ -12,8 +12,8 @@
- XML_LIBS = @XML_LIBS@
+--- lib/Makefile.in.orig Wed Nov 13 03:50:52 2002
++++ lib/Makefile.in Mon Nov 18 20:04:11 2002
+@@ -14,6 +14,11 @@
+ GLIB_LIBS = @GLIB_LIBS@
have_gtk = @have_gtk@
--ifeq ($(INSTALL_PROGRAM),)
-- INSTALL_PROGRAM = $(INSTALL) -m 755
-+ifeq ($(INSTALL_SCRIPT),)
-+ INSTALL_SCRIPT = $(INSTALL) -m 755
++datadir = @datadir@
++CPPFLAGS = @CPPFLAGS@ -DDATADIR=\"$(datadir)\"
++LDFLAGS = @LDFLAGS@
++INTL_LIBS = @LTLIBINTL@
++
+ ifeq ($(INSTALL_PROGRAM),)
+ INSTALL_PROGRAM = $(INSTALL) -m 755
endif
- ifeq ($(INSTALL_DATA),)
- INSTALL_DATA = $(INSTALL) -m 644
-@@ -26,7 +26,7 @@
+@@ -28,7 +33,7 @@
libdir = $(prefix)/lib
includedir = $(prefix)/include/gretl
aclocaldir = $(prefix)/share/aclocal
@@ -20,33 +21,29 @@
INSTALLDIRS = $(libdir) $(includedir) $(aclocaldir)
-@@ -40,7 +40,7 @@
- LIBGRETL = libgretl.la
+@@ -42,7 +47,7 @@
INSTALL_CFG = install-cfg-old
endif
--LIBS = -lm -ldl -L/usr/local/lib -lz $(XML_LIBS)
-+LIBS = -lm -lz $(XML_LIBS)
+
+-LIBS = -lm -ldl -L/usr/local/lib -lz $(XML_LIBS) $(GLIB_LIBS)
++LIBS = -lm -lz $(XML_LIBS) $(GLIB_LIBS) $(INTL_LIBS)
#### End of system configuration section. ####
-@@ -77,17 +77,17 @@
- .PHONY:
+@@ -73,14 +78,14 @@
- install: $(LIBGRETL) install-data
-- $(LIBTOOL) $(INSTALL_PROGRAM) $< $(libdir)/$<
-+ $(LIBTOOL) $(INSTALL_DATA) $< $(libdir)/$<
+ override CFLAGS += -I. -I./src -I.. $(XML_CFLAGS) $(GLIB_CFLAGS) -DHAVE_CONFIG_H
- install-strip: $(LIBGRETL) install-data
-- $(LIBTOOL) $(INSTALL_PROGRAM) -s $< $(libdir)/$<
-+ $(LIBTOOL) $(INSTALL_DATA) -s $< $(libdir)/$<
+-COMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS)
++COMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) $(CPPFLAGS)
- install-data: installdirs $(INSTALL_CFG)
- $(INSTALL_DATA) $(srcdir)/*.h $(includedir)
- $(INSTALL_DATA) ../gretl.m4 $(aclocaldir)
+ .c.o:
+ $(COMPILE) $<
- install-cfg-old: ../gretl-config
-- $(INSTALL_PROGRAM) ../gretl-config $(bindir)
-+ $(INSTALL_SCRIPT) ../gretl-config $(bindir)
+ $(LIBGRETL): $(OBJS) $(LOBJS) $(CEPHES_OBJ) $(CEPHES_OBJ)
+ $(LIBTOOL) --mode=link $(CC) -o $@ $(LOBJS) $(CEPHES_LOBJ) \
+- -rpath $(prefix)/lib $(LIBS) -version-info 0:0:0
++ -rpath $(prefix)/lib $(LIBS) -version-info 0:0:0 $(LDFLAGS)
+
+ .PHONY:
- install-cfg-new: ../gretl2.pc
- $(INSTALL_DATA) ../gretl2.pc $(pkgconfigdir)
diff --git a/misc/gretl/files/patch-lib::src::gretl_utils.c b/misc/gretl/files/patch-lib::src::gretl_utils.c
new file mode 100644
index 000000000000..b05b6e035e38
--- /dev/null
+++ b/misc/gretl/files/patch-lib::src::gretl_utils.c
@@ -0,0 +1,13 @@
+--- lib/src/gretl_utils.c.orig Mon Sep 30 06:13:40 2002
++++ lib/src/gretl_utils.c Mon Oct 21 08:31:52 2002
+@@ -1373,8 +1373,8 @@
+ if (home != NULL) {
+ strcpy(ppaths->gretldir, home);
+ } else {
+- strcpy(ppaths->gretldir, GRETL_PREFIX);
+- strcat(ppaths->gretldir, "/share/gretl/");
++ strcpy(ppaths->gretldir, DATADIR);
++ strcat(ppaths->gretldir, "/gretl/");
+ }
+ if (gui) {
+ sprintf(ppaths->binbase, "%sdb/", ppaths->gretldir);
diff --git a/misc/gretl/files/patch-plugin::Makefile.in b/misc/gretl/files/patch-plugin::Makefile.in
index 6413e81a5ddf..e02bb5a24afa 100644
--- a/misc/gretl/files/patch-plugin::Makefile.in
+++ b/misc/gretl/files/patch-plugin::Makefile.in
@@ -1,23 +1,28 @@
---- plugin/Makefile.in.orig Mon Aug 26 02:32:01 2002
-+++ plugin/Makefile.in Wed Aug 28 00:45:07 2002
-@@ -2,6 +2,7 @@
-
- prefix = @prefix@
- exec_prefix = @exec_prefix@
-+libdir = @libdir@
- CC = @CC@
- CFLAGS = @CFLAGS@
- MAKE = @MAKE@
-@@ -26,7 +27,7 @@
- endif
-
- # Installation directory
--share = $(prefix)/share/gretl
-+gretldir = $(libdir)/gretl
-
+--- plugin/Makefile.in.orig Fri Oct 11 03:03:46 2002
++++ plugin/Makefile.in Mon Oct 21 10:23:25 2002
+@@ -8,6 +8,10 @@
+ INSTALL = @INSTALL@
+ LN = @LN_S@
+
++CPPFLAGS = @CPPFLAGS@
++LDFLAGS = @LDFLAGS@
++INTL_LIBS = @LTLIBINTL@
++
+ have_gtk = @have_gtk@
+ GTK_CFLAGS = @GTK_CFLAGS@
+ GTK_LIBS = @GTK_LIBS@
+@@ -31,8 +35,8 @@
override CFLAGS += -I.. -DHAVE_CONFIG_H
-@@ -48,7 +49,7 @@
+ LIBTOOL = $(topsrc)/libtool
+-COMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS)
+-LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -shared
++COMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) $(CPPFLAGS)
++LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -shared $(LDFLAGS)
+
+ GRETLINC = -I$(topsrc)/lib/src
+ GRETLLIB = ../lib/libgretl.la
+@@ -47,7 +51,7 @@
PROGRESS_PLUGIN = progress_bar.so
GNUMERIC_PLUGIN = gnumeric_import.so
EXCEL_PLUGIN = excel_import.so
@@ -25,25 +30,18 @@
+ GRETL_LIBOLE2_CFLAGS := -I. $(shell $(GLIB_CONFIG) --cflags)
endif
- PLUGINS = stats_tables.so panel_data.so des_import.so \
-@@ -139,15 +140,15 @@
+ PLUGINS = stats_tables.so panel_data.so des_import.so range-mean.so lad.so \
+@@ -156,11 +160,11 @@
.PHONY:
install: $(PLUGINS) installdirs
- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) \
-- $(PLUGINS) $(share)/plugins
+ $(LIBTOOL) --mode=install $(INSTALL_DATA) \
-+ $(PLUGINS) $(gretldir)/plugins
+ $(PLUGINS) $(plugindir)
install-strip: $(PLUGINS) installdirs
- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) -s \
-- $(PLUGINS) $(share)/plugins
+ $(LIBTOOL) --mode=install $(INSTALL_DATA) -s \
-+ $(PLUGINS) $(gretldir)/plugins
+ $(PLUGINS) $(plugindir)
installdirs:
-- $(topsrc)/tools/mkinstalldirs $(share)/plugins
-+ $(topsrc)/tools/mkinstalldirs $(gretldir)/plugins
-
- clean:
- rm -f *.o *.lo *.so core
diff --git a/misc/gretl/files/patch-po::Makefile.in.in b/misc/gretl/files/patch-po::Makefile.in.in
new file mode 100644
index 000000000000..53fa2d5ede09
--- /dev/null
+++ b/misc/gretl/files/patch-po::Makefile.in.in
@@ -0,0 +1,11 @@
+--- po/Makefile.in.in.orig Fri May 24 05:03:49 2002
++++ po/Makefile.in.in Mon Oct 21 08:10:04 2002
+@@ -21,7 +21,7 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ datadir = @datadir@
+-localedir = $(datadir)/locale
++localedir = $(prefix)/share/locale
+ gettextsrcdir = $(datadir)/gettext/po
+
+ INSTALL = @INSTALL@
diff --git a/misc/gretl/files/patch-share::Makefile.in b/misc/gretl/files/patch-share::Makefile.in
index 53377eeebc2c..c4811e225653 100644
--- a/misc/gretl/files/patch-share::Makefile.in
+++ b/misc/gretl/files/patch-share::Makefile.in
@@ -1,14 +1,14 @@
---- share/Makefile.in.orig Tue Aug 20 05:22:47 2002
-+++ share/Makefile.in Wed Aug 28 00:48:06 2002
+--- share/Makefile.in.orig Mon Sep 30 03:49:42 2002
++++ share/Makefile.in Mon Oct 21 07:31:57 2002
@@ -1,11 +1,12 @@
topsrc = ..
prefix = @prefix@
-+libdir = @libdir@
++datadir = @datadir@
have_gtk = @have_gtk@
-gretldir = $(prefix)/share/gretl
-+gretldir = $(libdir)/gretl
++gretldir = $(datadir)/gretl
tooldir = $(topsrc)/tools
-INSTALL_DATA = cp -fp
+INSTALL_DATA = @INSTALL_DATA@
diff --git a/misc/gretl/files/patch-tools::ltmain.sh b/misc/gretl/files/patch-tools::ltmain.sh
new file mode 100644
index 000000000000..3d010b6c9f88
--- /dev/null
+++ b/misc/gretl/files/patch-tools::ltmain.sh
@@ -0,0 +1,49 @@
+--- tools/ltmain.sh.orig Mon May 20 06:43:59 2002
++++ tools/ltmain.sh Mon Oct 21 10:45:46 2002
+@@ -956,6 +956,7 @@
+ ;;
+
+ -avoid-version)
++ build_old_libs=no
+ avoid_version=yes
+ continue
+ ;;
+@@ -1043,14 +1044,14 @@
+ # These systems don't actually have a C library (as such)
+ test "X$arg" = "X-lc" && continue
+ ;;
+- *-*-openbsd*)
++ *-*-openbsd* | *-*-freebsd*)
+ # Do not include libc due to us having libc/libc_r.
+ test "X$arg" = "X-lc" && continue
+ ;;
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd*)
++ *-*-openbsd* | *-*-freebsd*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -2441,7 +2442,7 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
+- *-*-openbsd*)
++ *-*-openbsd* | *-*-freebsd*)
+ # Do not include libc due to us having libc/libc_r.
+ ;;
+ *)
+@@ -4210,10 +4211,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"