aboutsummaryrefslogtreecommitdiff
path: root/misc/gtktalog/Makefile
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-04-21 19:49:01 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-04-21 19:49:01 +0000
commit6d3cc600b0e10a524dd5d55262276990e987b18a (patch)
treeb74e7de61c89ef5ea10f32f296f2cac1dd18947e /misc/gtktalog/Makefile
parent6d25bcb88dbe8ba88134152f42627e1330a4cd59 (diff)
Notes
Diffstat (limited to 'misc/gtktalog/Makefile')
-rw-r--r--misc/gtktalog/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/misc/gtktalog/Makefile b/misc/gtktalog/Makefile
new file mode 100644
index 000000000000..9b7071939bdb
--- /dev/null
+++ b/misc/gtktalog/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: gtktalog
+# Date created: 20 Mar 2002
+# Whom: Juan Salaverria <rael@vectorstar.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtktalog
+PORTVERSION= 0.99.19
+CATEGORIES= misc
+MASTER_SITES= http://freesoftware.fsf.org/download/gtktalog/gtktalog/sources/
+
+MAINTAINER= rael@vectorstar.net
+
+USE_GNOMELIBS= yes
+GNU_CONFIGURE= yes
+
+MAN1= gtktalog.1
+
+DOCS= AUTHORS BUGS COPYING ChangeLog NEWS README TODO
+
+post-patch:
+ ${PERL} -pi -e "s@^(Applicationsdir = ).*@\1${PREFIX}/share/gnome/apps/Applications@" ${WRKSRC}/Makefile.in
+ ${PERL} -pi -e "s@^(localedir = ).*@\1${PREFIX}/share/locale@" \
+ ${WRKSRC}/po/Makefile.in.in
+ ${PERL} -pi -e "s@^(gtktalog_helpdir = ).*@\1${PREFIX}/share/gnome/help/gtktalog/C@" ${WRKSRC}/Docs/C/Makefile.in
+ ${PERL} -pi -e "s@^(gtktalog_helpdir = ).*@\1${PREFIX}/share/gnome/help/gtktalog/fr@" ${WRKSRC}/Docs/fr/Makefile.in
+ ${PERL} -pi -e "s@^(MountPoint ).*@\1/cdrom@" \
+ ${WRKSRC}/src/gtktalog/gtktalog.cf.in.in
+
+post-install:
+ ${RMDIR} ${PREFIX}/share/gnome/help/gtktalog/*/images 2>/dev/null || ${TRUE}
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>