aboutsummaryrefslogtreecommitdiff
path: root/misc/gtl/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-04-21 15:31:34 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-04-21 15:31:34 +0000
commit1a074bd43cdd60cd3e18f18959244e4b77ac8627 (patch)
treee45b0aba5c28a98816dc2e61f5ff9d03ff09f3f6 /misc/gtl/Makefile
parent76b13a18e3a584f89828b44bdec65258c7706780 (diff)
downloadports-1a074bd43cdd60cd3e18f18959244e4b77ac8627.tar.gz
ports-1a074bd43cdd60cd3e18f18959244e4b77ac8627.zip
Notes
Diffstat (limited to 'misc/gtl/Makefile')
-rw-r--r--misc/gtl/Makefile39
1 files changed, 29 insertions, 10 deletions
diff --git a/misc/gtl/Makefile b/misc/gtl/Makefile
index 6961bf83ed23..08e5ac2cf6eb 100644
--- a/misc/gtl/Makefile
+++ b/misc/gtl/Makefile
@@ -6,23 +6,42 @@
#
PORTNAME= gtl
-PORTVERSION= 0.3.3
+PORTVERSION= 1.2.1
CATEGORIES= misc
-# The original distribution files are not available
-# anymore from the master_sites (http://infosun.fmi.uni-passau.de/GTL/)
-MASTER_SITES= #
+# The original distribution files are no longer freely
+# available from the master_sites
+MASTER_SITES= # http://infosun.fmi.uni-passau.de/GTL/
DISTNAME= GTL-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= q@uni.de
COMMENT= C++ STL-based support for graphs and graph algorithms
+RESTRICTED= License forbids redistribution (source or binary)
+
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+USE_INC_LIBTOOL_VER=13
+USE_GNOME= lthack
+USE_GCC= 3.3 # Won't build with 3.4
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500035
-BROKEN= "Does not compile on 5.0"
+.if !exists("${DISTDIR}/${DISTFILES}") && !defined(PACKAGE_BUILDING)
+ECHO_MSG=/usr/bin/printf
+IGNORE= \n\
+With the release of version 1.0.0 the download policy of GTL has been\n\
+changed. GTL can be downloaded free of charge for non-commercial use.\n\
+Please follow the steps below to get access to the download archive:\n\
+\n\
+Send an email to gtl-download@infosun.fmi.uni-passau.de containing the\n\
+following information: \n\
+- Your Name\n\
+- Your Affiliation\n\
+- And your email address. Please use your academic address, e.g. .edu, if\n\
+ you have. Otherwise your are classified as a "commercial" user.\n\
+As soon as possible you will receive an answer from the GTL Team containing\n\
+the access code to the download page.\n\
+\n\
+If you intend to use GTL commercially please send an email to\n\
+brandenb@fmi.uni-passau.de.\n
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>