aboutsummaryrefslogtreecommitdiff
path: root/misc/hello/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-02-07 08:31:09 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-02-07 08:31:09 +0000
commit3f482f595de8f557039db37c46f3bede0a7060b7 (patch)
tree50598a8200d2da66acc2cc9270d25e1f9354b9b0 /misc/hello/Makefile
parentdeced0b16fe3efa5bbbe4a62e88ad95c525ecf19 (diff)
Notes
Diffstat (limited to 'misc/hello/Makefile')
-rw-r--r--misc/hello/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/misc/hello/Makefile b/misc/hello/Makefile
index afc1f68a3dba..e01032d14cfc 100644
--- a/misc/hello/Makefile
+++ b/misc/hello/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= hello
-PORTVERSION= 2.1.1
-PORTREVISION= 2
+PORTVERSION= 2.3
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= hello
@@ -20,13 +19,22 @@ GNU_CONFIGURE= YES
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= hello.1
+INFO= hello
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
PLIST_SUB+= NLS=""
.else
-CONFIGURE_ARGS+=--disable-nls
+CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+pre-install:
+ ${CHMOD} a+x ${WRKSRC}/build-aux/install-sh
+
.include <bsd.port.mk>