aboutsummaryrefslogtreecommitdiff
path: root/misc/hotkeys/Makefile
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2006-05-21 14:24:55 +0000
committerStefan Walter <stefan@FreeBSD.org>2006-05-21 14:24:55 +0000
commit4a92e653a0025a0c67a60e653d5a28399d4cc1b5 (patch)
treecc16e692ec353dedd797dab16cb8124d7f4132f3 /misc/hotkeys/Makefile
parent087cb078c0eae1a8485bb446d61bfcd4716c4ec2 (diff)
downloadports-4a92e653a0025a0c67a60e653d5a28399d4cc1b5.tar.gz
ports-4a92e653a0025a0c67a60e653d5a28399d4cc1b5.zip
Notes
Diffstat (limited to 'misc/hotkeys/Makefile')
-rw-r--r--misc/hotkeys/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/misc/hotkeys/Makefile b/misc/hotkeys/Makefile
index 75f803912c46..698e7360d898 100644
--- a/misc/hotkeys/Makefile
+++ b/misc/hotkeys/Makefile
@@ -15,21 +15,28 @@ DISTNAME= hotkeys_${PORTVERSION}
MAINTAINER= amp0928@rit.edu
COMMENT= Allows usage of special keys on internet/multimedia keyboards
-LIB_DEPENDS= xosd.4:${PORTSDIR}/misc/xosd \
- xml2.5:${PORTSDIR}/textproc/libxml2 \
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
db3.3:${PORTSDIR}/databases/db3
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-GNU_CONFIGURE= 1
CONFIGURE_ARGS= --with-db3-inc=${LOCALBASE}/include/db3 \
- --with-db3-lib=${LOCALBASE}/lib \
- --with-xosd
-USE_GMAKE= yes
+ --with-db3-lib=${LOCALBASE}/lib
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
MAN1= hotkeys.1
ORIG_CONFIG= ${PREFIX}/etc/hotkeys.conf
SAMPLE_CONFIG= ${PREFIX}/etc/hotkeys.conf.sample
+OPTIONS= XOSD "Enable On-Screen-Display support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_XOSD)
+LIB_DEPENDS+= xosd.4:${PORTSDIR}/misc/xosd
+CONFIGURE_ARGS+= --with-xosd
+.endif
+
post-extract:
@${CP} ${PATCHDIR}/error.h ${WRKSRC}/src
@${CP} ${PATCHDIR}/eliteduo.def ${WRKSRC}/def
@@ -39,4 +46,4 @@ post-install:
@${MV} ${ORIG_CONFIG} ${SAMPLE_CONFIG}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>