aboutsummaryrefslogtreecommitdiff
path: root/misc/inplace/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2004-05-01 19:13:05 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2004-05-01 19:13:05 +0000
commit211b52d2ab5ebd670632ac2ee997701b60c5e582 (patch)
treed325c4279d3a809ccfdd090dd47a08d306beb3aa /misc/inplace/Makefile
parent1a4bab358caac14a6ea4a8fbd2a447b621388bb4 (diff)
downloadports-211b52d2ab5ebd670632ac2ee997701b60c5e582.tar.gz
ports-211b52d2ab5ebd670632ac2ee997701b60c5e582.zip
Notes
Diffstat (limited to 'misc/inplace/Makefile')
-rw-r--r--misc/inplace/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/misc/inplace/Makefile b/misc/inplace/Makefile
new file mode 100644
index 000000000000..647a32301b97
--- /dev/null
+++ b/misc/inplace/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: inplace(1)
+# Date created: 2 May 2004
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= inplace
+PORTVERSION= 1.0.1
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.iDaemons.org/pub/distfiles/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= knu
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A tool to edit files in-place through given filter commands
+
+USE_BZIP2= yes
+USE_RUBY= yes
+
+MAKE_ARGS= PREFIX="${PREFIX}"
+MAKEFILE= BSDmakefile
+
+MAN1= inplace.1
+MANCOMPRESSED= maybe
+PLIST_FILES= bin/inplace
+
+RUBY_REQUIRE= Ruby > 180
+
+.include <bsd.port.pre.mk>
+
+.if !defined(RUBY_PROVIDED)
+IGNORE= only works with Ruby 1.8.0 or later
+.endif
+
+.include <bsd.port.post.mk>