aboutsummaryrefslogtreecommitdiff
path: root/misc/ipbt
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-12-14 22:58:33 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-12-14 22:58:33 +0000
commitb89c6a4ffdc00ed24984b7cb24e0beedf7969e0f (patch)
tree713f96741aef69945c56432a54a6c6fbcfa0da65 /misc/ipbt
parent39ffd212bfaf9a91a36aba64bfe8d03e47cfd048 (diff)
downloadports-b89c6a4ffdc00ed24984b7cb24e0beedf7969e0f.tar.gz
ports-b89c6a4ffdc00ed24984b7cb24e0beedf7969e0f.zip
Notes
Diffstat (limited to 'misc/ipbt')
-rw-r--r--misc/ipbt/Makefile35
-rw-r--r--misc/ipbt/distinfo3
-rw-r--r--misc/ipbt/pkg-descr14
3 files changed, 52 insertions, 0 deletions
diff --git a/misc/ipbt/Makefile b/misc/ipbt/Makefile
new file mode 100644
index 000000000000..534238862d3d
--- /dev/null
+++ b/misc/ipbt/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ipbt
+# Date created: 7 May 2006
+# Whom: Matt Mills <matt_mills@btopenworld.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipbt
+DISTVERSION= r7471
+CATEGORIES= misc
+MASTER_SITES= http://www.chiark.greenend.org.uk/~sgtatham/ipbt/ \
+ http://freebsd.unixfreunde.de/sources/ \
+ https://www.spoerlein.net/pub/
+
+MAINTAINER= uspoerlein@gmail.com
+COMMENT= A high-tech ttyrec player with improvements over ttyplay
+
+MAN1= ipbt.1
+
+USE_PERL5= yes
+
+ALL_TARGET= ${PORTNAME}
+PLIST_FILES= bin/ipbt bin/ttygrep bin/ttydump
+
+post-patch:
+ @${REINPLACE_CMD} -e '1s|.*|#!${PERL} -w|' ${WRKSRC}/sbcsgen.pl
+ @${REINPLACE_CMD} -e 's|perl|${PERL}|' ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/ttydump ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/ttygrep ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ipbt.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/misc/ipbt/distinfo b/misc/ipbt/distinfo
new file mode 100644
index 000000000000..2797bf624153
--- /dev/null
+++ b/misc/ipbt/distinfo
@@ -0,0 +1,3 @@
+MD5 (ipbt-r7471.tar.gz) = dcbf3feb4329a09479aa4e3055b69852
+SHA256 (ipbt-r7471.tar.gz) = 6706cbc4144a8bc59d8490257ebe44ea4dc3f6bad4df153bd170ad5450dca550
+SIZE (ipbt-r7471.tar.gz) = 174942
diff --git a/misc/ipbt/pkg-descr b/misc/ipbt/pkg-descr
new file mode 100644
index 000000000000..475a0ed0ea1e
--- /dev/null
+++ b/misc/ipbt/pkg-descr
@@ -0,0 +1,14 @@
+IPBT (It's Play-Back Time) is a ttyrec player with many features
+that ttyplay lacks. Notable features are:
+
+ * Pausing
+ * Move forward/backward frame by frame
+ * Adjustable play speed (faster/slower)
+ * Jump to beginning/end in a single keystroke
+ * Searching forward/backward for a given string
+ * ttygrep and ttydump utilities
+
+IPBT works by reading the entire input file and running it through
+an internal terminal emulator (the one from PuTTY).
+
+WWW: http://www.chiark.greenend.org.uk/~sgtatham/ipbt/