aboutsummaryrefslogtreecommitdiff
path: root/misc/jbidwatcher/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2004-08-23 20:27:31 +0000
committerGreg Lewis <glewis@FreeBSD.org>2004-08-23 20:27:31 +0000
commit6380ce531d836f59d62e29eafd606ef64f1a2a09 (patch)
treeded05e594be0a8ff7771fe6ea375ff804374fa04 /misc/jbidwatcher/Makefile
parent19392bbe75779aaa327a0340e92b455cf382926a (diff)
downloadports-6380ce531d836f59d62e29eafd606ef64f1a2a09.tar.gz
ports-6380ce531d836f59d62e29eafd606ef64f1a2a09.zip
Notes
Diffstat (limited to 'misc/jbidwatcher/Makefile')
-rw-r--r--misc/jbidwatcher/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/misc/jbidwatcher/Makefile b/misc/jbidwatcher/Makefile
new file mode 100644
index 000000000000..8d505176a884
--- /dev/null
+++ b/misc/jbidwatcher/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: jbidwatcher
+# Date Created: 24 July 2004
+# Whom: Jose Rodriguez <king@v2project.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jbidwatcher
+PORTVERSION= 0.9.3.1
+CATEGORIES= misc java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= JBidWatcher-${PORTVERSION}
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY=
+
+MAINTAINER= king@v2project.com
+COMMENT= A Java-based application allowing you to monitor eBay auctions
+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
+NO_BUILD= yes
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar \
+ bin/${PORTNAME}
+
+do-install:
+ @${INSTALL_DATA} ${DISTDIR}/${DISTFILES} ${JAVAJARDIR}/${PORTNAME}.jar
+ @${SED} -e "s:%%LOCALBASE%%:${LOCALBASE}:" \
+ -e "s:%%JAVAJARDIR%%:${JAVAJARDIR}:" \
+ ${FILESDIR}/jbidwatcher.sh > ${PREFIX}/bin/${PORTNAME}
+ @${CHOWN} ${BINOWN}:${BINGRP} ${PREFIX}/bin/${PORTNAME}
+ @${CHMOD} a+rx ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>