aboutsummaryrefslogtreecommitdiff
path: root/misc/jbidwatcher
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2004-08-23 20:27:31 +0000
committerGreg Lewis <glewis@FreeBSD.org>2004-08-23 20:27:31 +0000
commit6380ce531d836f59d62e29eafd606ef64f1a2a09 (patch)
treeded05e594be0a8ff7771fe6ea375ff804374fa04 /misc/jbidwatcher
parent19392bbe75779aaa327a0340e92b455cf382926a (diff)
downloadports-6380ce531d836f59d62e29eafd606ef64f1a2a09.tar.gz
ports-6380ce531d836f59d62e29eafd606ef64f1a2a09.zip
Notes
Diffstat (limited to 'misc/jbidwatcher')
-rw-r--r--misc/jbidwatcher/Makefile35
-rw-r--r--misc/jbidwatcher/distinfo2
-rw-r--r--misc/jbidwatcher/files/jbidwatcher.sh5
-rw-r--r--misc/jbidwatcher/pkg-descr8
4 files changed, 50 insertions, 0 deletions
diff --git a/misc/jbidwatcher/Makefile b/misc/jbidwatcher/Makefile
new file mode 100644
index 000000000000..8d505176a884
--- /dev/null
+++ b/misc/jbidwatcher/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: jbidwatcher
+# Date Created: 24 July 2004
+# Whom: Jose Rodriguez <king@v2project.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jbidwatcher
+PORTVERSION= 0.9.3.1
+CATEGORIES= misc java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= JBidWatcher-${PORTVERSION}
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY=
+
+MAINTAINER= king@v2project.com
+COMMENT= A Java-based application allowing you to monitor eBay auctions
+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
+NO_BUILD= yes
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar \
+ bin/${PORTNAME}
+
+do-install:
+ @${INSTALL_DATA} ${DISTDIR}/${DISTFILES} ${JAVAJARDIR}/${PORTNAME}.jar
+ @${SED} -e "s:%%LOCALBASE%%:${LOCALBASE}:" \
+ -e "s:%%JAVAJARDIR%%:${JAVAJARDIR}:" \
+ ${FILESDIR}/jbidwatcher.sh > ${PREFIX}/bin/${PORTNAME}
+ @${CHOWN} ${BINOWN}:${BINGRP} ${PREFIX}/bin/${PORTNAME}
+ @${CHMOD} a+rx ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/misc/jbidwatcher/distinfo b/misc/jbidwatcher/distinfo
new file mode 100644
index 000000000000..e1586e41852c
--- /dev/null
+++ b/misc/jbidwatcher/distinfo
@@ -0,0 +1,2 @@
+MD5 (JBidWatcher-0.9.3.1.jar) = c3453c675f3c1e3773a52add8d839fcb
+SIZE (JBidWatcher-0.9.3.1.jar) = 469325
diff --git a/misc/jbidwatcher/files/jbidwatcher.sh b/misc/jbidwatcher/files/jbidwatcher.sh
new file mode 100644
index 000000000000..2e3918b378ac
--- /dev/null
+++ b/misc/jbidwatcher/files/jbidwatcher.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+javavm -jar %%JAVAJARDIR%%/jbidwatcher.jar $@
diff --git a/misc/jbidwatcher/pkg-descr b/misc/jbidwatcher/pkg-descr
new file mode 100644
index 000000000000..4ee7780d2e0a
--- /dev/null
+++ b/misc/jbidwatcher/pkg-descr
@@ -0,0 +1,8 @@
+A Java-based application allowing you to monitor ebay auctions,
+submit bids, snipe (bid at the last moment), and otherwise track
+your auction-site experience. It includes adult-auction management,
+MANY currencies (yen, pound, dollar (US, Canada, Australian, and
+New Taiwanese), Swiss Francs, and euro, presently), drag-and-drop
+of auction URLs, a unique and powerful 'multisniping' feature.
+
+WWW: http://www.jbidwatcher.com/