aboutsummaryrefslogtreecommitdiff
path: root/misc/kde4-l10n/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-09 16:52:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-09 16:52:28 +0000
commit568f8e877fb50618d4813b943d712e3bc08fd147 (patch)
tree16eef3a555a802ca06d05606c7f2a75ccbc6a431 /misc/kde4-l10n/Makefile
parentbdcf355d6dedb8678255a8053a2b423f9cc7cc6c (diff)
downloadports-568f8e877fb50618d4813b943d712e3bc08fd147.tar.gz
ports-568f8e877fb50618d4813b943d712e3bc08fd147.zip
Notes
Diffstat (limited to 'misc/kde4-l10n/Makefile')
-rw-r--r--misc/kde4-l10n/Makefile48
1 files changed, 21 insertions, 27 deletions
diff --git a/misc/kde4-l10n/Makefile b/misc/kde4-l10n/Makefile
index 4037f7f6a227..393b96af566b 100644
--- a/misc/kde4-l10n/Makefile
+++ b/misc/kde4-l10n/Makefile
@@ -1,13 +1,12 @@
-# New ports collection makefile for: kde2-i18n
-# Date created: 1 March 2001
-# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+# New ports collection makefile for: kde4-l10n
+# Date created: 21 July 2008
+# Whom: Martin Wilke <miwi@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= kde-i18n
-PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTNAME= kde-l10n
+PORTVERSION= ${KDE4_VERSION}
CATEGORIES= misc kde
MASTER_SITES= # none
DISTFILES= # none
@@ -17,35 +16,30 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Localized messages and documentation for KDE
RUN_DEPENDS+=\
- ${LOCALBASE}/share/locale/ar/entry.desktop:${PORTSDIR}/arabic/kde3-i18n \
- ${LOCALBASE}/share/locale/ja/entry.desktop:${PORTSDIR}/japanese/kde3-i18n \
- ${LOCALBASE}/share/locale/fr/entry.desktop:${PORTSDIR}/french/kde3-i18n \
- ${LOCALBASE}/share/locale/de/entry.desktop:${PORTSDIR}/german/kde3-i18n \
- ${LOCALBASE}/share/locale/he/entry.desktop:${PORTSDIR}/hebrew/kde3-i18n \
- ${LOCALBASE}/share/locale/hu/entry.desktop:${PORTSDIR}/hungarian/kde3-i18n \
- ${LOCALBASE}/share/locale/ko/entry.desktop:${PORTSDIR}/korean/kde3-i18n \
- ${LOCALBASE}/share/locale/ru/entry.desktop:${PORTSDIR}/russian/kde3-i18n \
- ${LOCALBASE}/share/locale/uk/entry.desktop:${PORTSDIR}/ukrainian/kde3-i18n \
- ${LOCALBASE}/share/locale/vi/entry.desktop:${PORTSDIR}/vietnamese/kde3-i18n \
- ${LOCALBASE}/share/locale/pl/entry.desktop:${PORTSDIR}/polish/kde3-i18n
+ ${KDE4_PREFIX}/share/locale/ja/entry.desktop:${PORTSDIR}/japanese/kde4-l10n \
+ ${KDE4_PREFIX}/share/locale/fr/entry.desktop:${PORTSDIR}/french/kde4-l10n \
+ ${KDE4_PREFIX}/share/locale/de/entry.desktop:${PORTSDIR}/german/kde4-l10n \
+ ${KDE4_PREFIX}/share/locale/hu/entry.desktop:${PORTSDIR}/hungarian/kde4-l10n \
+ ${KDE4_PREFIX}/share/locale/ko/entry.desktop:${PORTSDIR}/korean/kde4-l10n \
+ ${KDE4_PREFIX}/share/locale/ru/entry.desktop:${PORTSDIR}/russian/kde4-l10n \
+ ${KDE4_PREFIX}/share/locale/uk/entry.desktop:${PORTSDIR}/ukrainian/kde4-l10n \
+ ${KDE4_PREFIX}/share/locale/pl/entry.desktop:${PORTSDIR}/polish/kde4-l10n
-.for LANG in af az bg bn br bs ca cs csb cy da el en_GB eo es et eu fa fi fy ga gl hi \
- hr hsb is it kk km lt lv mk mn ms mt nb nds nl nn nso pa ro rw se sk sl \
- sr sr@Latn ss sv ta te tg th tr uz ven wa xh zu
-RUN_DEPENDS+=\
-${LOCALBASE}/share/locale/${LANG}/entry.desktop:${PORTSDIR}/misc/kde3-i18n-${LANG}
+.for LANG in bg ca cs csb da el en_GB eo es et fi fy ga gl hi it kk km ku lt \
+ lv mk ml nb nds pa sl sr sv ta th tr wo
+RUN_DEPENS+= \
+ ${KDE4_PREFIX}/share/locale/${LANG}/entry.desktop:${PORTSDIR}/misc/kde4-l10n-${LANG}
.endfor
RUN_DEPENDS+=\
-${LOCALBASE}/share/locale/pt/entry.desktop:${PORTSDIR}/portuguese/kde3-i18n \
-${LOCALBASE}/share/locale/pt_BR/entry.desktop:${PORTSDIR}/portuguese/kde3-i18n-pt_BR
+ ${KDE4_PREFIX}/share/locale/pt/entry.desktop:${PORTSDIR}/portuguese/kde4-l10n \
+ ${KDE4_PREFIX}/share/locale/pt_BR/entry.desktop:${PORTSDIR}/portuguese/kde4-l10n-pt_BR
.for ZH in zh_CN zh_TW
RUN_DEPENDS+=\
-${LOCALBASE}/share/locale/${ZH}/entry.desktop:${PORTSDIR}/chinese/kde3-i18n-${ZH}
+${LOCALBASE}/share/locale/${ZH}/entry.desktop:${PORTSDIR}/chinese/kde4-l10n-${ZH}
.endfor
-USE_KDELIBS_VER=3
NO_BUILD= yes
-KDE_I18N= yes
+USE_KDE4= kdeprefix kdelibs
do-install: # none