aboutsummaryrefslogtreecommitdiff
path: root/misc/kdeaddons3
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-12-04 03:47:18 +0000
committerWill Andrews <will@FreeBSD.org>2001-12-04 03:47:18 +0000
commit1d206a3483e848f4589962473bdf169313ea740f (patch)
tree269caee3e56d61cd6318b44d85c3ff64b32d57b6 /misc/kdeaddons3
parentfb2c030e15fb4b426c06fee701c06b7f44c272ab (diff)
downloadports-1d206a3483e848f4589962473bdf169313ea740f.tar.gz
ports-1d206a3483e848f4589962473bdf169313ea740f.zip
Notes
Diffstat (limited to 'misc/kdeaddons3')
-rw-r--r--misc/kdeaddons3/Makefile46
-rw-r--r--misc/kdeaddons3/distinfo2
-rw-r--r--misc/kdeaddons3/pkg-plist60
3 files changed, 50 insertions, 58 deletions
diff --git a/misc/kdeaddons3/Makefile b/misc/kdeaddons3/Makefile
index 26fe58557c84..18fe7500dff1 100644
--- a/misc/kdeaddons3/Makefile
+++ b/misc/kdeaddons3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdeaddons
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES?= misc kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -14,30 +14,40 @@ DIST_SUBDIR= KDE
MAINTAINER?= ports@FreeBSD.org
+BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
+ automake14:${PORTSDIR}/devel/automake14 \
+ objprelink:${PORTSDIR}/devel/objprelink
+LIB_DEPENDS+= noatun.0:${PORTSDIR}/audio/kdemultimedia2 \
+ SDL-1.1.3:${PORTSDIR}/devel/sdl12
+
+WITH_SDL= yes
USE_KDEBASE_VER=2
-LIB_DEPENDS+= noatun.0:${PORTSDIR}/audio/kdemultimedia2
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
PLIST_SUB+= RM=${RM}
+CONFIGURE_ENV+= SDL_CONFIG="${LOCALBASE}/bin/sdl11-config"
+CONFIGURE_ARGS= --enable-objprelink
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/include/SDL11/SDL.h)
-WITH_SDL= yes
-.endif
-
-.if defined(WITH_SDL) && ${WITH_SDL} == yes
-LIB_DEPENDS+= SDL-1.1.3:${PORTSDIR}/devel/sdl12
-CONFIGURE_ENV+= SDL_CONFIG="${LOCALBASE}/bin/sdl11-config"
-PLIST_SUB+= SDL=""
-.else
-PLIST_SUB+= SDL="@comment "
-pre-everything::
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with SDL support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_SDL=yes\""
- @${ECHO_MSG}
-.endif
+pre-configure:
+ ${MKDIR} ${WRKSRC}/auto-bin
+.for AC in autoconf autoheader
+ ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
+.endfor
+.for AM in automake aclocal
+ ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
+.endfor
+ cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ ${GMAKE} -f Makefile.cvs
+ find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
+ "s@sdl-config@${LOCALBASE}/bin/sdl11-config@g"
.include <bsd.port.post.mk>
diff --git a/misc/kdeaddons3/distinfo b/misc/kdeaddons3/distinfo
index 54bc41edca3c..40c40c31dea5 100644
--- a/misc/kdeaddons3/distinfo
+++ b/misc/kdeaddons3/distinfo
@@ -1 +1 @@
-MD5 (KDE/kdeaddons-2.2.1.tar.bz2) = 034f35ed3cd575b65f8ccc6110590d20
+MD5 (KDE/kdeaddons-2.2.2.tar.bz2) = 9392da0992f4aede5f6a86840e47fef6
diff --git a/misc/kdeaddons3/pkg-plist b/misc/kdeaddons3/pkg-plist
index 3eca8d5c45a4..de49b3f8b00c 100644
--- a/misc/kdeaddons3/pkg-plist
+++ b/misc/kdeaddons3/pkg-plist
@@ -1,11 +1,7 @@
-@unexec %%RM%% -f %D/lib/libkolourpicker.so
-@unexec %%RM%% -f %D/lib/libktimemon.so
-@unexec %%RM%% -f %D/share/doc/HTML/en/kate-plugins/common
-@unexec %%RM%% -f %D/share/doc/HTML/en/kicker-applets/common
bin/dcop_kate
-%%SDL%%bin/noatunsynaescope.bin
-%%SDL%%bin/noatuntippecanoe.bin
-%%SDL%%bin/noatuntyler.bin
+bin/noatunsynaescope.bin
+bin/noatuntippecanoe.bin
+bin/noatuntyler.bin
bin/testor
lib/kde2/libbabelfishplugin.la
lib/kde2/libbabelfishplugin.so
@@ -41,30 +37,30 @@ lib/libkolourpicker.so.1
lib/libktimemon.la
lib/libktimemon.so
lib/libktimemon.so.1
-%%SDL%%lib/libnoatunblurscope.la
-%%SDL%%lib/libnoatunblurscope.so
+lib/libnoatunblurscope.la
+lib/libnoatunblurscope.so
lib/libnoatunluckytag.la
lib/libnoatunluckytag.so
lib/libnoatunmadness.la
lib/libnoatunmadness.so
-%%SDL%%lib/libnoatunsynaescope.la
-%%SDL%%lib/libnoatunsynaescope.so
-%%SDL%%lib/libnoatuntippecanoe.la
-%%SDL%%lib/libnoatuntippecanoe.so
-%%SDL%%lib/libnoatuntyler.la
-%%SDL%%lib/libnoatuntyler.so
+lib/libnoatunsynaescope.la
+lib/libnoatunsynaescope.so
+lib/libnoatuntippecanoe.la
+lib/libnoatuntippecanoe.so
+lib/libnoatuntyler.la
+lib/libnoatuntyler.so
lib/libnoatunwakeup.la
lib/libnoatunwakeup.so
-share/apps/kate/plugins/katehtmltools/ui.rc
share/apps/kate/plugins/katehtmltools.desktop
-share/apps/kate/plugins/kateinsertcommand/ui.rc
+share/apps/kate/plugins/katehtmltools/ui.rc
share/apps/kate/plugins/kateinsertcommand.desktop
-share/apps/kate/plugins/kateopenheader/ui.rc
+share/apps/kate/plugins/kateinsertcommand/ui.rc
share/apps/kate/plugins/kateopenheader.desktop
-share/apps/kate/plugins/kateprojectmanager/ui.rc
+share/apps/kate/plugins/kateopenheader/ui.rc
share/apps/kate/plugins/kateprojectmanager.desktop
-share/apps/kate/plugins/katetextfilter/ui.rc
+share/apps/kate/plugins/kateprojectmanager/ui.rc
share/apps/kate/plugins/katetextfilter.desktop
+share/apps/kate/plugins/katetextfilter/ui.rc
share/apps/khtml/kpartplugins/khtmlsettingsplugin.rc
share/apps/khtml/kpartplugins/plugin_babelfish.rc
share/apps/khtml/kpartplugins/plugin_domtreeviewer.rc
@@ -84,13 +80,13 @@ share/apps/konqiconview/kpartplugins/dirfilterplugin.rc
share/apps/konqiconview/kpartplugins/kimgalleryplugin.rc
share/apps/konqlistview/kpartplugins/dirfilterplugin.rc
share/apps/konqlistview/kpartplugins/kimgalleryplugin.rc
-%%SDL%%share/apps/noatun/blurscope.plugin
+share/apps/noatun/blurscope.plugin
share/apps/noatun/luckytag.plugin
share/apps/noatun/madness.plugin
-%%SDL%%share/apps/noatun/synaescope.plugin
-%%SDL%%share/apps/noatun/tippecanoe.plugin
-%%SDL%%share/apps/noatun/tyler.plugin
-%%SDL%%share/apps/noatun/tylerstates
+share/apps/noatun/synaescope.plugin
+share/apps/noatun/tippecanoe.plugin
+share/apps/noatun/tyler.plugin
+share/apps/noatun/tylerstates
share/apps/noatun/wakeup.plugin
share/doc/HTML/en/kate-plugins/common
share/doc/HTML/en/kate-plugins/helloworld.docbook
@@ -124,28 +120,14 @@ share/icons/locolor/16x16/apps/ktimemon.png
share/icons/locolor/32x32/apps/ktimemon.png
share/mimelnk/application/x-webarchive.desktop
share/services/webarchivethumbnail.desktop
-@dirrm share/services
-@dirrm share/mimelnk/application
-@dirrm share/icons/locolor/32x32/apps
-@dirrm share/icons/locolor/16x16/apps
-@dirrm share/icons/hicolor/22x22/actions
-@dirrm share/icons/hicolor/16x16/actions
@dirrm share/doc/HTML/en/kicker-applets
@dirrm share/doc/HTML/en/kate-plugins
-@dirrm share/doc/HTML/en
-@dirrm share/apps/noatun
-@dirrm share/apps/konqlistview/kpartplugins
-@dirrm share/apps/konqiconview/kpartplugins
@dirrm share/apps/knewsticker/scripts
@dirrm share/apps/knewsticker
-@dirrm share/apps/kicker/applets
@dirrm share/apps/khtml/kpartplugins
-@dirrm share/apps/khtml
@dirrm share/apps/kate/plugins/katetextfilter
@dirrm share/apps/kate/plugins/kateprojectmanager
@dirrm share/apps/kate/plugins/kateopenheader
@dirrm share/apps/kate/plugins/kateinsertcommand
@dirrm share/apps/kate/plugins/katehtmltools
@dirrm share/apps/kate/plugins
-@dirrm share/apps/kate
-@dirrm lib/kde2