aboutsummaryrefslogtreecommitdiff
path: root/misc/kfile-plugins/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 13:03:38 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 13:03:38 +0000
commit0880dbf4740b2ce3bc0aeb719edf77e8ae3b6808 (patch)
treea18f7940e73dc8582da0ee4bedf903e99124fe4a /misc/kfile-plugins/Makefile
parente2df73802df0a5485b43ba7629466bb2c2ac9f64 (diff)
downloadports-0880dbf4740b2ce3bc0aeb719edf77e8ae3b6808.tar.gz
ports-0880dbf4740b2ce3bc0aeb719edf77e8ae3b6808.zip
Notes
Diffstat (limited to 'misc/kfile-plugins/Makefile')
-rw-r--r--misc/kfile-plugins/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/misc/kfile-plugins/Makefile b/misc/kfile-plugins/Makefile
new file mode 100644
index 000000000000..82a08e6e1d6b
--- /dev/null
+++ b/misc/kfile-plugins/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: kfile-plugins
+# Date created: 11 Febrary 2004
+# Whom: Michael Nottebrock <lofi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${KFILEPLUGINS_PORTNAME}
+PORTVERSION= ${KFILEPLUGINS_PORTVERSION}
+PORTREVISION= ${KFILEPLUGINS_PORTREVISION}
+CATEGORIES= misc kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Plugins for Konqueror (in filemanager mode)
+
+IGNORE= This port is part of KDE 3.2.1 and is not yet ready
+
+KDE_SPLIT= ${KFILEPLUGINS_PORTNAME:S/${KDE_SPLIT_DIST}-//}
+KDE_DOC_SPLIT= # none
+USE_KDEBASE_VER=3
+USE_KDELIBS_VER=3
+
+USE_BZIP2= yes
+PREFIX= ${KDE_PREFIX}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS+= %%PREFIX%%/lib/kde3
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include "${.CURDIR}/../../misc/kdeaddons3/Makefile.split"
+.include <bsd.port.mk>