aboutsummaryrefslogtreecommitdiff
path: root/misc/lf
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-20 06:26:12 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-20 06:26:12 +0000
commit49cbc2473763a149c502a69b41ef66222c3962d7 (patch)
tree58a387ddfc902d70d907d1acdca70dcb260d64d5 /misc/lf
parent7916621ff20a53e47ad893f76aa033bcdf5677bc (diff)
downloadports-49cbc2473763a149c502a69b41ef66222c3962d7.tar.gz
ports-49cbc2473763a149c502a69b41ef66222c3962d7.zip
New port: misc/lf: Terminal file manager
Notes
Notes: svn path=/head/; revision=502084
Diffstat (limited to 'misc/lf')
-rw-r--r--misc/lf/Makefile23
-rw-r--r--misc/lf/distinfo7
-rw-r--r--misc/lf/pkg-descr7
3 files changed, 37 insertions, 0 deletions
diff --git a/misc/lf/Makefile b/misc/lf/Makefile
new file mode 100644
index 000000000000..9a3297323573
--- /dev/null
+++ b/misc/lf/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= lf
+DISTVERSIONPREFIX= r
+DISTVERSION= 12
+CATEGORIES= misc
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Terminal file manager
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go
+USE_GITHUB= yes
+GH_ACCOUNT= gokcehan
+GH_TUPLE= mattn:go-runewidth:703b5e6:runewidth/vendor/github.com/mattn/go-runewidth \
+ nsf:termbox-go:288510b:termbox/vendor/github.com/nsf/termbox-go
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+
+PLIST_FILES= bin/lf
+
+.include <bsd.port.mk>
diff --git a/misc/lf/distinfo b/misc/lf/distinfo
new file mode 100644
index 000000000000..fcea810d1dfb
--- /dev/null
+++ b/misc/lf/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1558333231
+SHA256 (gokcehan-lf-r12_GH0.tar.gz) = 8a3ca71dd18ca01f34a08573049c5f9f4302b5c7a998443d2b0855792fdca7f2
+SIZE (gokcehan-lf-r12_GH0.tar.gz) = 64921
+SHA256 (mattn-go-runewidth-703b5e6_GH0.tar.gz) = 62c40ad7642da0ad00a3d47887cc7404c09703e580d65c709b2ecb65d721e9c8
+SIZE (mattn-go-runewidth-703b5e6_GH0.tar.gz) = 19884
+SHA256 (nsf-termbox-go-288510b_GH0.tar.gz) = f4f60382dbf63d1e453110e9dd44f8517316c8be3d40f0f101a845c7aae351b1
+SIZE (nsf-termbox-go-288510b_GH0.tar.gz) = 32359
diff --git a/misc/lf/pkg-descr b/misc/lf/pkg-descr
new file mode 100644
index 000000000000..d8a4a8350cfb
--- /dev/null
+++ b/misc/lf/pkg-descr
@@ -0,0 +1,7 @@
+lf (as in "list files") is a terminal file manager written in Go. It is heavily
+inspired by ranger with some missing and extra features. Some of the missing
+features are deliberately omitted since they are better handled by external
+tools. See faq for more information and tutorial for a gentle introduction with
+screencasts.
+
+WWW: https://github.com/gokcehan/lf