aboutsummaryrefslogtreecommitdiff
path: root/misc/libhome/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2005-08-30 03:25:29 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2005-08-30 03:25:29 +0000
commit8cc647ca0628c92ca96c813dadf21054ab7f4231 (patch)
treea968df6f5bf12292d70ffcb4bf44843e0b71560e /misc/libhome/Makefile
parentf6a2177cda0f8e357e5bf92de810bb117264a9a4 (diff)
Notes
Diffstat (limited to 'misc/libhome/Makefile')
-rw-r--r--misc/libhome/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/misc/libhome/Makefile b/misc/libhome/Makefile
index f7ead6f5fbe2..f49c2dba0998 100644
--- a/misc/libhome/Makefile
+++ b/misc/libhome/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libhome
-PORTVERSION= 0.9
+PORTVERSION= 0.10
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pll
@@ -19,7 +19,6 @@ OPTIONS+= MYSQL "Support for MySQL queries" on
OPTIONS+= DB3 "Support for DB3" on
OPTIONS+= DB4 "Support for DB4" off
OPTIONS+= PAM "Support for PAM (Experimental)" off
-OPTIONS+= PROXY "Support for Proxy Driver (Experimental)" off
OPTIONS+= PGSQL "Support for PostgreSQL (Experimental)" off
USE_LIBTOOL_VER= 15
@@ -32,6 +31,8 @@ INSTALLS_SHLIB= yes
.error You cannot use DB3 and DB4 in the same time.
.endif
+CONFIGURE_ARGS+= --with-proxy --with-nss
+
.if !defined(WITHOUT_LDAP)
USE_OPENLDAP= yes
CONFIGURE_ARGS+= --with-ldap=${LOCALBASE}/include
@@ -66,12 +67,6 @@ CONFIGURE_ARGS+= --with-pam
CONFIGURE_ARGS+= --without-pam
.endif
-.if defined(WITH_PROXY)
-CONFIGURE_ARGS+= --with-proxy
-.else
-CONFIGURE_ARGS+= --without-proxy
-.endif
-
.if defined(WITH_PGSQL)
CONFIGURE_ARGS+= --with-pgsql
USE_PGSQL= YES
@@ -80,8 +75,10 @@ CONFIGURE_ARGS+= --without-pgsql
.endif
MAN5= home.conf.5
+MAN8= home_proxy.8
post-install:
${INSTALL_DATA} ${WRKSRC}/home.conf ${PREFIX}/etc/home.conf.dist
+ ${INSTALL_SCRIPT} ${WRKSRC}/rc/freebsd/home_proxy.sh ${PREFIX}/etc/rc.d/home_proxy.sh
.include <bsd.port.post.mk>