aboutsummaryrefslogtreecommitdiff
path: root/misc/libmcal/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-12 20:16:22 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-12 20:16:22 +0000
commit743a256850e12f012a76b99359e6c03d1d3885e4 (patch)
treebf506df04b90128ea1ec03cd1e7b170d77b7d54f /misc/libmcal/Makefile
parenta86a05bdbc1443212e3f3287625e583a8bd4ae00 (diff)
downloadports-743a256850e12f012a76b99359e6c03d1d3885e4.tar.gz
ports-743a256850e12f012a76b99359e6c03d1d3885e4.zip
Notes
Diffstat (limited to 'misc/libmcal/Makefile')
-rw-r--r--misc/libmcal/Makefile24
1 files changed, 7 insertions, 17 deletions
diff --git a/misc/libmcal/Makefile b/misc/libmcal/Makefile
index 795c5117c773..54461e1eeeed 100644
--- a/misc/libmcal/Makefile
+++ b/misc/libmcal/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libmcal
PORTVERSION= 0.6
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -34,7 +35,6 @@ post-extract:
${CP} -pR ${WRKSRCDRV}/icap ${WRKSRC}
${MV} ${WRKSRC}/mstore/Makefile ${WRKSRC}/mstore/Makefile.dist
${MV} ${WRKSRC}/mstore/Makefile.FreeBSD ${WRKSRC}/mstore/Makefile
- ${PERL} -pi -e "s:/etc/mpasswd:${PREFIX}/etc/mpasswd:" ${WRKSRC}/mstore/mstore.c
${MV} ${WRKSRC}/icap/Makefile ${WRKSRC}/icap/Makefile.dist
${MV} ${WRKSRC}/icap/Makefile.FreeBSD ${WRKSRC}/icap/Makefile
${MV} ${WRKSRC}/configure ${WRKSRC}/configure.dist
@@ -42,6 +42,9 @@ post-extract:
${CHMOD} u+x ${WRKSRC}/configure
${MV} ${WRKSRC}/mstore/README ${WRKSRC}/mstore/README.mstore
+post-patch:
+ ${PERL} -pi -e "s:/etc/mpasswd:${PREFIX}/etc/mpasswd:" ${WRKSRC}/mstore/mstore.c
+
pre-configure:
@${ECHO_MSG} "===> Building the driver mstore"
cd ${WRKSRC}/mstore ; \
@@ -60,21 +63,8 @@ post-install:
.endfor
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
- @${ECHO} "*****************************************************************************"
- @${ECHO} " libmcap has been installed. In order to end its configuration,"
- @${ECHO} " please enter the following commands:"
- @${ECHO} ""
- @${ECHO} " mkdir /var/calendar"
- @${ECHO} " chmod 1777 /var/calendar"
- @${ECHO} ""
- @${ECHO} " To work with the mstore driver, using the Apache's htpasswd utility,"
- @${ECHO} " you may create the mpasswd file with the command below:"
- @${ECHO} ""
- @${ECHO} " htpasswd -c ${LOCALBASE}/etc/mpasswd username"
- @${ECHO} ""
- @${ECHO} " To add or update this file you would execute as follows:"
- @${ECHO} ""
- @${ECHO} " htpasswd ${LOCALBASE}/etc/mpasswd username"
- @${ECHO} "*****************************************************************************"
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE} | ${SED} -e "s:%%LOCALBASE%%:${LOCALBASE}:g"
+ @${ECHO}
.include <bsd.port.mk>