aboutsummaryrefslogtreecommitdiff
path: root/misc/lingoteach
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-11-18 04:28:01 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-11-18 04:28:01 +0000
commit0d977d5e7a8abc27de2728d6efdbacf4b27d1244 (patch)
tree7a0c632adf03c47d753a533177907791364a4039 /misc/lingoteach
parentb26260296615e0b0cde7ec9727327d2f20f3d3f9 (diff)
downloadports-0d977d5e7a8abc27de2728d6efdbacf4b27d1244.tar.gz
ports-0d977d5e7a8abc27de2728d6efdbacf4b27d1244.zip
- Update to 0.3.9
- Use system gettext instead of bundled one * Lingoteach is now able to display multiple languages at once * New search and browse feature with a tree like structure * User manual PR: ports/58782 Submitted by: maintainer Approved by: adamw (mentor)
Notes
Notes: svn path=/head/; revision=94230
Diffstat (limited to 'misc/lingoteach')
-rw-r--r--misc/lingoteach/Makefile53
-rw-r--r--misc/lingoteach/distinfo2
-rw-r--r--misc/lingoteach/pkg-plist42
3 files changed, 59 insertions, 38 deletions
diff --git a/misc/lingoteach/Makefile b/misc/lingoteach/Makefile
index 7921c52343f3..b21c22501285 100644
--- a/misc/lingoteach/Makefile
+++ b/misc/lingoteach/Makefile
@@ -1,37 +1,37 @@
# New ports collection makefile for: lingoteach
# Date created: 01 September 2002
-# Whom: Marcus vA
+# Whom: Marcus von Appen
#
# $FreeBSD$
#
PORTNAME= lingoteach
-PORTVERSION= 0.3.8
+PORTVERSION= 0.3.9
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= ${PORTNAME}-ui-${PORTVERSION}.tar.gz
.if defined(WITH_SOUND)
-DISTFILES= ${PORTNAME}-sound-${PORTVERSION}.tar.gz \
- ${PORTNAME}-${PORTVERSION}.tar.gz
+DISTFILES+= ${PORTNAME}-sound-${SOUNDV}.tar.gz
.endif
MAINTAINER= mva@sysfault.org
COMMENT= A language teaching program with sound
-LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS= lingoteach.0:${PORTSDIR}/textproc/liblingoteach
-.if defined(WITH_SOUND)
-RUN_DEPENDS= ogg123:${PORTSDIR}/audio/vorbis-tools
-.endif
+WRKSRC= ${WRKDIR}/${PORTNAME}-ui-${PORTVERSION}
USE_GNOME= gtk20
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= ""
USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
-.if defined(WITH_COMP)
-CONFIGURE_ARGS+= --with-compression
-.endif
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+
+# sound version
+SOUNDV= 0.3.8
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
@@ -51,30 +51,37 @@ pre-everything::
@${ECHO_CMD} ""
@${ECHO_CMD} " WITH_SOUND download additional sounds"
@${ECHO_CMD} " for lingoteach"
- @${ECHO_CMD} " WITH_COMP enable compression of data"
- @${ECHO_CMD} " files"
@${ECHO_CMD} " WITH_DEBUG enable debugging"
@${ECHO_CMD} ""
+post-patch::
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|^SUBDIRS = intl src po data doc|SUBDIRS = src po data|g' \
+ ${WRKSRC}/Makefile.in
+.else
+ @${REINPLACE_CMD} -e 's|^SUBDIRS = intl src po data doc|SUBDIRS = src po data doc|g' \
+ ${WRKSRC}/Makefile.in
+.endif
+
.if defined(WITH_SOUND)
pre-install::
- ${CAT} pkg-plist | ${SED} '/@dirrm/d' > ${WRKDIR}/plist; \
- cd ${WRKDIR}/${PORTNAME}-sound-${PORTVERSION}/data; \
- ${FIND} . -type f \! -name "Make*" | cut -c2- | \
+ @${CAT} pkg-plist | ${SED} '/@dirrm/d' > ${PLIST}; \
+ cd ${WRKDIR}/${PORTNAME}-sound-${SOUNDV}/data; \
+ ${FIND} . -type f \! -name "Make*" | ${CUT} -c2- | \
${SED} 's|^|${DATADIR:S,${PREFIX}/,,}/data|' \
| ${SORT} >> ${PLIST}; \
- ${CAT} ${WRKDIR}/../pkg-plist | ${GREP} '@dirrm include' >> ${PLIST}; \
- cd ${WRKDIR}/${PORTNAME}-sound-${PORTVERSION}/data; \
- ${FIND} . -type d | cut -c2- | ${SED} \
- 's|^|@dirrm ${DATADIR:S,${PREFIX}/,,}/data|' | ${SORT} -r >> ${PLIST};
+ ${CAT} ${.CURDIR}/pkg-plist | ${SED} '/%%PORTDOCS%%@dirrm/!d' >> ${PLIST}; \
+ cd ${WRKDIR}/${PORTNAME}-sound-${SOUNDV}/data; \
+ ${FIND} . -type d | ${CUT} -c2- | ${SED} \
+ 's|^|@dirrm ${DATADIR:S,${PREFIX}/,,}/data|' | ${SORT} -r >> ${PLIST}; \
${ECHO_CMD} "@dirrm ${DATADIR:S,${PREFIX}/,,}" >> ${PLIST};
.endif
.if defined(WITH_SOUND)
post-install::
- cd ${WRKDIR}/${PORTNAME}-sound-${PORTVERSION}/data; \
+ cd ${WRKDIR}/${PORTNAME}-sound-${SOUNDV}/data; \
${RM} -f Make*; \
- ${CP} -R ${WRKDIR}/${PORTNAME}-sound-${PORTVERSION}/data \
+ ${CP} -R ${WRKDIR}/${PORTNAME}-sound-${SOUNDV}/data \
${DATADIR};
.endif
diff --git a/misc/lingoteach/distinfo b/misc/lingoteach/distinfo
index 6c802662fe7b..a9492ccd4056 100644
--- a/misc/lingoteach/distinfo
+++ b/misc/lingoteach/distinfo
@@ -1,2 +1,2 @@
+MD5 (lingoteach-ui-0.3.9.tar.gz) = f89acfb1d4f048cdf1d6086f605d219c
MD5 (lingoteach-sound-0.3.8.tar.gz) = 981f0b5bfaf84b7dbf31c0a826130cf0
-MD5 (lingoteach-0.3.8.tar.gz) = a78626a2c5ec2c24b2270bd0a75f949d
diff --git a/misc/lingoteach/pkg-plist b/misc/lingoteach/pkg-plist
index 62dc61fbb43b..550cf461905f 100644
--- a/misc/lingoteach/pkg-plist
+++ b/misc/lingoteach/pkg-plist
@@ -1,22 +1,36 @@
bin/lingoteach-gtk
-include/lingoteach/conf.h
-include/lingoteach/data.h
-include/lingoteach/iterator.h
-include/lingoteach/language.h
-include/lingoteach/lesson.h
-include/lingoteach/meaning.h
-include/lingoteach/sound.h
-info/lingoteach.info
-lib/liblingoteach.a
-lib/liblingoteach.la
-lib/liblingoteach.so
-lib/liblingoteach.so.0
+%%PORTDOCS%%share/doc/lingoteach/img/first-start.png
+%%PORTDOCS%%share/doc/lingoteach/img/pref-general.png
+%%PORTDOCS%%share/doc/lingoteach/img/pref-lesson.png
+%%PORTDOCS%%share/doc/lingoteach/img/pref-module.png
+%%PORTDOCS%%share/doc/lingoteach/img/pref-system.png
+%%PORTDOCS%%share/doc/lingoteach/img/use-filter.png
+%%PORTDOCS%%share/doc/lingoteach/img/use-multichoice.png
+%%PORTDOCS%%share/doc/lingoteach/img/use-onebyone.png
+%%PORTDOCS%%share/doc/lingoteach/img/use-search.png
+%%PORTDOCS%%share/doc/lingoteach/index.html
+%%PORTDOCS%%share/doc/lingoteach/lingoteach-conf.html
+%%PORTDOCS%%share/doc/lingoteach/lingoteach-install.html
+%%PORTDOCS%%share/doc/lingoteach/lingoteach-use.html
+%%PORTDOCS%%share/doc/lingoteach/lingoteach.css
+%%PORTDOCS%%share/doc/lingoteach/ln-legal.html
+share/lingoteach/AUTHORS
+share/lingoteach/COPYING
+share/lingoteach/README
share/lingoteach/data/basic.xml
-share/lingoteach/data/freedict.xml
share/lingoteach/data/language.dtd
share/lingoteach/data/language.xml
share/lingoteach/data/lingoteach.dtd
share/lingoteach/data/rules.en.txt
+share/locale/da/LC_MESSAGES/lingoteach.mo
+share/locale/de/LC_MESSAGES/lingoteach.mo
+share/locale/eo/LC_MESSAGES/lingoteach.mo
+share/locale/fr/LC_MESSAGES/lingoteach.mo
+share/locale/hu/LC_MESSAGES/lingoteach.mo
+share/locale/id/LC_MESSAGES/lingoteach.mo
+share/locale/pt_BR/LC_MESSAGES/lingoteach.mo
+share/locale/sv/LC_MESSAGES/lingoteach.mo
@dirrm share/lingoteach/data
@dirrm share/lingoteach
-@dirrm include/lingoteach
+%%PORTDOCS%%@dirrm share/doc/lingoteach/img
+%%PORTDOCS%%@dirrm share/doc/lingoteach