aboutsummaryrefslogtreecommitdiff
path: root/misc/lingoteach
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-29 03:42:13 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-29 03:42:13 +0000
commit6e2badba4d1c53e092e3003024c39ae3baf1a20f (patch)
tree1c7bf5f5094feccdc6dc18bcda3044d5c93c115e /misc/lingoteach
parentdbcfa3aed1761ca025db64f3ebab6e92962cad62 (diff)
downloadports-6e2badba4d1c53e092e3003024c39ae3baf1a20f.tar.gz
ports-6e2badba4d1c53e092e3003024c39ae3baf1a20f.zip
Notes
Diffstat (limited to 'misc/lingoteach')
-rw-r--r--misc/lingoteach/Makefile40
-rw-r--r--misc/lingoteach/distinfo4
-rw-r--r--misc/lingoteach/pkg-plist22
3 files changed, 42 insertions, 24 deletions
diff --git a/misc/lingoteach/Makefile b/misc/lingoteach/Makefile
index 112dd0c22cc7..7921c52343f3 100644
--- a/misc/lingoteach/Makefile
+++ b/misc/lingoteach/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lingoteach
-PORTVERSION= 0.3.7
-PORTREVISION= 2
+PORTVERSION= 0.3.8
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -30,6 +29,14 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= ""
USE_GMAKE= yes
+.if defined(WITH_COMP)
+CONFIGURE_ARGS+= --with-compression
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
.if defined(WITH_SOUND)
PLIST= ${WRKDIR}/plist
.endif
@@ -38,28 +45,25 @@ SORT?= /usr/bin/sort
.include <bsd.port.pre.mk>
-.if !defined(WITH_SOUND)
-pre-extract::
- @${ECHO_CMD} "************************************************"
- @${ECHO_CMD} "* *"
- @${ECHO_CMD} "* For Sound in Lingoteach, type Ctrl-C now and *"
- @${ECHO_CMD} "* define WITH_SOUND=yes *"
- @${ECHO_CMD} "* *"
- @${ECHO_CMD} "************************************************"
- @sleep 3
-.endif
+pre-everything::
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} " Available options for lingoteach:"
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} " WITH_SOUND download additional sounds"
+ @${ECHO_CMD} " for lingoteach"
+ @${ECHO_CMD} " WITH_COMP enable compression of data"
+ @${ECHO_CMD} " files"
+ @${ECHO_CMD} " WITH_DEBUG enable debugging"
+ @${ECHO_CMD} ""
.if defined(WITH_SOUND)
pre-install::
- cd ${WRKSRC}/src; ${ECHO_CMD} \
- "bin/`find . -type f -perm 755 |cut -c3-`" > ${PLIST}; \
+ ${CAT} pkg-plist | ${SED} '/@dirrm/d' > ${WRKDIR}/plist; \
cd ${WRKDIR}/${PORTNAME}-sound-${PORTVERSION}/data; \
${FIND} . -type f \! -name "Make*" | cut -c2- | \
${SED} 's|^|${DATADIR:S,${PREFIX}/,,}/data|' \
| ${SORT} >> ${PLIST}; \
- cd ${WRKDIR}/${PORTNAME}-${PORTVERSION}/data; \
- ${FIND} . -type f \! -name "Make*" | cut -c2- | ${SED} \
- 's|^|${DATADIR:S,${PREFIX}/,,}/data|' | ${SORT} >> ${PLIST}; \
+ ${CAT} ${WRKDIR}/../pkg-plist | ${GREP} '@dirrm include' >> ${PLIST}; \
cd ${WRKDIR}/${PORTNAME}-sound-${PORTVERSION}/data; \
${FIND} . -type d | cut -c2- | ${SED} \
's|^|@dirrm ${DATADIR:S,${PREFIX}/,,}/data|' | ${SORT} -r >> ${PLIST};
@@ -69,7 +73,7 @@ pre-install::
.if defined(WITH_SOUND)
post-install::
cd ${WRKDIR}/${PORTNAME}-sound-${PORTVERSION}/data; \
- ${RM} Make*; \
+ ${RM} -f Make*; \
${CP} -R ${WRKDIR}/${PORTNAME}-sound-${PORTVERSION}/data \
${DATADIR};
.endif
diff --git a/misc/lingoteach/distinfo b/misc/lingoteach/distinfo
index ace84341109d..6c802662fe7b 100644
--- a/misc/lingoteach/distinfo
+++ b/misc/lingoteach/distinfo
@@ -1,2 +1,2 @@
-MD5 (lingoteach-sound-0.3.7.tar.gz) = 13f008b67161fef001258582986b0997
-MD5 (lingoteach-0.3.7.tar.gz) = ac128bbf49b8e70fbe296aa9f71c5baf
+MD5 (lingoteach-sound-0.3.8.tar.gz) = 981f0b5bfaf84b7dbf31c0a826130cf0
+MD5 (lingoteach-0.3.8.tar.gz) = a78626a2c5ec2c24b2270bd0a75f949d
diff --git a/misc/lingoteach/pkg-plist b/misc/lingoteach/pkg-plist
index 4284e673e8c2..62dc61fbb43b 100644
--- a/misc/lingoteach/pkg-plist
+++ b/misc/lingoteach/pkg-plist
@@ -1,8 +1,22 @@
-bin/lingoteach
-share/lingoteach/data/rules.en.txt
-share/lingoteach/data/lingoteach.dtd
+bin/lingoteach-gtk
+include/lingoteach/conf.h
+include/lingoteach/data.h
+include/lingoteach/iterator.h
+include/lingoteach/language.h
+include/lingoteach/lesson.h
+include/lingoteach/meaning.h
+include/lingoteach/sound.h
+info/lingoteach.info
+lib/liblingoteach.a
+lib/liblingoteach.la
+lib/liblingoteach.so
+lib/liblingoteach.so.0
+share/lingoteach/data/basic.xml
+share/lingoteach/data/freedict.xml
share/lingoteach/data/language.dtd
share/lingoteach/data/language.xml
-share/lingoteach/data/basic.xml
+share/lingoteach/data/lingoteach.dtd
+share/lingoteach/data/rules.en.txt
@dirrm share/lingoteach/data
@dirrm share/lingoteach
+@dirrm include/lingoteach