aboutsummaryrefslogtreecommitdiff
path: root/misc/linm
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-04-11 14:55:33 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-04-11 14:55:33 +0000
commit2ab476a8cf9ac0d08c9a0639d91563454a6d13c0 (patch)
tree378f7e37477e82dec0fd7983923ca138d51bd266 /misc/linm
parent0fd5432d0030914fddc71dbfb0ad14291b0dfcc0 (diff)
downloadports-2ab476a8cf9ac0d08c9a0639d91563454a6d13c0.tar.gz
ports-2ab476a8cf9ac0d08c9a0639d91563454a6d13c0.zip
- Add a patch to replace deprecated des_* methods from des_old.h, which
enables the build against LibreSSL (OpenSSL head has also removed this header) - Simplify WRKSRC and move it where it normally belongs in Makefile - Remove no longer required "/LIBS=/s|-lpthread|-pthread|" gimmick, and bring Makefile header under standard form - Provide a better port description while I'm here PR: 198984 Submitted by: Bernard Spil
Notes
Notes: svn path=/head/; revision=383804
Diffstat (limited to 'misc/linm')
-rw-r--r--misc/linm/Makefile13
-rw-r--r--misc/linm/files/patch-panel_common_passencrypt.cpp48
-rw-r--r--misc/linm/pkg-descr6
3 files changed, 57 insertions, 10 deletions
diff --git a/misc/linm/Makefile b/misc/linm/Makefile
index efd180a1de76..a05d946011bb 100644
--- a/misc/linm/Makefile
+++ b/misc/linm/Makefile
@@ -1,4 +1,4 @@
-# Created by: cjh@FreeBSD.org
+# Created by: CHOI Junho <cjh@FreeBSD.org>
# $FreeBSD$
PORTNAME= linm
@@ -14,8 +14,6 @@ COMMENT= Clone of Mdir, mc-style terminal file manager
LICENSE= GPLv2 # (or later)
LICENSE_FILE= ${WRKSRC}/COPYING
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/-.*//}
-
USES= gettext pkgconfig gmake libtool
USE_OPENSSL= yes
GNU_CONFIGURE= yes
@@ -23,6 +21,8 @@ CONFIGURE_ARGS= --enable-cfgpath="${ETCDIR}"
MAKE_JOBS_UNSAFE= yes
INSTALL_TARGET= install-strip
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -39,11 +39,8 @@ PLIST_SUB+= SMB="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -e \
- 's|configpath|cfgpath|g ; \
- /LIBS=/s|-lpthread|-pthread|' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
- '/^AM_CFLAGS/s|=.*|= -fPIC -std=gnu89|' \
+ @${REINPLACE_CMD} -e 's|configpath|cfgpath|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^AM_CFLAGS/s|=.*|= -fPIC -std=gnu89|' \
${WRKSRC}/panel/vfs/libssh2/Makefile.in
post-install:
diff --git a/misc/linm/files/patch-panel_common_passencrypt.cpp b/misc/linm/files/patch-panel_common_passencrypt.cpp
new file mode 100644
index 000000000000..8bbfe7550371
--- /dev/null
+++ b/misc/linm/files/patch-panel_common_passencrypt.cpp
@@ -0,0 +1,48 @@
+--- panel/common/passencrypt.cpp.orig 2007-11-24 13:03:32 UTC
++++ panel/common/passencrypt.cpp
+@@ -64,9 +64,9 @@ char PasswdCrypt::HexValue(char c)
+ void PasswdCrypt::DesECBEncode(const string& sKeyHex, const string& sDecode, string& sEncode)
+ {
+ #ifdef __LINM_SFTP_USE__
+- des_key_schedule tKeySchedule;
++ DES_key_schedule tKeySchedule;
+
+- des_cblock tHexBlock, tSrcBlock, tDecBlock;
++ DES_cblock tHexBlock, tSrcBlock, tDecBlock;
+ char cHexa[] = {'0','1','2','3','4','5','6','7','8','9','A','B','C','D','E','F'};
+ unsigned char cMask[2] = {0xF0, 0x0F};
+ char cEncode[17];
+@@ -93,8 +93,8 @@ void PasswdCrypt::DesECBEncode(const str
+ tSrcBlock[i] = (unsigned char)' ';
+ }
+
+- des_set_key((const_des_cblock*)&tHexBlock, tKeySchedule);
+- des_ecb_encrypt((const_des_cblock*)&tSrcBlock, &tDecBlock, tKeySchedule, DES_ENCRYPT);
++ DES_set_key((const_DES_cblock*)&tHexBlock, &tKeySchedule);
++ DES_ecb_encrypt((const_DES_cblock*)&tSrcBlock, &tDecBlock, &tKeySchedule, DES_ENCRYPT);
+
+ for(i=0; i<8; i++)
+ {
+@@ -110,9 +110,9 @@ void PasswdCrypt::DesECBEncode(const str
+ void PasswdCrypt::DesECBDecode(const string& sKeyHex, const string& sEncode, string& sDecode)
+ {
+ #ifdef __LINM_SFTP_USE__
+- des_key_schedule tKeySchedule;
++ DES_key_schedule tKeySchedule;
+
+- des_cblock tKeyBlock, tEncBlock, tDecBlock;
++ DES_cblock tKeyBlock, tEncBlock, tDecBlock;
+ char cKeyHex[16];
+ char cEncode[16];
+ int i;
+@@ -133,8 +133,8 @@ void PasswdCrypt::DesECBDecode(const str
+ HEX2BYTE(*(tEncBlock+i), cEncode+i*2);
+ }
+
+- des_set_key((const_des_cblock*)&tKeyBlock, tKeySchedule);
+- des_ecb_encrypt((const_des_cblock*)&tEncBlock, &tDecBlock, tKeySchedule, DES_DECRYPT);
++ DES_set_key((const_DES_cblock*)&tKeyBlock, &tKeySchedule);
++ DES_ecb_encrypt((const_DES_cblock*)&tEncBlock, &tDecBlock, &tKeySchedule, DES_DECRYPT);
+
+ sDecode = "";
+ for(i=0; i<8; i++)
diff --git a/misc/linm/pkg-descr b/misc/linm/pkg-descr
index 033a718821cd..96a5b1e75853 100644
--- a/misc/linm/pkg-descr
+++ b/misc/linm/pkg-descr
@@ -1,4 +1,6 @@
-linm/mls is a clone of Mdir, the popular file manager from the MS-DOS
-age in Korea.
+LinM is a Linux clone of famous MS-DOS file manager Mdir, popular in
+Korea. It inherits keyboard shortcuts and screen layout from Mdir in
+order to maximize user-friendliness, and supports FTP, SFTP, and SMB
+protocols.
WWW: http://kldp.net/projects/mls/