aboutsummaryrefslogtreecommitdiff
path: root/misc/magicpoint
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /misc/magicpoint
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'misc/magicpoint')
-rw-r--r--misc/magicpoint/Makefile6
-rw-r--r--misc/magicpoint/files/patch-png.c20
2 files changed, 23 insertions, 3 deletions
diff --git a/misc/magicpoint/Makefile b/misc/magicpoint/Makefile
index d6cf246981b9..036c341c06e3 100644
--- a/misc/magicpoint/Makefile
+++ b/misc/magicpoint/Makefile
@@ -7,14 +7,14 @@
PORTNAME= magicpoint
PORTVERSION= 1.13a
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES?= misc
MASTER_SITES= ftp://sh.wide.ad.jp/WIDE/free-ware/mgp/
MAINTAINER= dinoex@FreeBSD.org
COMMENT= An X11-based presentation tool
-LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png \
+LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png \
mng:${PORTSDIR}/graphics/libmng
RUN_DEPENDS+= pnmscale:${PORTSDIR}/graphics/netpbm
@@ -78,7 +78,7 @@ CONFIGURE_ARGS+= --disable-imlib
post-patch:
${REINPLACE_CMD} -e 's|-lungif|-lgif|' \
-e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
- ${WRKSRC}/configure ${WRKSRC}/image/png.c
+ ${WRKSRC}/configure
post-configure:
cd ${WRKSRC}/contrib/xmindpath && \
diff --git a/misc/magicpoint/files/patch-png.c b/misc/magicpoint/files/patch-png.c
new file mode 100644
index 000000000000..59d7537f2734
--- /dev/null
+++ b/misc/magicpoint/files/patch-png.c
@@ -0,0 +1,20 @@
+--- image/png.c.orig 2001-04-11 10:37:00.000000000 +0200
++++ image/png.c 2012-05-05 08:48:02.000000000 +0200
+@@ -86,7 +86,7 @@
+ return NULL;
+ }
+
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ fclose(fp);
+ return NULL;
+@@ -134,7 +134,7 @@
+ }
+
+ if (colortype == PNG_COLOR_TYPE_GRAY && bitdepth < 8){
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ }
+
+ if (png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS)){