aboutsummaryrefslogtreecommitdiff
path: root/misc/magicpoint
diff options
context:
space:
mode:
authorYoshio MITA <mita@FreeBSD.org>2001-01-21 03:10:31 +0000
committerYoshio MITA <mita@FreeBSD.org>2001-01-21 03:10:31 +0000
commit21eac153253a8a25c6393eb51a22c8993501159e (patch)
tree1fc090e56edb38385b1376a1f4eaa420a953b87d /misc/magicpoint
parentb743e6df03903c6124b1e8c38eff66e232da64f3 (diff)
downloadports-21eac153253a8a25c6393eb51a22c8993501159e.tar.gz
ports-21eac153253a8a25c6393eb51a22c8993501159e.zip
Notes
Diffstat (limited to 'misc/magicpoint')
-rw-r--r--misc/magicpoint/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/misc/magicpoint/Makefile b/misc/magicpoint/Makefile
index b9437cd0922c..dcc6b18361c7 100644
--- a/misc/magicpoint/Makefile
+++ b/misc/magicpoint/Makefile
@@ -35,20 +35,28 @@ EMACS_LISPS= mgp-mode.el mgp-el/COPYING mgp-el/README \
mgp-el/mgp.el mgp-el/mgp.sty mgp-el/sample.tex
SAMPLE_SCRIPTS= eqn2eps.sh tex2eps.sh mgp2html.pl mgp2latex.pl
+.include <bsd.port.pre.mk>
+
post-configure:
(cd ${WRKSRC}/contrib/xmindpath; ./configure --prefix=${PREFIX})
post-build:
- (cd ${WRKSRC}/contrib/xmindpath; make; \
+ (cd ${WRKSRC}/contrib/xmindpath; make)
+.if ${XFREE86_VERSION} == 4
+ (cd ${WRKSRC}/contrib/xmindpath; \
${RM} -f xmindpath.1.html xmindpath-1.html; \
${X11BASE}/bin/rman -f HTML < xmindpath.1 > xmindpath-1.html && \
${MV} -f xmindpath-1.html xmindpath.1.html)
+.endif
# NOTE: there are some discussions/twists in gzip'ing xmindpath.1.
post-install:
- (cd ${WRKSRC}/contrib/xmindpath; make install; \
- ${INSTALL_MAN} xmindpath.1.html ${PREFIX}/lib/X11/doc/html)
+ (cd ${WRKSRC}/contrib/xmindpath; make install)
${GZIP_CMD} ${PREFIX}/man/man1/xmindpath.1
+.if ${XFREE86_VERSION} == 4
+ (cd ${WRKSRC}/contrib/xmindpath;
+ ${INSTALL_MAN} xmindpath.1.html ${PREFIX}/lib/X11/doc/html)
+.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/mgp
for i in $(DOCS); do \
@@ -68,4 +76,4 @@ post-install:
done
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>