aboutsummaryrefslogtreecommitdiff
path: root/misc/magicpoint
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-09-03 05:00:32 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-09-03 05:00:32 +0000
commitea1237cf5e53134db56449396d80dbaa8167c827 (patch)
treec5183529cbd52b0d0faab4943e4caa6b90207378 /misc/magicpoint
parent921f1f3bb19b61ed1c47eac175ae694466b6b107 (diff)
downloadports-ea1237cf5e53134db56449396d80dbaa8167c827.tar.gz
ports-ea1237cf5e53134db56449396d80dbaa8167c827.zip
Notes
Diffstat (limited to 'misc/magicpoint')
-rw-r--r--misc/magicpoint/Makefile2
-rw-r--r--misc/magicpoint/files/patch-draw.c17
2 files changed, 18 insertions, 1 deletions
diff --git a/misc/magicpoint/Makefile b/misc/magicpoint/Makefile
index 2f72854ccfbf..d401653f18f3 100644
--- a/misc/magicpoint/Makefile
+++ b/misc/magicpoint/Makefile
@@ -3,7 +3,7 @@
PORTNAME= magicpoint
PORTVERSION= 1.13a
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES?= misc
MASTER_SITES= ftp://sh.wide.ad.jp/WIDE/free-ware/mgp/
diff --git a/misc/magicpoint/files/patch-draw.c b/misc/magicpoint/files/patch-draw.c
new file mode 100644
index 000000000000..c2e711a07490
--- /dev/null
+++ b/misc/magicpoint/files/patch-draw.c
@@ -0,0 +1,17 @@
+--- draw.c.orig 2008-01-24 16:43:17.000000000 +0100
++++ draw.c 2013-09-03 06:48:44.000000000 +0200
+@@ -5471,12 +5471,12 @@
+ XFT_FAMILY, XftTypeString, font,
+ XFT_ENCODING, XftTypeString, registry,
+ XFT_STYLE, XftTypeString, style,
+- XFT_PIXEL_SIZE, XftTypeDouble, (float)csize, 0);
++ XFT_PIXEL_SIZE, XftTypeDouble, (float)csize, NULL);
+ } else {
+ xftfont = XftFontOpen(display, screen,
+ XFT_FAMILY, XftTypeString, font,
+ XFT_ENCODING, XftTypeString, registry,
+- XFT_PIXEL_SIZE, XftTypeDouble, (float)csize, 0);
++ XFT_PIXEL_SIZE, XftTypeDouble, (float)csize, NULL);
+ }
+ if (xftfont == 0) {
+ free(xfont);