aboutsummaryrefslogtreecommitdiff
path: root/misc/mbuffer
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2021-01-16 16:56:30 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2021-01-16 16:56:30 +0000
commit051501c445b9f181828693d28d291fe0e00741a2 (patch)
tree8c76f021fe4e6a2e3b5e76c247f062b7589278a3 /misc/mbuffer
parentc63daa1f70e8c7f4d54c88f60a62d7e42642d4c3 (diff)
downloadports-051501c445b9f181828693d28d291fe0e00741a2.tar.gz
ports-051501c445b9f181828693d28d291fe0e00741a2.zip
misc/mbuffer: Update to 20200929
Upstream changes according to the ChangeLog: - enhancement: added option --no-direct to disable use of O_DIRECT - defaults: raised default TCP timeout to 10ms for WAN connections - fix: leave TCP buffer size untouched if not set - enhancement: add option to set TCP timeout - performance optimization: use recv with MSG_WAITALL instead of read - configure fix: look for objdump also with target prefix - testing: make sure to use gtar for testing to avoid unexpected failures - portability: NetBSD compatibility fix - build enhancement: added dependency calculation for make - build enhancement: automatic version string generation PR: 252737 Submitted by: Fabian Keil <fk@fabiankeil.de>
Notes
Notes: svn path=/head/; revision=561737
Diffstat (limited to 'misc/mbuffer')
-rw-r--r--misc/mbuffer/Makefile2
-rw-r--r--misc/mbuffer/distinfo6
-rw-r--r--misc/mbuffer/files/patch-Makefile.in31
-rw-r--r--misc/mbuffer/files/patch-configure184
4 files changed, 93 insertions, 130 deletions
diff --git a/misc/mbuffer/Makefile b/misc/mbuffer/Makefile
index c8a74b912bac..bf4402304367 100644
--- a/misc/mbuffer/Makefile
+++ b/misc/mbuffer/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mbuffer
-PORTVERSION= 20200505
+PORTVERSION= 20200929
CATEGORIES= misc
MASTER_SITES= http://www.maier-komor.de/software/mbuffer/
diff --git a/misc/mbuffer/distinfo b/misc/mbuffer/distinfo
index e67b03f683cb..5320bd81e614 100644
--- a/misc/mbuffer/distinfo
+++ b/misc/mbuffer/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1588997358
-SHA256 (mbuffer-20200505.tgz) = cc046183149e51814c23b9f83fd748cc1625a88ee128651ea500aa7bd5f01f0b
-SIZE (mbuffer-20200505.tgz) = 146020
+TIMESTAMP = 1608187011
+SHA256 (mbuffer-20200929.tgz) = 53a6e3c14e9a049f18a09840653dd84f18e7ec7560f2dcf2b61c0ab5f0ead4e8
+SIZE (mbuffer-20200929.tgz) = 147855
diff --git a/misc/mbuffer/files/patch-Makefile.in b/misc/mbuffer/files/patch-Makefile.in
index 87500a07920e..a93aabeb1d4a 100644
--- a/misc/mbuffer/files/patch-Makefile.in
+++ b/misc/mbuffer/files/patch-Makefile.in
@@ -1,21 +1,40 @@
---- Makefile.in.orig 2019-07-25 21:31:45 UTC
+--- Makefile.in.orig 2020-09-29 20:57:02 UTC
+++ Makefile.in
-@@ -42,7 +42,7 @@ TAR = @TAR@
+@@ -42,26 +42,19 @@ TAR = @TAR@
TARGET = mbuffer$(EXE)
SOURCES = log.c network.c mbuffer.c hashing.c input.c common.c settings.c globals.c
-OBJECTS = $(SOURCES:%.c=build/%.o)
+-DEPS = $(SOURCES:%.c=build/%.d)
+OBJECTS = $(SOURCES:.c=.o)
TESTTREE = /bin /usr/bin
-@@ -54,9 +54,6 @@ $(OBJECTS): build config.h Makefile
+ .PHONY: clean all distclean install check testcleanup
+
+-all: $(TARGET) idev.so tapetest.so have-af
++all: $(TARGET) idev.so have-af
+
+-$(OBJECTS): config.h Makefile
++$(OBJECTS): config.h version.h Makefile
build:
mkdir build
--
+
-build/%.o: %.c
- $(CC) $(CFLAGS) -c $< -o $@
+-
+-build/%.d: %.c
+- $(CC) -MM -MG -MT $(@:%.d=%.o) $(CFLAGS) $< -o $@
+-
+ always:
+
+ version.h: always
+@@ -195,7 +188,3 @@ tapetest.so: tapetest.c config.h
- $(TARGET): $(OBJECTS)
- $(CC) $(CFLAGS) $(LDFLAGS) $(OBJECTS) $(LIBS) -o $@
+ idev.so: idev.c config.h
+ $(CC) $(CFLAGS) -shared -g -fPIC idev.c -o $@ $(LIBS)
+-
+-$(DEPS): | build
+-
+-include $(DEPS)
diff --git a/misc/mbuffer/files/patch-configure b/misc/mbuffer/files/patch-configure
index 59ed173b3380..4f495b69fd94 100644
--- a/misc/mbuffer/files/patch-configure
+++ b/misc/mbuffer/files/patch-configure
@@ -1,43 +1,42 @@
-Remove objdump and open/read/write/fstat symbol names check. objdump
-is not available on all architectures and the symbol names are
-unlikely to ever change from their visible names on FreeBSD.
+Remove objdump symbol names check. objdump is not available on all
+architectures and the symbol names are unlikely to ever change from
+their visible names on FreeBSD.
---- configure.orig 2020-05-05 17:31:17 UTC
+--- configure.orig 2020-09-29 20:57:02 UTC
+++ configure
-@@ -625,7 +625,6 @@ LIBOBJS
+@@ -625,8 +625,6 @@ LIBOBJS
AUTOCONF
DEBUG
ALLOCA
+-ac_ct_OBJDUMP
-OBJDUMP
AWK
- TAR
MT
-@@ -4394,51 +4393,6 @@ $as_echo "no" >&6; }
- fi
+ CP
+@@ -4649,97 +4647,6 @@ fi
--for ac_prog in objdump gobjdump
+
+-for ac_prog in gobjdump objdump
-do
-- # Extract the first word of "$ac_prog", so it can be a program name with args.
--set dummy $ac_prog; ac_word=$2
+- # Extract the first word of "$target_alias-$ac_prog", so it can be a program name with args.
+-set dummy $target_alias-$ac_prog; ac_word=$2
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
-$as_echo_n "checking for $ac_word... " >&6; }
--if ${ac_cv_path_OBJDUMP+:} false; then :
+-if ${ac_cv_prog_OBJDUMP+:} false; then :
- $as_echo_n "(cached) " >&6
-else
-- case $OBJDUMP in
-- [\\/]* | ?:[\\/]*)
-- ac_cv_path_OBJDUMP="$OBJDUMP" # Let the user override the test with a path.
-- ;;
-- *)
-- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+- if test -n "$OBJDUMP"; then
+- ac_cv_prog_OBJDUMP="$OBJDUMP" # Let the user override the test.
+-else
+-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
-- ac_cv_path_OBJDUMP="$as_dir/$ac_word$ac_exec_ext"
+- ac_cv_prog_OBJDUMP="$target_alias-$ac_prog"
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
@@ -45,10 +44,9 @@ unlikely to ever change from their visible names on FreeBSD.
- done
-IFS=$as_save_IFS
-
-- ;;
--esac
-fi
--OBJDUMP=$ac_cv_path_OBJDUMP
+-fi
+-OBJDUMP=$ac_cv_prog_OBJDUMP
-if test -n "$OBJDUMP"; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $OBJDUMP" >&5
-$as_echo "$OBJDUMP" >&6; }
@@ -60,110 +58,56 @@ unlikely to ever change from their visible names on FreeBSD.
-
- test -n "$OBJDUMP" && break
-done
--
- # Check whether --enable-largefile was given.
- if test "${enable_largefile+set}" = set; then :
- enableval=$enable_largefile;
-@@ -4653,11 +4607,7 @@ fi
-
-
-
-if test -z "$OBJDUMP"; then
-- as_fn_error $? "unable to find objdump" "$LINENO" 5
--fi
-
--
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether to enable assertions" >&5
- $as_echo_n "checking whether to enable assertions... " >&6; }
- # Check whether --enable-assert was given.
-@@ -5673,86 +5623,12 @@ fi
- fi
-
-
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking open() and write() to detect libc names" >&5
--$as_echo_n "checking linking open() and write() to detect libc names... " >&6; }
--ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
--ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
--ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
--ac_compiler_gnu=$ac_cv_c_compiler_gnu
--
--cat confdefs.h - <<_ACEOF >conftest.$ac_ext
--/* end confdefs.h. */
--
--
-- #define _LARGEFILE64_SOURCE
-- #include <unistd.h>
-- #include <fcntl.h>
-- #include <sys/stat.h>
-- int main(int argc, char **argv) {
-- unsigned x;
-- struct stat st;
-- open(*argv,O_RDONLY);
-- fstat(0,&st);
-- read(0,&x,sizeof(x));
-- write(1,"null",4);
-- }
--
--_ACEOF
--if ac_fn_c_try_link "$LINENO"; then :
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: OK" >&5
--$as_echo "OK" >&6; }
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking name of open() in C library" >&5
--$as_echo_n "checking name of open() in C library... " >&6; }
-- libc_open=`$OBJDUMP -T conftest | $AWK '/\*UND\*/ && $NF ~ /^open/ { print $NF }'`
--
- cat >>confdefs.h <<_ACEOF
--#define LIBC_OPEN $libc_open
-+#define LIBC_OPEN open
-+#define LIBC_READ read
-+#define LIBC_WRITE write
-+#define LIBC_FSTAT fstat
- _ACEOF
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $libc_open" >&5
--$as_echo "$libc_open" >&6; }
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking name of read() in C library" >&5
--$as_echo_n "checking name of read() in C library... " >&6; }
-- libc_read=`$OBJDUMP -T conftest | $AWK '/\*UND\*/ && $NF ~ /^read/ { print $NF }'`
--
--cat >>confdefs.h <<_ACEOF
--#define LIBC_READ $libc_read
--_ACEOF
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $libc_read" >&5
--$as_echo "$libc_read" >&6; }
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking name of write() in C library" >&5
--$as_echo_n "checking name of write() in C library... " >&6; }
-- libc_write=`$OBJDUMP -T conftest | $AWK '/\*UND\*/ && $NF ~ /^write/ { print $NF }'`
--
--cat >>confdefs.h <<_ACEOF
--#define LIBC_WRITE $libc_write
--_ACEOF
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $libc_write" >&5
--$as_echo "$libc_write" >&6; }
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking name of fstat() in C library" >&5
--$as_echo_n "checking name of fstat() in C library... " >&6; }
-- libc_fstat=`$OBJDUMP -T conftest | $AWK '/\*UND\*/ && $NF ~ /^fstat/ { print $NF }'`
+- if test "$build" = "$target"; then
+- ac_ct_OBJDUMP=$OBJDUMP
+- for ac_prog in gobjdump objdump
+-do
+- # Extract the first word of "$ac_prog", so it can be a program name with args.
+-set dummy $ac_prog; ac_word=$2
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+-$as_echo_n "checking for $ac_word... " >&6; }
+-if ${ac_cv_prog_ac_ct_OBJDUMP+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- if test -n "$ac_ct_OBJDUMP"; then
+- ac_cv_prog_ac_ct_OBJDUMP="$ac_ct_OBJDUMP" # Let the user override the test.
+-else
+-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_prog_ac_ct_OBJDUMP="$ac_prog"
+- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+- done
+-IFS=$as_save_IFS
-
--cat >>confdefs.h <<_ACEOF
--#define LIBC_FSTAT $libc_fstat
--_ACEOF
+-fi
+-fi
+-ac_ct_OBJDUMP=$ac_cv_prog_ac_ct_OBJDUMP
+-if test -n "$ac_ct_OBJDUMP"; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_ct_OBJDUMP" >&5
+-$as_echo "$ac_ct_OBJDUMP" >&6; }
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-fi
-
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $libc_fstat" >&5
--$as_echo "$libc_fstat" >&6; }
-
--else
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
--$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
--as_fn_error $? "failed to link open/write test
--See \`config.log' for more details" "$LINENO" 5; }
+- test -n "$ac_ct_OBJDUMP" && break
+-done
-
+- OBJDUMP=$ac_ct_OBJDUMP
+- else
+- OBJDUMP=""
+- fi
-fi
--rm -f core conftest.err conftest.$ac_objext \
-- conftest$ac_exeext conftest.$ac_ext