aboutsummaryrefslogtreecommitdiff
path: root/misc/mc-light/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-09-02 12:10:35 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-09-02 12:10:35 +0000
commitea67c48995c9ac3dc99aee7b1814f99854bca653 (patch)
tree766e4aadf0fedd016bf4c3ff2b1402f16a9007c5 /misc/mc-light/Makefile
parent495d7e11423fdb5d9fb050ae8c834f0a89dc98c4 (diff)
downloadports-ea67c48995c9ac3dc99aee7b1814f99854bca653.tar.gz
ports-ea67c48995c9ac3dc99aee7b1814f99854bca653.zip
Notes
Diffstat (limited to 'misc/mc-light/Makefile')
-rw-r--r--misc/mc-light/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/misc/mc-light/Makefile b/misc/mc-light/Makefile
new file mode 100644
index 000000000000..5a2b117a8b69
--- /dev/null
+++ b/misc/mc-light/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: mc-light
+# Date created: 31.08.2004
+# Whom: Roman Y. Bogdanov <sam@brj.pp.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mc-light
+PORTVERSION= 4.1.40.p9
+CATEGORIES= misc shells
+MASTER_SITES= http://mc.linuxinside.com/Releases/
+DISTNAME= mc-${PORTVERSION:S/.p9/-pre9/}
+
+MAINTAINER= sam@brj.pp.ru
+COMMENT= A lightweight Midnight Commander clone
+
+CONFLICTS= mc-4.6*
+
+USE_GMAKE= yes
+USE_GNOME= glib20 pkgconfig gnometarget
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-included-slang \
+ --with-gettext \
+ --with-vfs \
+ --with-netrc \
+ --without-subshell \
+ --without-gpm-mouse \
+ --with-edit
+
+MAN1= mc.1 mcedit.1
+MAN8= mcserv.8
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>