aboutsummaryrefslogtreecommitdiff
path: root/misc/mc-light
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-29 12:42:04 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-29 12:42:04 +0000
commit222461c302e52a3848555e999ecc7a10f98b278e (patch)
tree4fad0f8d9c328a570a49371daf5f0078d7075272 /misc/mc-light
parentb6155c63444b79580e9bd13727472581d1ed66f1 (diff)
Convert to new option framework
Notes
Notes: svn path=/head/; revision=300215
Diffstat (limited to 'misc/mc-light')
-rw-r--r--misc/mc-light/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/misc/mc-light/Makefile b/misc/mc-light/Makefile
index e75c679da0e3..b9c804104263 100644
--- a/misc/mc-light/Makefile
+++ b/misc/mc-light/Makefile
@@ -19,9 +19,9 @@ RUN_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
CONFLICTS= mc-4.7*
-OPTIONS= NLS "Enable gettext support" on \
- SUBSHELL "Build with subshell support (only for bash!)" off \
- MC_IN_MC "Allow run mc inside mc (useful for mcedit)" off
+OPTIONS_DEFINE= NLS SUBSHELL MC_IN_MC
+SUBSHELL_DESC= Build with subshell support (only for bash!)
+MC_IN_MC_DESC= Allow run mc inside mc (useful for mcedit)
USE_GMAKE= yes
USE_ICONV= yes
@@ -37,13 +37,13 @@ CONFIGURE_ARGS+=--with-included-slang \
MAN1= mc.1 mcedit.1
MAN8= mcserv.8
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITH_SUBSHELL)
+.if ${PORT_OPTIONS:MSUBSHELL}
CONFIGURE_ARGS+=--without-subshell
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
@@ -51,7 +51,7 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITH_MC_IN_MC)
+.if ${PORT_OPTIONS:MMC_IN_MC}
CPPFLAGS+= -DMC_IN_MC_ALLOWED
.endif
@@ -60,4 +60,4 @@ post-install:
${CHMOD} 755 ${PREFIX}/share/mc/extfs/${i}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>