aboutsummaryrefslogtreecommitdiff
path: root/misc/mc/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2002-08-11 12:00:46 +0000
committerMax Khon <fjoe@FreeBSD.org>2002-08-11 12:00:46 +0000
commit294062fca63871133606e543f0e0bb034b1eba65 (patch)
tree74424841649966dc9d199387413b8afcbc525434 /misc/mc/Makefile
parent7f274ced92a6efb0e978222c0ca2f171a868c6a0 (diff)
downloadports-294062fca63871133606e543f0e0bb034b1eba65.tar.gz
ports-294062fca63871133606e543f0e0bb034b1eba65.zip
Notes
Diffstat (limited to 'misc/mc/Makefile')
-rw-r--r--misc/mc/Makefile26
1 files changed, 20 insertions, 6 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index 2d593b8d483b..52eb658ae16c 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -5,10 +5,10 @@
# $FreeBSD$
#
-PORTNAME= mc
+PORTNAME?= mc
PORTVERSION= 4.5.55
-PORTREVISION= 3
-CATEGORIES= misc
+PORTREVISION?= 3
+CATEGORIES?= misc
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/mc
@@ -25,21 +25,35 @@ LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
USE_GMAKE= yes
USE_GNOMENG= yes
+.if ${PORTNAME} == "mc"
USE_GNOME= glib12
+.else
+USE_GNOME= gnomeprefix gnomelibs
+.endif
USE_REINPLACE= yes
GNU_CONFIGURE= yes
.if !defined(WITHOUT_SLANG)
-CONFIGURE_ARGS= --with-slang --without-gnome
+CONFIGURE_ARGS= --with-slang
.else
-CONFIGURE_ARGS= --with-ncurses --without-gnome
+CONFIGURE_ARGS= --with-ncurses
.endif
.if !defined(WITHOUT_ICONV)
CONFIGURE_ARGS+=--enable-charset --with-libiconv-prefix=${LOCALBASE}
+PLIST_SUB= CHARSETS=""
+.else
+PLIST_SUB= CHARSETS="@comment "
+.endif
+.if ${PORTNAME} == "mc"
+CONFIGURE_ARGS+=--without-gnome
.endif
-
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+.if ${PORTNAME} == "mc"
+PLIST_SUB+= GNOMEMC="@comment " SHARE_PATH="share"
+.else
+PLIST_SUB+= GNOMEMC="" SHARE_PATH="share/gnome"
+.endif
MAN1= mc.1 mcedit.1