aboutsummaryrefslogtreecommitdiff
path: root/misc/mc/Makefile
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-10-21 21:07:18 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-10-21 21:07:18 +0000
commitf20231016351d45203f2c99c8a227d9db02e46df (patch)
tree90c8dbd5d22bea311fd6fc70abdb0e9052b8ed85 /misc/mc/Makefile
parent472743a1563016633ddc6601c85aeb73830f17a1 (diff)
downloadports-f20231016351d45203f2c99c8a227d9db02e46df.tar.gz
ports-f20231016351d45203f2c99c8a227d9db02e46df.zip
Notes
Diffstat (limited to 'misc/mc/Makefile')
-rw-r--r--misc/mc/Makefile97
1 files changed, 48 insertions, 49 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index d9091151105d..f0c723dca012 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mc
-PORTVERSION= 4.8.8
+PORTVERSION= 4.8.10
PORTREVISION= 0
CATEGORIES= misc shells
MASTER_SITES= http://ftp.osuosl.org/pub/midnightcommander/
@@ -12,82 +12,81 @@ COMMENT= Midnight Commander, a free Norton Commander Clone
LICENSE= GPLv3
-LIB_DEPENDS= ssh2:${PORTSDIR}/security/libssh2
+LIB_DEPENDS= libssh2.so:${PORTSDIR}/security/libssh2
CONFLICTS= mc-light-4*
+USE_XZ= yes
USES= gmake perl5 pkgconfig
USE_GNOME= glib20
-USE_XZ= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ZIP=${UNZIP_CMD} UNZIP=${UNZIP_CMD}
USE_AUTOTOOLS= libtool
-PORTDATA= *
+OPTIONS_DEFINE= DOCS EDITOR ICONV NLS SMB SUBSHELL X11
+
+OPTIONS_SINGLE= SCREEN
+OPTIONS_SINGLE_SCREEN= SLANG NCURSES
-OPTIONS_DEFINE= SLANG ICONV NLS EDIT X11 SUBSHELL SMB
-EDIT_DESC= Build with internal editor
+OPTIONS_DEFAULT= EDITOR ICONV SLANG SMB SUBSHELL X11
+
+EDITOR_DESC= Build with internal editor
SUBSHELL_DESC= Build with subshell support
-OPTIONS_DEFAULT= SLANG ICONV NLS EDIT X11 SUBSHELL SMB
+OPTIONS_SUB= yes
-NO_STAGE= yes
-post-patch:
- ${REINPLACE_CMD} -e 's/SUBDIRS = intl/SUBDIRS =/' ${WRKSRC}/Makefile.in
- ${REINPLACE_CMD} -e 's/saved_CPPFLAGS="-ltermcap/saved_CPPFLAGS="/' ${WRKSRC}/configure
+EDITOR_CONFIGURE_WITH= internal-edit
-.include <bsd.port.options.mk>
+ICONV_USES= iconv
+ICONV_CONFIGURE_ENABLE= charset
-.if ${PORT_OPTIONS:MSMB} && !defined(MINIMAL)
-CONFIGURE_ARGS+=--enable-vfs-smb --with-configdir=${LOCALBASE}/etc\
- --with-codepagedir=${LOCALBASE}/etc/codepages
-.endif
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
-.if ${PORT_OPTIONS:MICONV} && !defined(MINIMAL)
-USES+= iconv
-.else
-CONFIGURE_ARGS+=--disable-charset
-.endif
+SLANG_LIB_DEPENDS= libslang.so:${PORTSDIR}/devel/libslang2
+
+SMB_CONFIGURE_ENABLE= vfs-smb configdir=${LOCALBASE}/etc \
+ codepagedir=${LOCALBASE}/etc/codepages
+
+SUBSHELL_CONFIGURE_WITH= subshell
-.if ! ${PORT_OPTIONS:MNLS} && !defined(MINIMAL)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+X11_CONFIGURE_ENABLE= x
+
+PORTDOCS= *
+
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= AUTHORS NEWS README
+
+DOCSRCDIR2= ${WRKSRC}/doc
+DOCSDIR2= ${DOCSDIR}/doc
+DOC_FILES2= FAQ HACKING MAINTAINERS *.txt TODO
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USES+= gettext
-PLIST_SUB+= NLS=""
-_MANLANG= es hu it pl ru sr
.endif
-.if ! ${PORT_OPTIONS:MX11} && !defined(MINIMAL)
-CONFIGURE_ARGS+=--without-x
-.else
+.if${PORT_OPTIONS:MX11}
USE_XORG= x11 xext
.endif
-.if ! ${PORT_OPTIONS:MEDIT} && !defined(MINIMAL)
-CONFIGURE_ARGS+=--without-edit
-PLIST_SUB+= EDITOR="@comment "
-.else
-PLIST_SUB+= EDITOR=""
-.endif
-
-.if ! ${PORT_OPTIONS:MSLANG} && !defined(MINIMAL)
-CONFIGURE_ARGS+=--with-screen=ncurses
-.else
-LIB_DEPENDS+= slang:${PORTSDIR}/devel/libslang2
+.if ${PORT_OPTIONS:MSLANG}
CONFIGURE_ARGS+=--with-screen=slang --with-slang-includes=${LOCALBASE}/include
.endif
-.if ! ${PORT_OPTIONS:MSUBSHELL} && !defined(MINIMAL)
-CONFIGURE_ARGS+=--without-subshell
+.if ${PORT_OPTIONS:MNCURSES}
+CONFIGURE_ARGS+=--with-screen=ncurses --with-ncurses-includes=${LOCALBASE}/include
.endif
-MAN1= mc.1 mcedit.1 mcview.1
-_MAN1= mc.1
-.for lang in ${_MANLANG}
-_MANPAGES+= ${_MAN1:S%^%${MAN1PREFIX}/man/${lang}/man1/%}
-.endfor
+post-patch:
+ @${REINPLACE_CMD} -e 's|SUBDIRS = intl|SUBDIRS =|' ${WRKSRC}/Makefile.in
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
.include <bsd.port.mk>