aboutsummaryrefslogtreecommitdiff
path: root/misc/mc
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2013-01-26 06:38:17 +0000
committerMax Khon <fjoe@FreeBSD.org>2013-01-26 06:38:17 +0000
commitd6b4b54e357d31c454e9b45a4baa738c30eb17e4 (patch)
treef151a5293cf315e94d0a4f99473a530e6a134d68 /misc/mc
parentaa46cfc802381b56dd8f996ebfbf2a285d0dfe0f (diff)
downloadports-d6b4b54e357d31c454e9b45a4baa738c30eb17e4.tar.gz
ports-d6b4b54e357d31c454e9b45a4baa738c30eb17e4.zip
Notes
Diffstat (limited to 'misc/mc')
-rw-r--r--misc/mc/Makefile2
-rw-r--r--misc/mc/distinfo4
-rw-r--r--misc/mc/files/patch-mc-editor46
-rw-r--r--misc/mc/pkg-plist2
4 files changed, 51 insertions, 3 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index 4be6d15090e5..d1871cbbf937 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mc
-PORTVERSION= 4.8.1.6
+PORTVERSION= 4.8.1.7
PORTREVISION= 0
CATEGORIES= misc shells
MASTER_SITES= http://www.midnight-commander.org/downloads/ \
diff --git a/misc/mc/distinfo b/misc/mc/distinfo
index 9c90938f3d29..e0a82728b6ba 100644
--- a/misc/mc/distinfo
+++ b/misc/mc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mc-4.8.1.6.tar.xz) = 34545890b12c499654878a683c87724459292961d0b1c32eceee3adee5a408e4
-SIZE (mc-4.8.1.6.tar.xz) = 2097020
+SHA256 (mc-4.8.1.7.tar.xz) = ea5340c35735e374eed9b92268e80a12121a8fdf21ec249fef095fe2522faf9c
+SIZE (mc-4.8.1.7.tar.xz) = 2049316
diff --git a/misc/mc/files/patch-mc-editor b/misc/mc/files/patch-mc-editor
new file mode 100644
index 000000000000..1129f4781783
--- /dev/null
+++ b/misc/mc/files/patch-mc-editor
@@ -0,0 +1,46 @@
+Index: src/filemanager/ext.c
+===================================================================
+--- src/filemanager/ext.c (revision 05d220a9c6f31134373e4326608a6d7e9cbb20f1)
++++ src/filemanager/ext.c (revision 529a7ba24c9da9fdb1df939ff0fe35c6d27e65df)
+@@ -637,4 +637,7 @@
+ int have_type = 0; /* Flag used by regex_check_type() */
+
++ if (filename_vpath == NULL)
++ return 0;
++
+ /* Check for the special View:%d parameter */
+ if (strncmp (action, "View:", 5) == 0)
+Index: src/filemanager/midnight.c
+===================================================================
+--- src/filemanager/midnight.c (revision 308237aa11bf34450340574131a9894a1892e997)
++++ src/filemanager/midnight.c (revision 529a7ba24c9da9fdb1df939ff0fe35c6d27e65df)
+@@ -952,9 +952,11 @@
+ case MC_RUN_EDITOR:
+ {
+- vfs_path_t *param_vpath;
+-
+- param_vpath = vfs_path_from_str (mc_run_param0);
+- ret = edit_file (param_vpath, mc_args__edit_start_line);
+- vfs_path_free (param_vpath);
++ vfs_path_t *vpath = NULL;
++
++ if (mc_run_param0 != NULL && *mc_run_param0 != '\0')
++ vpath = vfs_path_from_str (mc_run_param0);
++
++ ret = edit_file (vpath, mc_args__edit_start_line);
++ vfs_path_free (vpath);
+ }
+ break;
+@@ -962,7 +964,9 @@
+ case MC_RUN_VIEWER:
+ {
+- vfs_path_t *vpath;
+-
+- vpath = prepend_cwd_on_local (mc_run_param0);
++ vfs_path_t *vpath = NULL;
++
++ if (mc_run_param0 != NULL && *mc_run_param0 != '\0')
++ vpath = prepend_cwd_on_local (mc_run_param0);
++
+ view_file (vpath, 0, 1);
+ vfs_path_free (vpath);
diff --git a/misc/mc/pkg-plist b/misc/mc/pkg-plist
index 7b27bcc63c0e..cc26788b8fb2 100644
--- a/misc/mc/pkg-plist
+++ b/misc/mc/pkg-plist
@@ -81,10 +81,12 @@ libexec/mc/mc.sh
%%NLS%%share/locale/es/LC_MESSAGES/mc.mo
%%NLS%%share/locale/et/LC_MESSAGES/mc.mo
%%NLS%%share/locale/eu/LC_MESSAGES/mc.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/mc.mo
%%NLS%%share/locale/fi/LC_MESSAGES/mc.mo
%%NLS%%share/locale/fi_FI/LC_MESSAGES/mc.mo
%%NLS%%share/locale/fr/LC_MESSAGES/mc.mo
%%NLS%%share/locale/gl/LC_MESSAGES/mc.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/mc.mo
%%NLS%%share/locale/hu/LC_MESSAGES/mc.mo
%%NLS%%share/locale/ia/LC_MESSAGES/mc.mo
%%NLS%%share/locale/id/LC_MESSAGES/mc.mo