aboutsummaryrefslogtreecommitdiff
path: root/misc/metromap/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-07-05 05:49:59 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-07-05 05:49:59 +0000
commit6313c635c662c01b28b0c33c2bc4fcf4ddc4af31 (patch)
tree549ee61c94546edc8217d1bd94e035942ce1f383 /misc/metromap/Makefile
parent8a2f7b0bd7d1f2b5c215cbf1e39b4d1f9917b1cf (diff)
downloadports-6313c635c662c01b28b0c33c2bc4fcf4ddc4af31.tar.gz
ports-6313c635c662c01b28b0c33c2bc4fcf4ddc4af31.zip
Notes
Diffstat (limited to 'misc/metromap/Makefile')
-rw-r--r--misc/metromap/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/misc/metromap/Makefile b/misc/metromap/Makefile
new file mode 100644
index 000000000000..b0b13f78b318
--- /dev/null
+++ b/misc/metromap/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: metromap
+# Date created: 2005-07-01
+# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= metromap
+PORTVERSION= 0.1.0
+CATEGORIES= misc
+MASTER_SITES= http://metromap.antex.ru/
+
+MAINTAINER= vsevolod@highsecure.ru
+COMMENT= A simple application for finding paths in different subways maps
+
+USE_PYTHON= yes
+USE_GNOME= pygtk2
+USE_BZIP2= yes
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr,${PREFIX},' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's,/usr/bin/python,${SETENV} python,' ${WRKSRC}/metromap.py
+
+.include <bsd.port.mk>