aboutsummaryrefslogtreecommitdiff
path: root/misc/nut
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2003-05-03 22:03:10 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2003-05-03 22:03:10 +0000
commitd242c3d58740609fcd73ebc0bdd3a5c29802fdc3 (patch)
treed7e2d5b4d5075f2ff1a817968165b39d7883a054 /misc/nut
parent5627ce909d1e78af757e2276811fd0c0b10957da (diff)
downloadports-d242c3d58740609fcd73ebc0bdd3a5c29802fdc3.tar.gz
ports-d242c3d58740609fcd73ebc0bdd3a5c29802fdc3.zip
Notes
Diffstat (limited to 'misc/nut')
-rw-r--r--misc/nut/Makefile34
-rw-r--r--misc/nut/distinfo1
-rw-r--r--misc/nut/files/patch-Makefile13
-rw-r--r--misc/nut/pkg-descr14
-rw-r--r--misc/nut/pkg-plist6
5 files changed, 68 insertions, 0 deletions
diff --git a/misc/nut/Makefile b/misc/nut/Makefile
new file mode 100644
index 000000000000..8a42da16ca64
--- /dev/null
+++ b/misc/nut/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: nut
+# Date created: Tue Apr 29 12:45:30 GMT 2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nut
+PORTVERSION= 8.3
+CATEGORIES= misc
+MASTER_SITES= http://www.lafn.org/~av832/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Nut is nutrition software to record what you eat
+
+MAN1= nut.1
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/nut ${PREFIX}/bin/
+ ${MKDIR} ${PREFIX}/etc/nut
+ ${INSTALL_DATA} ${WRKSRC}/raw.data/FOOD_DES.txt ${PREFIX}/etc/nut/
+ ${INSTALL_DATA} ${WRKSRC}/raw.data/NUT_DATA.txt ${PREFIX}/etc/nut/
+ ${INSTALL_DATA} ${WRKSRC}/raw.data/WEIGHT.txt ${PREFIX}/etc/nut/
+ ${INSTALL_DATA} ${WRKSRC}/raw.data/sr15.nut ${PREFIX}/etc/nut/
+ ${INSTALL_MAN} ${WRKSRC}/nut.1 ${PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/misc/nut/distinfo b/misc/nut/distinfo
new file mode 100644
index 000000000000..cb33dfe2e5a4
--- /dev/null
+++ b/misc/nut/distinfo
@@ -0,0 +1 @@
+MD5 (nut-8.3.tar.gz) = d3362e19d29ae3255cd7ea0aeee95646
diff --git a/misc/nut/files/patch-Makefile b/misc/nut/files/patch-Makefile
new file mode 100644
index 000000000000..069527271f9e
--- /dev/null
+++ b/misc/nut/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Tue Apr 29 05:48:48 2003
++++ Makefile Sun May 4 05:50:02 2003
+@@ -1,8 +1,8 @@
+ objects := $(patsubst %.c,%.o,$(wildcard *.c))
+
+-CFLAGS= -O3 -Wall -pedantic -ansi -DNUTDIR=\".nutdb\" -DFOODDIR=\"/usr/local/lib/nut\"
++CFLAGS+= -Wall -pedantic -ansi -DNUTDIR=\".nutdb\" -DFOODDIR=\"%%PREFIX%%/etc/nut\"
+
+-nut: $(objects)
++all: $(objects)
+ gcc ${CFLAGS} -lm -o nut $(objects)
+ strip nut
+
diff --git a/misc/nut/pkg-descr b/misc/nut/pkg-descr
new file mode 100644
index 000000000000..846656d7f8b5
--- /dev/null
+++ b/misc/nut/pkg-descr
@@ -0,0 +1,14 @@
+nut is nutrition software to record what you eat and analyze
+your meals for nutrient composition. The database included is
+the USDA Nutrient Database for Standard Reference, Release 15,
+which contains 6,220 foods and 117 nutrients. This database
+contains values for vitamins, minerals, fats, calories,
+protein, carbohydrates, fiber, etc., and includes the essential
+polyunsaturated fats, Omega-3 and Omega-6. Nutrient levels are
+expressed as a percentage of the Daily Value, the familiar
+standard of food labeling in the United States, but also can be
+fully customized. Recipes can be added, and graphs drawn. The
+program is completely menu-driven and there are no commands to
+learn.
+
+WWW: http://www.lafn.org/~av832/
diff --git a/misc/nut/pkg-plist b/misc/nut/pkg-plist
new file mode 100644
index 000000000000..cd776366ce18
--- /dev/null
+++ b/misc/nut/pkg-plist
@@ -0,0 +1,6 @@
+bin/nut
+etc/nut/FOOD_DES.txt
+etc/nut/NUT_DATA.txt
+etc/nut/WEIGHT.txt
+etc/nut/sr15.nut
+@dirrm etc/nut