aboutsummaryrefslogtreecommitdiff
path: root/misc/openhmd
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-07-13 09:16:55 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-07-13 09:16:55 +0000
commitf071dd1f95a96be9b3e7b1f3655197db867f8228 (patch)
tree286a50f787913d3d1f0249025f94e14f407e81d7 /misc/openhmd
parent5b2cddc113e5c4950dc847329a823b555d337561 (diff)
downloadports-f071dd1f95a96be9b3e7b1f3655197db867f8228.tar.gz
ports-f071dd1f95a96be9b3e7b1f3655197db867f8228.zip
Notes
Diffstat (limited to 'misc/openhmd')
-rw-r--r--misc/openhmd/Makefile9
-rw-r--r--misc/openhmd/distinfo6
-rw-r--r--misc/openhmd/files/patch-CMakeLists.txt16
3 files changed, 8 insertions, 23 deletions
diff --git a/misc/openhmd/Makefile b/misc/openhmd/Makefile
index 7944c6c2ac3e..652f7ebc5e03 100644
--- a/misc/openhmd/Makefile
+++ b/misc/openhmd/Makefile
@@ -1,9 +1,7 @@
# $FreeBSD$
PORTNAME= OpenHMD
-DISTVERSION= 0.2.0-215
-PORTREVISION= 1
-DISTVERSIONSUFFIX= -g6f91c10
+DISTVERSION= 0.3.0
CATEGORIES= misc
MASTER_SITES= CHEESESHOP
@@ -19,9 +17,12 @@ USES= cmake compiler:c++11-lang
USE_GITHUB= yes
USE_LDCONFIG= yes
+CMAKE_ON= BUILD_SHARED_LIBS
+
PLIST_FILES= include/openhmd.h \
lib/libopenhmd.so \
lib/libopenhmd.so.0 \
- lib/libopenhmd.so.0.1.0
+ lib/libopenhmd.so.0.1.0 \
+ libdata/pkgconfig/openhmd.pc
.include <bsd.port.mk>
diff --git a/misc/openhmd/distinfo b/misc/openhmd/distinfo
index 0c9c39156162..2870ec4507cd 100644
--- a/misc/openhmd/distinfo
+++ b/misc/openhmd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1532595494
-SHA256 (OpenHMD-OpenHMD-0.2.0-215-g6f91c10_GH0.tar.gz) = 725f363ae2004d32594ef5b2877937718001e60908ff5dea4322bffaf4cdfc05
-SIZE (OpenHMD-OpenHMD-0.2.0-215-g6f91c10_GH0.tar.gz) = 116599
+TIMESTAMP = 1563008631
+SHA256 (OpenHMD-OpenHMD-0.3.0_GH0.tar.gz) = ec5c97ab456046a8aef3cde6d59e474603af398f1d064a66e364fe3c0b26a0fa
+SIZE (OpenHMD-OpenHMD-0.3.0_GH0.tar.gz) = 128041
diff --git a/misc/openhmd/files/patch-CMakeLists.txt b/misc/openhmd/files/patch-CMakeLists.txt
deleted file mode 100644
index 7862c1fb8e8c..000000000000
--- a/misc/openhmd/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,16 +0,0 @@
---- CMakeLists.txt.orig 2018-07-11 16:24:43 UTC
-+++ CMakeLists.txt
-@@ -150,10 +150,10 @@ endif (UNIX)
- link_libraries(${LIBS})
- add_library(openhmd-shared SHARED ${openhmd_source_files})
- SET_TARGET_PROPERTIES(openhmd-shared PROPERTIES OUTPUT_NAME openhmd CLEAN_DIRECT_OUTPUT 1 VERSION ${LIB_VERSION_STRING} SOVERSION ${LIB_VERSION_MAJOR})
--add_library(openhmd-static STATIC ${openhmd_source_files})
--SET_TARGET_PROPERTIES(openhmd-static PROPERTIES OUTPUT_NAME openhmd CLEAN_DIRECT_OUTPUT 1)
-+#add_library(openhmd-static STATIC ${openhmd_source_files})
-+#SET_TARGET_PROPERTIES(openhmd-static PROPERTIES OUTPUT_NAME openhmd CLEAN_DIRECT_OUTPUT 1)
- set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_CURRENT_DIR}/)
-
- #install properties
--install (TARGETS openhmd-shared openhmd-static DESTINATION lib)
-+install (TARGETS openhmd-shared DESTINATION lib)
- install (FILES include/openhmd.h DESTINATION include)