aboutsummaryrefslogtreecommitdiff
path: root/misc/orville-write/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-12-25 16:05:59 +0000
committerSteve Price <steve@FreeBSD.org>1999-12-25 16:05:59 +0000
commit8ab5693f64672c32b89732f7ea3fc548406372e6 (patch)
treefb23288a3fb4d7bcfff01e24e890a1436a90262c /misc/orville-write/Makefile
parent09a54cfe21bd4251f615dbe44f590588a06e150a (diff)
downloadports-8ab5693f64672c32b89732f7ea3fc548406372e6.tar.gz
ports-8ab5693f64672c32b89732f7ea3fc548406372e6.zip
Notes
Diffstat (limited to 'misc/orville-write/Makefile')
-rw-r--r--misc/orville-write/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/misc/orville-write/Makefile b/misc/orville-write/Makefile
new file mode 100644
index 000000000000..1de9f188da72
--- /dev/null
+++ b/misc/orville-write/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: orville-write
+# Version required: 2.41a
+# Date created: 4 December 1999
+# Whom: James Howard <howardj@wam.umd.edu>
+#
+# $FreeBSD$
+#
+
+DISTNAME= orville-write-2.41a
+CATEGORIES= misc
+MASTER_SITES= http://www.wwnet.net/~janc/software/
+
+MAINTAINER= howardjp@wam.umd.edu
+
+MAN1= amin.1 helpers.1 huh.1 mesg.1 write.1
+
+post-extract:
+ @(cd ${WRKSRC}; ${RM} -f .depend)
+
+post-patch:
+ @${PERL} -pi -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_SCRIPT} -g tty -o root -m 6711 ${WRKSRC}/write ${PREFIX}/bin
+ ${INSTALL_SCRIPT} -o root -m 4711 ${WRKSRC}/mesg ${PREFIX}/bin
+ ${INSTALL_SCRIPT} -o root -m 4711 ${WRKSRC}/amin ${PREFIX}/bin
+ ${INSTALL_SCRIPT} -o root -m 4711 ${WRKSRC}/huh ${PREFIX}/bin
+ ${INSTALL_SCRIPT} -o root -m 4711 ${WRKSRC}/helpers ${PREFIX}/bin
+ ${INSTALL_SCRIPT} -g tty -o root -m 6711 ${WRKSRC}/write ${PREFIX}/bin/tel
+ ${INSTALL_SCRIPT} -g tty -o root -m 6711 ${WRKSRC}/write ${PREFIX}/bin/chat
+ ${TOUCH} /var/run/wrttmp
+ ${TOUCH} /var/run/wrthist
+ ${TOUCH} /var/log/writelog
+ ${INSTALL_SCRIPT} ${WRKSRC}/wrttab ${PREFIX}/etc/wrttab
+.for f in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/${f} ${PREFIX}/man/man1/
+.endfor
+
+.include <bsd.port.mk>