aboutsummaryrefslogtreecommitdiff
path: root/misc/orville-write
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-10-13 19:18:53 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-10-13 19:18:53 +0000
commit1fb2a4c12d8828f93b24eef313aefddb3a42604b (patch)
treee1e1add2d4a5b672aeb33662dfcede47b65f440e /misc/orville-write
parent9b6b5c9b90dbf2451947f63afca8c53b3f079181 (diff)
downloadports-1fb2a4c12d8828f93b24eef313aefddb3a42604b.tar.gz
ports-1fb2a4c12d8828f93b24eef313aefddb3a42604b.zip
Notes
Diffstat (limited to 'misc/orville-write')
-rw-r--r--misc/orville-write/Makefile26
-rw-r--r--misc/orville-write/distinfo4
-rw-r--r--misc/orville-write/files/patch-Makefile.in18
-rw-r--r--misc/orville-write/files/patch-write.h10
-rw-r--r--misc/orville-write/files/patch-wrt_him.c71
-rw-r--r--misc/orville-write/files/patch-wrt_main.c73
6 files changed, 25 insertions, 177 deletions
diff --git a/misc/orville-write/Makefile b/misc/orville-write/Makefile
index 2a5b744d4780..729151b35836 100644
--- a/misc/orville-write/Makefile
+++ b/misc/orville-write/Makefile
@@ -6,15 +6,35 @@
#
PORTNAME= orville-write
-PORTVERSION= 2.54
+PORTVERSION= 2.55
CATEGORIES= misc
MASTER_SITES= http://unixpapa.com/software/
MAINTAINER= ports@FreeBSD.org
COMMENT= Advanced replacement for write/mesg
-MAN1= amin.1 helpers.1 huh.1 mesg.1 write.1
-
GNU_CONFIGURE= yes
+MAN1= amin.1 helpers.1 huh.1 mesg.1 write.1
+
+do-install:
+.for i in amin helpers huh mesg
+ ${INSTALL_PROGRAM} -m 4711 ${WRKSRC}/${i} ${PREFIX}/bin
+.endfor
+.for i in write
+ ${INSTALL_PROGRAM} -m 6711 ${WRKSRC}/${i} ${PREFIX}/bin
+.endfor
+.for i in jot tel telegram
+ ${LN} -sf write ${PREFIX}/bin/${i}
+.endfor
+.for i in orville.conf
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/etc
+.endfor
+.for i in wrthist wrttmp
+ ${INSTALL_DATA} -m 600 /dev/null ${PREFIX}/etc/${i}
+.endfor
+.for i in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/${i} ${MANPREFIX}/man/man1
+.endfor
+
.include <bsd.port.mk>
diff --git a/misc/orville-write/distinfo b/misc/orville-write/distinfo
index e0f816076735..e27ff37272c4 100644
--- a/misc/orville-write/distinfo
+++ b/misc/orville-write/distinfo
@@ -1,2 +1,2 @@
-MD5 (orville-write-2.54.tar.gz) = 69653357420473f506849b108647c07b
-SIZE (orville-write-2.54.tar.gz) = 76319
+MD5 (orville-write-2.55.tar.gz) = e89b238d935002e69ce5c0f2a4549139
+SIZE (orville-write-2.55.tar.gz) = 77451
diff --git a/misc/orville-write/files/patch-Makefile.in b/misc/orville-write/files/patch-Makefile.in
deleted file mode 100644
index 0e47e1a629a0..000000000000
--- a/misc/orville-write/files/patch-Makefile.in
+++ /dev/null
@@ -1,18 +0,0 @@
---- Makefile.in.old Fri Jan 12 16:54:53 2001
-+++ Makefile.in Fri Jan 12 16:55:56 2001
-@@ -65,11 +65,11 @@
-
- install: write mesg amin huh helpers
- ./install-sh -d $(bindir)
-- $(INSTALL) -o root -g $(groupid) -m 6711 write $(bindir)
-+ $(INSTALL) -m 6711 write $(bindir)
- -(cd $(bindir); $(LN) write jot; $(LN) write tel; $(LN) write telegram)
-- $(INSTALL) -o root -m 4711 mesg $(bindir)
-- $(INSTALL) -o root -m 4711 amin $(bindir)
-- $(INSTALL) -o root -m 4711 huh $(bindir)
-+ $(INSTALL) -m 4711 mesg $(bindir)
-+ $(INSTALL) -m 4711 amin $(bindir)
-+ $(INSTALL) -m 4711 huh $(bindir)
- $(INSTALL) -m 4711 helpers $(bindir)
- ./install-sh -d $(sysconfdir)
- $(INSTALL) -m 644 orville.conf $(sysconfdir)
diff --git a/misc/orville-write/files/patch-write.h b/misc/orville-write/files/patch-write.h
deleted file mode 100644
index f3f4a66ad249..000000000000
--- a/misc/orville-write/files/patch-write.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- write.h.orig Sun Sep 7 22:55:03 2003
-+++ write.h Sun Sep 7 22:56:20 2003
-@@ -34,6 +34,7 @@
-
- /* wrt_main.c functions */
- void done(int code);
-+void _log(char *outcome);
-
- /* wrt_me.c functions */
- void find_me(void);
diff --git a/misc/orville-write/files/patch-wrt_him.c b/misc/orville-write/files/patch-wrt_him.c
deleted file mode 100644
index 7a04c15cc3f0..000000000000
--- a/misc/orville-write/files/patch-wrt_him.c
+++ /dev/null
@@ -1,71 +0,0 @@
---- wrt_him.c.orig Sun Sep 7 22:57:06 2003
-+++ wrt_him.c Sun Sep 7 22:57:14 2003
-@@ -141,7 +141,7 @@
- if (mywrt.wrt_last[0] == '\0')
- {
- printf("No previous write or telegram. Can't repeat\n");
-- log("FAIL: no previous");
-+ _log("FAIL: no previous");
- done(1);
- }
- strncpy(hisname,mywrt.wrt_last,UT_NAMESIZE);
-@@ -170,13 +170,13 @@
- else if (rc == 1)
- {
- printf("No such tty\n");
-- log("FAIL: no such tty");
-+ _log("FAIL: no such tty");
- done(1);
- }
- else
- {
- printf("%s not logged onto %s\n",hisname,histty);
-- log("FAIL: not on tty");
-+ _log("FAIL: not on tty");
- done(1);
- }
- }
-@@ -253,7 +253,7 @@
- /* didn't find any matches, trouble */
- printf("%s is not logged on\n",hisname);
- {
-- log("FAIL: not on");
-+ _log("FAIL: not on");
- done(1);
- }
- }
-@@ -300,7 +300,7 @@
- if (*ut->ut_name == '\0')
- {
- printf("No one logged onto %s\n",histty);
-- log("FAIL: empty tty");
-+ _log("FAIL: empty tty");
- done(1);
- }
- strncpy(hisname, ut->ut_name, UT_NAMESIZE);
-@@ -344,7 +344,7 @@
- }
-
- printf("You are not being written\n");
-- log("FAIL: not written");
-+ _log("FAIL: not written");
- done(0);
- }
-
-@@ -444,14 +444,14 @@
- {
- printf("Sorry, no helpers are available right now.\n");
- if (f_nohelp) type_help(f_nohelp);
-- log("FAIL: no helpers");
-+ _log("FAIL: no helpers");
- }
- else
- {
- printf("Sorry, all helpers currently available are busy.\n");
- if (f_nohelp) type_help(f_nohelp);
- printf("Try again later...\n");
-- log("FAIL: help busy");
-+ _log("FAIL: help busy");
- }
- done(0);
- }
diff --git a/misc/orville-write/files/patch-wrt_main.c b/misc/orville-write/files/patch-wrt_main.c
deleted file mode 100644
index e62e471411fb..000000000000
--- a/misc/orville-write/files/patch-wrt_main.c
+++ /dev/null
@@ -1,73 +0,0 @@
---- wrt_main.c.orig Sun Sep 7 22:56:27 2003
-+++ wrt_main.c Sun Sep 7 22:56:47 2003
-@@ -69,7 +69,7 @@
-
- bool readyn(void);
- void type_help(char *file);
--void log(char *outcome);
-+void _log(char *outcome);
-
-
- main(int argc, char **argv)
-@@ -145,7 +145,7 @@
- {
- if (telegram) putchar('\n');
- printf("Permission denied: %s is not accepting messages\n",hisname);
-- log("FAIL: denied");
-+ _log("FAIL: denied");
- done(1);
- }
-
-@@ -176,7 +176,7 @@
- fflush(stdout);
- if (!readyn())
- {
-- log("ABANDON: interupting");
-+ _log("ABANDON: interupting");
- done(1);
- }
- }
-@@ -193,14 +193,14 @@
- if (!(hiswrt.wrt_telpref & (TELPREF_WRITE|TELPREF_TEL)) )
- {
- if (!no_switch) printf("Try the \042talk\042 command.\n");
-- log("FAIL: can't switch - talk only");
-+ _log("FAIL: can't switch - talk only");
- done(1);
- }
- if (no_switch || file_input)
- {
- if (!no_switch) printf("Try the \042write\042 command "
- "(with no input redirection).\n");
-- log("FAIL: can't switch");
-+ _log("FAIL: can't switch");
- done(1);
- }
- else
-@@ -211,7 +211,7 @@
- {
- if (!am_root)
- {
-- log("ABANDON: won't switch");
-+ _log("ABANDON: won't switch");
- done(1);
- }
- }
-@@ -273,7 +273,7 @@
- open_record();
-
- open_hist();
-- log(rec_only?"POSTPONED":"OK");
-+ _log(rec_only?"POSTPONED":"OK");
-
- /* Now that his terminal and the wrttmp file are open, abandon superuser */
- setuid(getuid());
-@@ -366,7 +366,7 @@
- /* LOG - This logs a write execution.
- */
-
--void log(char *outcome)
-+void _log(char *outcome)
- {
- FILE *fp;
- time_t tock;