aboutsummaryrefslogtreecommitdiff
path: root/misc/ossp-uuid/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-03-06 11:48:10 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-03-06 11:48:10 +0000
commit5b63de467e6b4bfe0fd2f41c9620b1fa8575f14d (patch)
tree8063a69dc7cf43527c5d7f1a29654aa0286b67cc /misc/ossp-uuid/Makefile
parenta6848ff6a376e87f7e4ea0326bfabf82a5f480f3 (diff)
downloadports-5b63de467e6b4bfe0fd2f41c9620b1fa8575f14d.tar.gz
ports-5b63de467e6b4bfe0fd2f41c9620b1fa8575f14d.zip
Notes
Diffstat (limited to 'misc/ossp-uuid/Makefile')
-rw-r--r--misc/ossp-uuid/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/misc/ossp-uuid/Makefile b/misc/ossp-uuid/Makefile
index 40a42cd0694f..9522f9985e47 100644
--- a/misc/ossp-uuid/Makefile
+++ b/misc/ossp-uuid/Makefile
@@ -3,7 +3,7 @@
PORTNAME= uuid
PORTVERSION= 1.6.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= misc devel
MASTER_SITES= OSSP/lib/${PORTNAME}
PKGNAMEPREFIX= ossp-
@@ -19,12 +19,15 @@ CONFIGURE_ARGS= --with-cxx \
.if defined(SLAVEPORT) && ${SLAVEPORT}=="perl"
PKGNAMEPREFIX= p5-OSSP-
-.else
-CONFLICTS= e2fsprogs-libuuid-[0-9]*
.endif
regression-test: test
+pre-patch:
+### Fixes lib conflicts with misc/e2fsprogs-libuuid ###
+ ${REINPLACE_CMD} 's/libuuid.la/libossp-uuid.la/ ; s/libuuid++.la/libossp-uuid++.la/' \
+ ${WRKDIR}/${DISTNAME}/Makefile.in
+
test: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS} check)