aboutsummaryrefslogtreecommitdiff
path: root/misc/ossp-uuid/Makefile
diff options
context:
space:
mode:
authorRalf S. Engelschall <rse@FreeBSD.org>2004-11-09 19:44:14 +0000
committerRalf S. Engelschall <rse@FreeBSD.org>2004-11-09 19:44:14 +0000
commitd0deb1258a1381cf7258faeb347c195391015dff (patch)
treeaee0e1beae2fe6a1eed412e24ad7a2fcff1ed7b4 /misc/ossp-uuid/Makefile
parent5a935776860da4d80607ed559c69db3d176a8c22 (diff)
downloadports-d0deb1258a1381cf7258faeb347c195391015dff.tar.gz
ports-d0deb1258a1381cf7258faeb347c195391015dff.zip
Notes
Diffstat (limited to 'misc/ossp-uuid/Makefile')
-rw-r--r--misc/ossp-uuid/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/misc/ossp-uuid/Makefile b/misc/ossp-uuid/Makefile
index 9f4c8327b300..117b8c41563b 100644
--- a/misc/ossp-uuid/Makefile
+++ b/misc/ossp-uuid/Makefile
@@ -13,7 +13,7 @@ MASTER_SITE_SUBDIR= lib/${PORTNAME}
PKGNAMEPREFIX= ossp-
MAINTAINER= ports@FreeBSD.org
-COMMENT= An ISO-C & Perl API and CLI for generating Universally Unique Identifiers (UUID)
+COMMENT= ISO-C & Perl API and CLI for generating Universally Unique Identifiers
CONFLICTS= e2fsprogs-[0-9]*
@@ -24,7 +24,7 @@ CONFIGURE_ARGS+= --disable-shared --enable-static
MAN1= uuid-config.1 uuid.1
MAN3= uuid.3
-.if !defined(WITHOUT_PERL)
+.if defined(WITH_PERL)
USE_PERL5= yes
CONFIGURE_ENV+= PERL=${PERL5}
CONFIGURE_ARGS+= --with-perl
@@ -38,4 +38,10 @@ PLIST_SUB+= WITH_PERL='@comment '
test:
cd ${WRKSRC}; ${MAKE} check
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PERL) && ${PERL_LEVEL} < 500800
+IGNORE= supports Perl 5.8.0 or above only
+.endif
+
+.include <bsd.port.post.mk>